Form

Form++用户手册

欢迎使用Form++用户手册。

您可以通过以下几种方法去获取手册中的信息：

  • 全部的内容分成章节显示；

  • 点击下面各章节的名字可以直接到各章详细内容。每章都有一个相关内容的目录；

  • 表格，图形和例子；

  • 主题目录。

章节

    1 : Form++ 简介

    2: 快速教程

    3: 开始使用Form++

    4 : 产品介绍

    5 : 核心类

    6: 组件

    7: 命令

    8 : 属性

    9: 对话框

    10: 窗口

    11:箭头

    12: Form++示例

    13: 联系UCanCode

  • top

    •


s

首 页

UCanCode主页

下 载

联 系

感谢您使用UCanCode Form++

为了扩展MFC的功能，Form++对Windows GDI作了一层抽象。这一层屏蔽了底层的GDI细节使得我们可以集中精力作应用设计。因为Form++类库扩展了MFC类库，您可以将我们的Form++资源整合到您的Visual C++工程里并实现无缝连接。然而，这并没有排除您对Form++类的功能进行定制。

Form++类库在以下方面对MFC类库作了增强：封装了Windows GDI API，支持交互图形，支持高级绘制如排版、复制、定制大小。

你可以使用Form++快速而有效地开发任何包含图形对象的应用。


s

首 页

UCanCode主页

下 载

联 系

使用Form++的预备知识

为了有效地使用Form++，你需要先掌握C++和微软基础类库(MFC)。对Windows的图形设备接口熟悉也很有帮助，但这不是必需的。

若要了解更多这方面的信息，我们建议你阅读以下文章：

MFC / C++ Links

CodeGuru | 一个包括包括很多MFC示例代码和文章的大型网站。 也有讨论栏。
CodeProject | 一个可以和CodeGuru类型的网站, 也有许多示例代码、文章和讨论栏。
microsoft.public.vc.language | Microsoft's VC++ 新闻组。
microsoft.public.vc.mfc | Microsoft's MFC 新闻组。
comp.os.ms-windows.programmer.tools.mfc | MFC 公共新闻组。
MFC mailing list | MFC 邮件列表。最近被微软接管。 使用订户姓名中的第一个姓作为消息的正文。
Microsofts VC++ page | Microsoft's VC++主页。
Win32 Foundation Classes | Sam Blackburn的MFC类集合。
Microsoft Systems Journal | 包括许多杂志的源代码。
MSDN Online | 微软最新的开发动态。
Microsoft Knowledge Base | 微软的完整知识库。
The MFC professional | 所有与MFC有关的内容集合。
Visual C++ Developer | 在线Contains a sample issue online.
Relisoft Software | Win32杂志, C++源程序和免费程序。
Interface Technologies | 包含一些编程以及与计算机有关的主题，例如Visual C++, MFC, and Windows NT
BrowseLC Project | 提供2个可以在Windows列表控件中扩展类的类库。
MFC Progammers Resources | 一个致力于MFC的网站，里面有许多网上与MFC有关的链结。
Developers.Net | 开发者的使用服务引擎。
mfcexperts.listbot.com | 另一个MFC邮件列表。
program.solobox.com | 编程资源中心。
www.codecranker.com | 一个针对开发的网站。
www.codepile.com | 另一个全面的开发网站。
www.parashift.com/c++-faq-lite/ | C++常见问题解答。 对你经常碰到的问题有很好的解答。


s

首 页

UCanCode主页

下 载

联 系

Form++的特点

单页面应用程序示例:

多页面应用程序示例：

多属性页面应用程序示例：

Form++ 类库是一个健壮的，有丰富特色的类库。它支持：

  • 单页面、多页面、多属性页面的应用程序

  • 拖放组件

  • 用户自定义属性

  • 移动组件

  • 定制组件大小

  • 编排，排序组件

  • 水平和垂直刻度尺

  • 网格，网格对齐

  • 打印或者输出到图形

  • 定制背景组件大小

  • 无限的undo/redo

  • 单行和多行文本，双击编辑文本

  • Microsoft Visio风格打印页眉和页脚编辑

  • Microsoft Visio风格工具盒

  • Office XP风格颜色选择器

  • Office 2000风格填充效果

  • 放大、缩小和正常模式

  • 下拉颜色、线型、线宽箭头选择器

  • 使用Form++ Library add-in，不写一行代码就可以很轻松的生成一个基于表格的应用程序。

Form++ 类库包括全部源代码，无须运行时许可费用 。

top


s

首 页

UCanCode主页

下 载

联 系

运行环境需求

Form++类库与Visual C++最新发行的32位类库兼容，包括：

  • Visual C++ 5.0
  • Visual C++ 6.0

Form++支持以下操作系统：

  • Windows 2000

  • Windows 98

  • Windows 95

  • Windows NT 3.5 or later


s

首 页

UCanCode主页

下 载

联 系

技术支持

1.在与我们的技术支持取得联系之前，请先注册到我们的支持系统

在第一次与我们的技术支持取得联系之，您必须到我们的支持系统注。注册请到 ucancode software 。

注册以后您就可以获得技术支持。

在提出技术支持需求前，您可以先到我们的在线 知识库寻求支持。大多数情况下，您的问题在我们的知识库中已有解答。我们对很多的常见问题进行回答以给我们的客户最大的方便。

2 怎样联系技术支持

对 Form++ 类库的技术支持是通过我们的公司网站发布的。请访问 ucancode support去阅读知识库，在线支持技术支持表格，升级下载或者和我们联系。如果您还有困难请和我们email联系。


s

首 页

UCanCode主页

下 载

联 系

Form++类库提供的文档

为了帮助你开始使用Form++，UCanCode提供了一套完整的各种格式的文档供你使用。

  • 用户手册 - 用户手册提供Form++类库的详细介绍。其中有类库的特点功能介绍和教程以帮助我们的新客户快速的学会创建 Form++应用程序。
    (..\UCanCode.Net Software\Form++ Library\Doc\fouser.chm) or(..\UCanCode.Net Software\Form++ Library\Doc\userguide.pdf)
  • 类库手册 - 类库手册提供了Form++类库中类的详细信息和所用的方法介绍。
    (..\UCanCode.Net Software\Form++ Library\Doc\fo4.chm)
  • 示例 - 随Form++产品打包了数个例子程序，示范如何使用类库。

(..\UCanCode.Net Software\Form++ Library\Samples\*.dsw)

  • 知识库 - 知识库是提供常见问题的解决方法的一种在线资源。

注意:文档包括以下格式：text (.txt), htmlhelp (.chm)和portable document format (.pdf). 若要阅读.pdf文件，你必须用Acrobat Reader打开它。你可以从Adobe公司(www.adobe.com)网站上免费下载。若要阅读.chm文件，你必须安装Internet Explorer 3.02以上版本或者是HTML Help Installation和升级包 (hhupd.exe) ，如果你使用的是Visual C++ 5.0或更早版本的话。Internet Explorer可以从Microsoft网站上(www.microsoft.com)免费下载。


s

首 页

UCanCode主页

下 载

联 系

在线资源

在我们的互联网上有UCanCode知识库：http://www.ucancode.net


新增功能

首 页

UCanCode主页

下 载

联 系

Form++4.0新增功能

  • 新增23个绘图组件

  • 新增一个超链接组件并且可以定制其属性

  • 支持对组件的分组和取消分组

  • 支持组件旋转和翻转

  • 可以改变图形的顶点位置

  • 支持插入 .wmf 和.emf文件

  • 增加设计/运行模式的选择

  • 增加图形方式填充组件

  • Office XP风格

  • 支持放大、缩小和正常三种模式


s

首 页

UCanCode主页

下 载

联 系

概述

下面的教程将教你如何创建简单的Form++应用程序。特别的，教程将描述：

  1. 如何使用Visual C++ AppWizard 创建一个简单应用程序

  2. 如何使用Form++ Library add-in创建类

  3. 如何在你的应用程序中增加绘图工具栏

  4. 如何在你的应用程序中增加格式组件工具栏

  5. 如何在你的应用程序中增加Form++命令到菜单中

以下的教程使用 Visual C++ 6.0 创建。如果您使用 Visual C++的其他版本，您可能需要做一些改动。

注意：本指南默认你已经建立了Form++ Library的DLL链接。


s

首 页

UCanCode主页

下 载

联 系

运行Visual C++ AppWizard

首先，我们用Visual C++ AppWizard基本应用程序。使用Visual C++ AppWizard，你可以集成MFC应用到你的新工程中。运行AppWizard并完成以下步骤：

  1. 打开Developer Studio从菜单File选择New新建一个工程

  2. 从工程类型列表中选择Form++ Library Application Wizard并在工程名输入框中输入Test1。然后单击OK。

3.在下一页中选择Multiple Document。确认Document/ View Architecture选中，并且语言类型为English (United States)。然后单击NEXT。

4.选择不支持数据库，单击Next。

5.选中支持ActiveX Controls ，单击Next。

6.选中以下特点，单击Next。

  • Docking Toolbar

  • Initial Status Bar

  • Printing and Print Preview

  • 3D Controls

7.选中以下风格：

  • Consists of standard MFC

  • Supports source file comments

  • Uses MFC as a shared DLL

然后单击Next。

8.这一页显示所继承的基类以及相应的文件名。确认后按 Finish。

9.这一页所包含的选项是单独属于Form++ Library的。这一页允许你设置Form++ Library应用程序的特点。选择以下选项后单击Next。

  • Ruler
  • Color Palette
  • ToolBox
  • Format Bar
  • Draw Bar
  • MultiPage

10.在AppWizard生成工程后，从Build菜单中选择Rebuild All进行一个完整的编译。然后执行应用程序。执行完毕后，如下图：

11.打开"..\Test1\Debug" 文件夹建立一个新的子文件夹"..\Test1\Debug\Components"。将Basic Shapes.trs Forms Shapes.trs index.dat 3个文件从"..\UCanCode.Net Software\Prebuild\Components\"复制到新建的文件夹中去。再执行应用程序，就应该如下图：

top


s

首 页

UCanCode主页

下 载

联 系

使用Form++ Library add-in生成类

如果你不想用Form++ Library Application Wizard新建应用程序，跟我去手工生成它吧！首先，用MFC Appwizard(exe)新建一个单文档的工程。（注意：工程名为TestSDI)。然后让我们一起用Form++ Library add-in来生成类，并用生成的类来代替原来的类。在这一节中，你将学会：

  • 安装Form++ Library add-in
  • 运行Form++ Library add-in

安装Form++ Library add-in

1.你可以复制FormAddIn.dll到任意文件夹。但是如果你将这个文件复制到Addins文件夹中（在msdev.exe文件所在文件夹的旁边），那么Visual Studio在下次启动时将自动导入这个文件。

2.启动Visual Studio后，在Tools菜单中选择定制命令。定制对话框如下：

3.在定制对话框中，选择Add-ins and Marco Files属性页。如果你将FormAddIn.dll文件复制到Addins文件夹中了，那么在这里就会显示出来，否则你可以用Browse按钮来查找DLL文件。

4.一旦DLL文件在Visual Studio中被记录了的话，从列表中选中该按钮以让它显示出来。

至此安装过程完成了。现在你就可以使用add-ins工具按钮了。

运行Form++ Library add-in

单击你刚才添加的Form++ Library add-in按钮，将出现下面对话框：

在这里你可以选择基类和你要生成的类的名字。当你完成这些后，单击OK。然后这些类将会被生成，并且对应的文件也将插入到Visual Studio的工程中去。

当然，为了完成工程，你还要做一些其他的工作。

1.包含Form++头文件。打开stdafx.h文件，在接近文件尾的位置增加以下行：

#include "fo.h"

2.现在增加Form++资源。打开View菜单选择Resource Includes。

  • 在只读符号指示框，填入以下一行：

    #include "fores.h"

  • 在 Compile-time 指示框，填入以下一行：

    #include "fores.rc"

  • 按 OK，弹出一个警告对话框，按 OK。

3.如果没有设置Visual C++ IDE的搜索路径，按这里开始。

4.现在增加对OLE拖放的支持。如果要加入对OLE拖放的支持，必须对OLE类库初始化。在方法InitInstance() 开始处，必须有以下代码：
FOInit();
if (!AfxOleInit())
{
          AfxMessageBox(IDP_OLE_INIT_FAILED);
          return FALSE;
}

5.从Build 选择Rebuild All。然后运行应用程序，显示如下：

top


s

首 页

UCanCode主页

下 载

联 系

绘制组件工具条

  1. Form++资源中包括两种工具条：命令和组件；它们具有不同的功能：

    Drawing Toolbar | IDR_FO_DRAWCOMPBAR
    Command Toolbar | IDR_FO_FORMAT

    你可以选择任何一种，或者选中其中的部分来创建其他功能的工具条。

    注意：如果你需要标准的Form++工具条，你无须拷贝资源到你的应用程序，因为工具条是在编译时从fores.rc导入的。如果你要定制工具条，你需要从fores.rc拷贝过去。

  2. 你可以象加入其他工具条一样，向你的框架窗口加入Form++工具条。在你的主框架窗口的头文件中加入工具条的成员变量(比如：MainFrm.h)。

    CToolBar m_wndDrawBar;

  3. 在主框架的资源文件中(比如：MainFrm.cpp)的OnCreate()函数中增加创建工具条的代码：

    if (!m_wndDrawBar.CreateEx(this, TBSTYLE_FLAT, WS_CHILD |
    WS_VISIBLE | CBRS_TOP | CBRS_GRIPPER | CBRS_TOOLTIPS |
    CBRS_FLYBY | CBRS_SIZE_DYNAMIC) ||
    !m_wndDrawBar.LoadToolBar    (IDR_FO_DRAWCOMPBAR))
         {
    TRACE0("Failed to create toolbar\n");
    return -1; // fail to create
    }

  4. 为了使工具条可以停泊，加入下面一行：

    m_wndDrawBar.EnableDocking(CBRS_ALIGN_ANY);
  5. 设置工具条的名字，在浮动时将显示：
    m_wndDrawBar.SetWindowText("ToolBox");

  6. 如果要在主框架窗口中停泊工具条，在OnCreate()加入：

    EnableDocking(CBRS_ALIGN_ANY);

  7. 当你如下调用时，你就可以停泊你的工具条了。

    DockControlBar(&m_wndDrawBar);
  8. 从Build选择Rebuild All。然后运行应用程序，显示如下：

top


s

首 页

UCanCode主页

下 载

联 系

增加格式工具栏

  1. Form++资源中包括两种工具条：命令和组件。它们具有不同的功能：

    Drawing Toolbar | IDR_FO_DRAWCOMPBAR
    Command Toolbar | IDR_FO_FORMAT

    你可以选择任何一种，或者选中其中的部分来创建其他功能的工具条。

    注意：如果你需要标准的Form++工具条，你无须拷贝资源到你的应用程序，因为工具条是在编译时从fores.rc导入的。如果你要定制工具条，你需要从fores.rc拷贝过去。

  2. 你可以象加入其他工具条一样，向你的框架窗口加入 Form++工具条。在你的主框架窗口的头文件中加入工具条的成员变量 (比如：MainFrm.h)。

    CToolBar m_wndFormatBar;

  3. 在主框架的资源文件中(比如：MainFrm.cpp)的OnCreate()函数中增加创建工具条的代码：

    if (!m_wndFormatBar.CreateEx(this, TBSTYLE_FLAT, WS_CHILD |
    WS_VISIBLE | CBRS_TOP | CBRS_GRIPPER | CBRS_TOOLTIPS |
    CBRS_FLYBY | CBRS_SIZE_DYNAMIC) ||
    !m_wndFormatBar.LoadToolBar(IDR_FO_FORMAT))
    {
           TRACE0("Failed to create toolbar\n");
           return -1;      // fail to create
    }

  4. 为了使工具条可以停泊，加入下面一行：

    m_wndFormatBar.EnableDocking(CBRS_ALIGN_ANY);

  5. 设置工具条的名字，在浮动时将显示：

    m_wndFormatBar.SetWindowText("FormatBar");

  6. 如果要在主框架窗口中停泊工具条，在OnCreate()加入：

    EnableDocking(CBRS_ALIGN_ANY);

  7. 当你如下调用时，你就可以停泊你的工具条了。

    DockControlBar(&m_wndFormatBar);

8. 从Build选择Rebuild All。然后运行应用程序，显示如下：

top


s

首 页

UCanCode主页

下 载

联 系

增加菜单项和加速键

  1. 下面增加菜单资源。如果你想让菜单项和视图交互，你可以从 Form++ 资源中拷贝到自己的资源中。不要把它们从Form++资源中删去。打开你的资源，同时打开Form++的资源 (\FO\Include\RORes.rc)。

  2. 从Form++'s View菜单中加亮你所需的菜单项然后拷贝。

  3. 把拷贝的菜单想项粘贴到你菜单中。然后从资源的字符表中删掉这些菜单项。并且建立起以ID_FO_开头的资源ID。

  4. 接下来增加加速键。文件FORes.rc包含了使用Form++的常用加速键资源。

  5. 选中你想要的加速键资源然后拷贝。

  6. 选择你自己应用程序的加速键表，在空处粘贴你拷贝的加速键资源。


s

首 页

UCanCode主页

下 载

联 系

增加组件工具盒

  1. 现在增加组件工具条。工具条wnd类是：
    CFOMultiToolBoxBar

  2. 你可以象加入其他工具条一样，向你的框架窗口加入Form++工具条。在你的主框架窗口的头文件中加入工具条的成员变量 (比如：MainFrm.h)：

    CFOMultiToolBoxBar m_FileBar;

  3. 在主框架的资源文件中(比如, MainFrm.cpp)，在OnCreate()增加创建工具条的代码：

    f (!m_FileBar.Create(this,ID_VIEW_TOOLBOX,_T("Docking Window"),CSize(200, 200)))
    {
        TRACE0("Failed to create m_FileBar\n");
        return -1;      // fail to create
  }

  m_FileBar.SetBarStyle(m_FileBar.GetBarStyle() |
        CBRS_TOOLTIPS | CBRS_FLYBY | CBRS_SIZE_DYNAMIC);

  4. 为了使工具条可以停泊，加入下面一行：

    m_FileBar.EnableDocking(CBRS_ALIGN_ANY);

  5. 设置工具条的名字，在浮动时将显示：

    m_FileBar.SetWindowText("ToolBox");

  6. 如果要在主框架窗口中停泊工具条，在OnCreate()加入：

    EnableDocking(CBRS_ALIGN_ANY);

  7. 当你如下调用时，你就可以停泊你的工具条了。

    DockControlBar(&m_FileBar, AFX_IDW_DOCKBAR_LEFT);

  8. 从Build选择Rebuild All。然后运行应用程序，显示如下：

top


s

首 页

UCanCode主页

下 载

联 系

安装Form++

要安装Form++，双击Setup.exe。下次系统会自动安装Form++的源代码到你的计算机。

安装Visual C++ IDE搜索路径

1.启动Microsoft Visual Studio.

2.从工具菜单（Tools ）选择选项（Options..），然后选择路径页（Directories ）。检查目标工作室包含路径显示在包含文件的列表中，如果没有就添加。

3.检查目标工作室库文件的目录显示在库文件的列表里。如果没有，现在就添加。

4.检查目标工作室源文件的目录显示在源文件的列表里。如果没有，现在就添加。

top


s

首 页

UCanCode主页

下 载

联 系

编译Form++ 库

在开始使用Form++中的类之前，需要编译Form++库。

Form++库可以被编译成静态连接库和动态连接库（DLL），两种配置都可以在带调试信息模式下（DEBUG）和释放模式下（RELEASE）编译

Form++装载了不同库的配置所要求的Visual C++的所有工程文件。

为了编译库，Visual C++ 的环境中，到Form++包含文件和库文件的目录路径必须被正确配置。

1.在Visual C++开发环境中，从工具菜单（Tools）选择选项（Options ）

2.象下面这样改变包含区（include ）：

3.在Visual Studio中，从编译菜单（Build）选择重新编译全部（Rebuild all）来编译选择的库。

库被编译完以后，它们被放在FO\Lib目录。每种配置被保存为一个单独的文件。每种编译配置都在FO\Build\目录下有子目录，目标文件就放在子目录下。

编译配置

下面的表列出了所有被支持的库的配置和每种配置默认的库名

配置名 | 默认库名
MFC Dll,Diagram++ Dll Release | XG40.lib
MFC Dll,Diagram++ Dll Debug | XGD40.lib
MFC Dll,Diagram++ Dll Unicode Release | XGU40.lib
MFC Dll,Diagram++ Dll Unicode Debug | XGUD40.lib
MFC Dll ,Diagram++ Lib Release | XGS40.lib
MFC Dll ,Diagram++ Lib Debug | XGSD40.lib
MFC Dll ,Diagram++ Lib Unicode Release | XGUS40.lib
MFC Dll ,Diagram++ Lib Unicode Debug | XGUSD40.lib
MFC Lib ,Diagram++ Lib Release | XGLS40.lib
MFC Lib ,Diagram++ Lib Debug | XGLSD40.lib
MFC Lib ,Diagram++ Lib Unicode Release | XGLUS40.lib
MFC Lib ,Diagram++ Lib Unicode Debug | XGLUSD40.lib

注意: 如果你是动态连接到Form++库（DLLs），你需要在你的路径里添加FO\Lib目录，或者手工把Form++动态连接库（DLLs）拷贝到你的Windows 目录下。

下面的说明介绍如何使用装载了产品的Visual C++工作平台来编译Form++库。

1.启动Visual C++ Developer Studio.

2.从…\UCanCode.Net Software\Form++ Library\FO\ 目录中打开Form++工程。

3.在Visual Studio中，从编译菜单（Build ）选择配置（Set Active Configuration ），并选择适合你要求的配置。默认情况下，Debug被选中。

4.在Visual Studio中从编译菜单（Build ）选择重新编译全部（Rebuild all）来编译所选的库。

top


s

首 页

UCanCode主页

下 载

联 系

运行Visual C++ AppWizard

  1. 打开Developer Studio从菜单File选择New新建一个工程

  2. 从工程类型列表中选择Form++ Library Application Wizard并在工程名输入框中输入Test1。然后单击OK。

3.在下一页中选择Multiple Document。确认Document/ View Architecture选中，并且语言类型为English (United States)。然后单击NEXT。

4.选择不支持数据库，单击Next。

5.选中支持ActiveX Controls ，单击Next。

6.选中以下特点，单击Next。

  • Docking Toolbar

  • Initial Status Bar

  • Printing and Print Preview

  • 3D Controls

7.选中以下风格：

  • Consists of standard MFC.

  • Supports source file comments.

  • Uses MFC as a shared DLL.

然后单击Next。

8.这一页显示所继承的基类以及相应的文件名。确认后按 Finish。

9.这一页所包含的选项是单独属于Form++ Library的。这一页允许你设置Form++ Library应用程序的特点。选择以下选项后单击Next.

  • Ruler
  • Color Palette
  • ToolBox
  • Format Bar
  • Draw Bar
  • MultiPage


s

首 页

UCanCode主页

下 载

联 系

介绍

本节主要从终端用户的角度描述了Form++的特点。用Form++开发的应用程序可以包括本章介绍的部分或全部特点。通过改变应用程序的菜单和工具栏，你可以添加或删除部分Form++的部分特点。例如：用命令标识 ID_FO_DRAW_BUTTON，用户可以添加一个工具栏按钮，它使用户拥有画按钮组件的能力。

在线观看本章讲述的特点：

  1. 启动Visual C++

  2. 打开FOSample，它直接放在Samples文件夹中。然后选择对应于你的C++版本的 FOSample工作区。

  3. 编译应用程序并且执行它。


s

首 页

UCanCode主页

下 载

联 系

定义

以下是在Form++ 产品中常用的术语和它们的定义：

组件

组件是在背景上绘制的对象。按钮、编辑框、组合框和矩形等都是组件的实例。组件有一个位置，占据一定的矩形区域。组件可以赋予以下属性：填充色，线型色，字体，显示和行为标志。

控制手柄

控制手柄实在组件被选中时显示的矩形框。对于基本组件如直线，矩形等控制手柄被放置在各顶点处。允许移动这些顶点来改变组件的形状。

连接

连接是组件之间的连线，用以显示组件的关系。连接是特殊的组件，在两端各有一个端口，这些端口可以与其他组件的端口项连。

模型

模型是用来显示一个全系统的图形对象和彼此关系的组件的集合。

端口

端口定义了组件与其他组件项连的点。一个连接连通两个端口。

属性

属性被赋予组件的标签值。属性是与组件相联系（编译时或者运行时），有唯一的标识和值的对象。

工具盒

工具盒是停靠在主窗口左边的一个工具栏，在这里年可以选择组件并把它拖到视图中去。

top


New features build in New year!

首 页

UCanCode主页

下　　载

联　　系

Form++应用程序向导-1

注意:以下的特点介绍假定你已经安装了Form++ Library的动态链接库。

整合Form++ Library到Visual studio，你可以在一个MFC应用中生成Visual C++工程,这个工程包含了你要整合的相关的Form++代码.

1. 打开Developer Studio然后从File选择New 生成一个新的应用程序.
2. 从工程类型列表中选择Form++ Library Application Wizard ,在工程名字栏中输入Test1.然后点OK.
3. 在下一步中,选择Single Document Interface 或者 Multiple Documents Interface.确保选中Document/View Architecture 复选框,进行语言选择,然后点Next .

Next


s

首 页

UCanCode主页

下 载

联 系

画图功能

Form++为绝大多数终端用户和画图应用程序提供了一系列的画图功能。用户可以在画布中绘制如下类型的组件：

  • 直线

  • 箭头直线

  • 多线段

  • 多边形

  • 贝塞尔曲线

  • 封闭贝塞尔曲线

  • 矩形

  • 椭圆

  • 静态组件

  • 图象

  • 超链接

  • ...

Form++ 提供了改变形状和图像的功能。这些动作用户可以使用一些组件来完成：

  • 选择指针

  • 移动

  • 标尺

  • 对齐

  • 旋转

  • 剪切, 复制,粘贴

  • 排序

  • 网格对齐

  • 打印和导出

  • 分组和取消分组

  • 连结两个组件

  • ...

top


s

首 页

UCanCode主页

下 载

联 系

画图组件

组件是一种放在背景中可供用户控制的对象。一个组件可以是简单的形状（例如：静态文本），也可以是复杂形状或图像的集合。Form++的用户接口功能需要用户在窗体上画出他们的形状，并把它们作为组件来添加才能实现。如果要绘制一个组件，用户选择工具栏或菜单命令，它们都有一个相对应的形状。这将把Form++应用程序放到一种模式下，在该模式下应用程序可以接受输入或绘制组件。鼠标左键是用来绘制外形的，而右键用来取消绘制。 下面讲述了如何拖动不同类型的外形和原始组件以及如何执行其它的相关绘制任务。

  • 绘制直线

在客户区单击鼠标左键然后拖动鼠标直到直线长度合适。

  • 箭头直线

在客户区单击鼠标左键然后拖动鼠标直到直线长度合适。

  • 多线段

在客户区单击鼠标左键。然后再单击鼠标放置顶点，双击完成绘制。单击鼠标右键取消绘制。

  • 多边形

在客户区单击鼠标左键。然后再单击鼠标放置顶点，双击完成绘制。单击鼠标右键取消绘制。

  • 贝塞尔曲线

在客户区单击鼠标左键。然后再单击鼠标放置一个终点，两个控制点和其他终点。双击完成绘制。单击鼠标右键取消绘制。

  • 封闭贝塞尔曲线

在客户区单击鼠标左键。然后再单击鼠标放置一个终点，两个控制点和其他终点。双击完成绘制。单击鼠标右键取消绘制。它不象多边形曲线，用户可以用一种颜色来填充该曲线。

  • 矩形

在客户区单击鼠标左键然后拖动鼠标直到矩形的高度和宽度满足你的要求为止。

  • 椭圆

在客户区单击鼠标左键然后拖动鼠标直到椭圆的大小满足你的要求为止。

  • 静态组件

在客户区单击鼠标左键。双击该组件你可以编辑文本。

  • 图象

在客户区单击鼠标左键。此时会弹出一个标准的“打开”对话框，在这里你可以选择要打开的 .bmp文件或 .wmf文件或 .emf文件。

  • 超链接

在客户区单击鼠标左键。双击该组件你可以编辑文本。


s

首 页

UCanCode主页

下 载

联 系

控制组件布局

1 选择

Form++的应用程序开始时默认在选择状态下。如果你不在选择状态下，你可以通过移动鼠标单击 [image] 按钮来转换。

当选择状态被激活时，你可以通过单击它来选择一个简单的组件。如果你想选择多个组件，你可以按住CTRL键，然后用鼠标单击每个你想选中的组件。 或者你也可以移动鼠标到一个空白区域，然后拖动鼠标把所要选中的组件包括在你所画的矩形框中。最后一个选中的组件不同于其他的组件，因为它的选择句柄时灰色的。灰色的句柄是用来显示该组件是一个支撑组件。Form++用支撑组件作为对齐组件的一个参考。如果你想把另外一个组件作为支撑组件，按住CTRL键，然后在该组件的选择区内单击鼠标左键。Form++就会把灰色句柄从前一个组件移到你刚才选中的那个组件上。

如果要从一组组件中去掉一个组件，按住SHIFT键，然后单击你不想要的那个组件即可。

2 移动

当应用程序在选择状态下时，你可以通过单击你所选择的组件或拖动鼠标来达到移动的目的。当你把鼠标指针放到组件中你可以移动的位置时，指针就会变成一个移动指针。如果你想Snap to Grid选项打开时，组件左上角就会和网格对齐。

通过使用对齐操作，你可以轻松地对齐多个组件。你可以按照组件的任何一条边或中心对齐它们。 在选择了多个组件时，支撑组件通过它的灰色句柄来区别于其它组件。多个组件被选中后，支撑组件是一个参考，其它组件和它对齐。

Align Top
Align Middle
Align Bottom
Align Left
Align Center
Align Right

你可以用“nudge”轻轻地移动你所选择的组件。这些组件在默认状态下移动组件一个单元，如果你按住SHIFT键的话，它们就会移动五个单元。下面四个nudge命令：

Nudge Up
Nudge Down
Nudge Left
Nudge Right

你也可以在画布上基于最上面或最下面的组件在均匀地分布一组组件，无论是在水平方向还是在垂直方向。

Space Across
Space Down

Form++允许你调整一组你所选择的组件的宽度、高度或者是两者。当你选择调整按钮时，你所选中的按钮就会自动地变大或变小以匹配支撑组件的大小。支撑组件是你最后选中的那个组件，它用灰色句柄来区分你所选中的其它组件。

Same Width
Same Height
Same Size

3 缩放

如果一个组件是可以缩放的，当你把指针移到该组件的一个控制句柄上时，指针就会变成一个有方向的箭头。这样，你所选择的组件就可以在水平、垂直或者是同时水平和垂直方向上缩放，至于方向则取决于你所选择的句柄。

4 组件次序

模板中单独的组件是按堆次序摆放的，也就是众所周知的Z轴次序。 堆次序决定了在堆栈中每个组件所绘制的位置。换言之，这个次序决定了那个组件最后被绘制。最后被绘制的那个覆盖已经在背景中绘制的所有组件。 Z轴次序是由添加到模板中去的那个组件所决定的。最后那个组件被添加到最上面。

用户可以用一组命令改变Z轴次序。Bring Forward命令代表把组件朝向上的方向移到堆栈上。Move Back命令代表把组件朝向下的方向移到堆栈上。用Bring to Front和Send to Back命令分别可以把一个组件直接移到堆栈的最上面和最下面。

Bring Forward
Move Back
Bring to Front
Send to Back

5 移动

如果要移动页到背景中不同的区域去，选择工具按钮 [image] 。这时光标将变成一只手的形状。你可以单击鼠标并且拖动它，使得页在模板上移动。

6 旋转

如果要将选中的组件旋转到任意角度，单击工具按钮 [image] 进行旋转。

当你把鼠标放到要旋转的组件上时，鼠标的形状就会发生变化。单击你要旋转的一个或多个组件，拖动鼠标到你要旋转的位置。这样组件就会从原来的位置旋转到你最后确定的位置。

有四种预定义的旋转命令供你使用，它们分别可以顺时针或逆时针旋转90度。

向左旋转

向右旋转
水平翻转
垂直翻转

7 分组和取消分组

你能够用工具按钮 [image] 对组件进行分组。

选择你想要分组的组件，然后单击分组按钮。分组后的组件操作起来有点象单个图形组件。你对一个组件进行的变化都将影响到这个分组中的每一个组件。因为此时它们被看成一个组件。

若要取消分组，选择工具按钮 [image] 取消分组。

8 锁定组件和取消锁定组件

你可以用工具按钮 [image] 来锁定组件。

选择你要锁定的组件，然后单击锁定按钮进行锁定。锁定后的组件是只读的，你不能自由地移动或缩放它。

若要取消锁定的话，选中你要取消锁定的组件后，然后单击工具按钮 [image] 取消锁定。

9 编辑顶点

若要移动顶点，首先单击 [image] 按钮。然后把鼠标移动到控制手柄上。鼠标的形状会发生变化，这就意味着你可以移动顶点了。单击控制手柄并且拖动它到一个新位置，然后就可以在新位置处释放鼠标了。

top


s

首 页

UCanCode主页

下 载

联 系

属性页

你能将任何组件与许多属性联系起来。要决定组件的属性，你需要打开组件属性页。若要打开组件属性页，需要先选中一个或多个组件，然后从“Edit"菜单中选择“属性”命令。你也可以将鼠标移到组件上，选中它，然后单击鼠标右键，从弹出菜单中选择”属性“来打开属性页。

组件属性页是一个制表对话框，它显示组件的属性，你也可以编辑它。在属性页中可用的属性取决于你所选择的组件。本节下面将要介绍如何使用每一个组件属性页。

一般属性

这个属性页显示了诸如组件名、组件类型等信息。属性所显示的内容取决与组件的类型。

top


s

首 页

UCanCode主页

下 载

联 系

标尺

你可以使用标尺将组件移动到精确的位置，如下图：

当要移动到的精确位置非常重要时，标尺就大有用处。


s

首 页

UCanCode主页

下 载

联 系

文件导出

该特点允许用户导出窗体到一个位图格式文件中去。目前Form++支持位图格式的导出文件。

如果要将窗体导出到文件中去，从菜单中选择File|Export命令。这会打开标准的Windows File Save对话框。在文件名下面的组合框中，你可以选择文件的类型。


s

首 页

UCanCode主页

下 载

联 系

页面布局

用户可以通过选择File菜单的Page Setup项来确认页面的背景设置。页设置决定了打印的背景以及在何处出现打印的中断。在这里使用了标准的Windows页面设置对话框，用户在这里可以设置页面的大小、页面的方向、边距和打印机型号。页面设置和你的文档一起保存，默认的打印机是用来为新文档初始化页面设置的。页边界在背景中用点线画了出来。.

页面设置对话框


s

首 页

UCanCode主页

下 载

联 系

画布背景

页的背景色可以在模板中显示出来。背景组件显示在页中其它所有组件的后面。用户不能直接操作背景组件。


Home

首 页

UCanCode主页

下 载

联 系

简介

F orm++ 核心类库提供了与MFC兼容的大量类。提供更多的功能使开发程序不再艰难。这些类从MFC继承但是提供了更多的方法，使我们能够屏蔽掉细节集中精力开发应用。因此你现在有了不同的思路来开发程序。
1. 你可以从Form++直接开发你的项目，从一个更高层次出发；
2.你可以结合Form++类库和MFC的优点来开发项目，我们的产品很容易与其他产品融合。

  核心类包括以下的概念：

1 组件和模型

一个组件是一个可以放置在表格上的对象。任何可以放置在表格上可以被操作的对象都是组件。

模型提供了一系列的方法供你使用来控制表格上的对象。你可以通过模型编辑足见的任何特性。比如，你可以改变足见的外观如背景色，文本色，字体，位置及其他。如果要使用模型。就可以使用这些方法。这些命令对象使用同样的方法来响应用户交互。

2 组件

Form++中所有的组件都是可见的。每个组件都是有属性、二维边界并且能绘制到设备上下文的对象。Form++组件类继承图后文中将会有介绍。

3 改变

无论何时模型都可以知道自身是否被改变。

详细信息，请点这里。

back


Home

首 页

UCanCode主页

下 载

联 系

核心类继承图

back [image] top


Caption

首 页

UCanCode主页

下 载

联 系

核心类列表

类继承图 详细描述了类库中类的关系。

类分布在以下的目录中。

CFOSubFormModel | Base class name:CFODataModel, Defined in:FOSubFormModel.h
CFOTabPageModel | Base class name:CFODataModel, Defined in:FOTabPageModel.h
CFODataModel | Base class name:CObject, Defined in:FODataModel.h
CFOCustomDataModel | Base class name:CFODataModelBase, Defined in:FODataModel.h
CFODataModelBase | Base class name:, Defined in:FODataModelBase.h
CFOMultiTracker | Base class name:CObject, Defined in:FOMultiTracker.h
CFOMultiPageView | Base class name:CFOBaseView, Defined in:FOMultiPageView.h
CFOBaseView | Base class name:CScrollView, Defined in:FOBaseView.h
CFOMultiPageModel | Base class name:CObject, Defined in:FOMultiPageModel.h
CFOMultiTabModel | Base class name:CObject, Defined in:FOMultiTabModel.h
CFODrawHelper | Base class name:CObject, Defined in:FODrawHelper.h
CFODoubleBufferDC | Base class name:CDC, Defined in:FODoubleBufferDC.h
CFODoc | Base class name:CDocument, Defined in:FODoc.h
CFOContentView | Base class name:CScrollView, Defined in:FOContentView.h
CFOCompSelection | Base class name:CObject, Defined in:FOCompSelection.h
CFOBackComponent | Base class name:CObject, Defined in:FOBackComponent.h
CFOArea | Base class name:CObject, Defined in:FOArea.h
CFOMPtArea | Base class name:CObject, Defined in:FOArea.h


Home

主 页

UCanCode主页

下 载

联 系

数据模型简介

1 组件和模型

一个组件是一个可以放置在表格上的对象。任何可以放置在表格上可以被操作的对象都是组件。

模型提供了一系列的方法供你使用来控制表格上的对象。你可以通过模型编辑足见的任何特性。比如，你可以改变足见的外观如背景色，文本色，字体，位置及其他。如果要使用模型。就可以使用这些方法。这些命令对象使用同样的方法来响应用户交互。

2 背景

表格的背景色和外观等保存在模型中。你可以定义背景上的组件，使用背景色。缺省情况下，背景色是灰色的，你可以依需要而改变。

背景组件由CFOBackComponent定义，以显示表格上其他组件背景的样式。

3 改变

无论何时模型都可以知道自身是否被改变。

4 CFODataModel

5 CFOSubFormModel

6 CFOMultiPageModel

7 CFOTabPageModel

8 CFOMultiTabModel


Home

首 页

UCanCode主页

下 载

联 系

视图类简介

视图包含了所有你递交的图形模到屏幕的逻辑转换。它处理模的绘制和打印，还有滚动和尺寸变化。视图的主要功能在模变化时更新屏幕区域。

1 网格

在默认状态下，每个视图被一个网格覆盖，组件依附在网格上。你可以显示或隐藏网格和打开或关闭依附的特性。你也可以改变网格的颜色，使它相对于画布的背景色是可见的。

在默认状态下，网格的行和列都是七个象素。你也可以改变它的距离。每个视图的网格都是独立的。因此，如果你改变一个视图的网格的间距或颜色，其他视图的网格不会受影响。

2 选择柄的尺寸

另一个你需要考虑的视觉方面的细节是你的组件被选中时如何显示。模板维持着选择柄。你可以指定它们的大小，也可以重载画选择柄的函数来改变它们的外观。

3 组件跟踪

视图的另一个指责是跟踪组件的操作。当终端用户移动，改变大小，比例放缩一个组件时，跟踪放置一个组件的轮廓。组件轮廓的目的是显示如果你在现在的位置放置组件，它看起来会是什么样的。

4 更新

视图监视着模板。当模板某方面发生变化，它会通知它的所有视图。视图有一个OnUpdate()函数来接收通知。然后确定视图的哪个区被变化所影响，并且重画。

5 滚动

每个视图都有在右边和底部有滚动条，当模板的尺寸比客户区大时，滚动条会自动显示。

6 OLE Drag-and-Drop

7 CFOBaseView

8 CFOMultiPageView

9 CFOTabPageView

10 CFOContentView


s

首 页

UCanCode主页

下 载

联 系

组件

在Form++中，所有的组件都是可见的。组件就是具有属性，两维的，能够用设备上下文（CDC）绘制的对象。下面是Form++组件类的层次图。

组件类层次图

top


s

首 页

UCanCode主页

下 载

联 系

组件要素

1 CFODrawComponent

CFODrawComponen是Form++中所有组件的基类。每个组件都有其属性、二维边界，并且可以在设备环境中绘制。每个组件都和一个唯一的名字和组件类型相联系。

CFODrawComponen类从FOIUnknown类继承。

2 组件名字

每个组件都有一个名字来区别于Form++的其他组件。

3 组件类型

这用来识别组件的类型。原始组件已设置了类型。例如，一个按钮组件自动分配了 FO_COMP_BUTTON类型，你可以调用SetType()函数来改变组件类型。

4 标题

每个组件都有一个标题。在默认状态下，标题和组件名字一样。你可以调用SetObjectCaption()函数来设置标题。

5 组件属性

每个组件可以没有或有多个属性与之相联系。借助属性可以设定组件的外观和组件的行为。 用指向对象属性值的指针构成的链表来存储属性值，属性类是从 CFOBaseProperties 类派生的。

开发人员可以在组件中加入自定义的属性。

6 控制点

一个组件有九个控制点，位于组件的限制框的四周：每个角，每条边的中点，还有组件中心都有一个控制点。

7 控制柄

当终端用户选定一个组件时，控制柄就会出现。这些控制柄能够让终端用户看到哪些组件被选定，并且放缩组件大小或是移动它的边界。

大多数组件的控制柄是位于限制框的边上的八个控制点。

8 用户数据

每个组件都有一个普通的CObject指针，通过这个指针你可以把组件设置你想要的状况。除了允许开发人员将特定数据与组件联系起来外，这个指针没有其他的用途。用户数据指针所指的对象必须从CObject类派生而且必须支持MFC串行化。

9 区域

通过画布背景，每个组件都可以根据定义知道它填充的逻辑空间的数目。组件的区域和子区域是紧密联系的。区域是用来判断单击组件和屏幕刷新的。组件的绑定矩形是根据这个区域对象计算出来的。

top


s

首 页

UCanCode主页

下 载

联 系

成形组件

现在的Form++4.0装载有以下组件，你可以用Form++ Library add-in创建你自己的组件。

增加了近50个定制组件，如下所示：

有一些组件类如下所示：

Class Name | Description
CFOButtonComponent | Button component.
CFOCalendarComponent | Calendar component.
CFOCheckComponent | CheckBox component.
CFOComboBoxComponent | ComboBox component.
CFOEditBoxComponent | EditBox component.
CFOEditWithButtonComponent | EditBox with a select button component.
CFOFrameComponent | Frame Window component.
CFOHorzScrollBarComponent | Horizontal ScrollBar Component.
CFOImageComponent | Image component.
CFOListBoxComponent | ListBox componnent.
CFOListCtrlComponent | ListCtrl component.
CFOMarqueeComponent | Marquee component.
CFOProgressCtrlComponent | ProgressCtrl component.
CFORadioComponent | RadioBox componnet.
CFORoundButtonComponent | RoundButton component.
CFOSeparatorComponent | Separator component.
CFOSliderComponent | Slider componnet.
CFOSpinEditComponent | EditBox with spinctrl component.
CFOStaticComponent | Static Text component.
CFOStaticRectComponent | Static rectangle component.
CFOTabComponent | Tab component.
CFOVertScrollBarComponent | Vertical scrollbar component.

top


组件类

1.CFOBaseComponent

所有组件的基类。

头文件 ：FOBaseComponent.h

2.CFODrawComponent

所有绘图组件的基类。

头文件：FODrawComponent.h

3.CFODrawPortsComponent

停靠点组件，所有具有停靠点绘图的组件都从CFODrawComponent继承，用于实现组件间连接线可以多点停靠的功能。

头文件：FODrawPortsComponent.h

4.CFOButtonComponent

按钮组件，从CFODrawPortsComponent继承，用于实现基本的按钮功能。

头文件：FOButtonComponent.h

5.CFOCalendarComponent

日历组件，从CFODrawPortsComponent继承，用于实现显示日历的功能。 当你想要在模板上增加一个日历时，你可以用这个组件。首先你选择这个组件，然后拖动它到模板上。这样在模板上就有一个日历组件了。

头文件：FOCalendarComponent.h

6.CFOCheckComponent

检查组件，从CFODrawPortsComponent继承，用于实现检查某选项是否被选上的功能。首先你选择这个组件，然后拖动它到模板上。这样在模板上就有一个检查组件了。

头文件：FOCheckComponent.h

7.CFOComboBoxComponent

下拉框组件，从CFODrawPortsComponent继承，从下拉框中列出多个选项，用于实现多选一的功能。

头文件：FOComboBoxComponent.h

8.CFOEditBoxComponent

可编辑下拉框组件，从CFODrawPortsComponent继承，下拉框中列出多个选项，而且可以编辑一个选项，用于实现编辑和多选的功能。

头文件：FOEditBoxComponent.h

9.CFOEditWithButtonComponent

带按钮的编辑框，从CFODrawPortsComponent继承，可以编辑，也可以按按钮进行选择。

头文件：FOEditWithButtonComponent.h

10.CFOFrameComponent

框架组件，从CFODrawPortsComponent继承，用于实现为一组组件设一个框架的功能。

头文件：FOFrameComponent.h

11.CFOHorzScrollBarComponent

水平滚动条组件，从CFODrawPortsComponent继承，用于实现水平滚动的功能。

头文件：FOHorzScrollBarComponent.h

12.CFOImageComponent

图象组件，从CFODrawPortsComponent继承，用于实现编辑图象的功能。

头文件：FOImageComponent.h

13.CFOListBoxComponent

列表框组件，从CFODrawPortsComponent继承，用于实现列表显示的功能。

头文件：FOListBoxComponent.h

14.CFOListCtrlComponent

列表控制框组件，从CFODrawPortsComponent继承，用于实现列出多项控制的功能。

头文件：FOListCtrlComponent.h

15.CFOMarqueeComponent

滚动文本组件，从CFODrawPortsComponent继承，用于实现文本滚动的功能。

头文件：FOMarqueeComponent.h

16.CFOProgressCtrlComponent

进度条组件，从CFODrawPortsComponent继承，用于实现显示工作进度的功能。

头文件：FOProgressCtrlComponent.h

17.CFORadioComponent

无线电组件，从CFODrawPortsComponent继承，用于实现单选的功能。

头文件：FORadioComponent.h

18.CFORoundButtonComponent

圆形按钮组件，从CFODrawPortsComponent继承，圆的外形，用于实现按钮的功能。

头文件：FORoundButtonComponent.h

19.CFOSeparatorComponent

隔离线组件，从CFODrawPortsComponent继承，用于实现隔离线的功能。

头文件：FOSeparatorComponent.h

20.CFOSliderComponent

滑动组件，从CFODrawPortsComponent继承，用于实现滑动向前或向后选择进度的功能。

头文件：FOSliderComponent.h

21.CFOSpinEditComponent

旋转可编辑组件，从CFODrawPortsComponent继承，用于实现编辑和上下旋转显示的功能。

头文件：FOSpinEditComponent.h

22.CFOStaticComponent

静态文本组件，从CFODrawPortsComponent继承，用于实现静态文本显示的功能。

头文件：FOStaticComponent.h

23.CFOStaticRectComponent

静态矩形组件，从CFODrawPortsComponent继承，用于实现显示一个静态矩形。

头文件：FOStaticRectComponent.h

24.CFOVertScrollBarComponent

垂直滚动条组件，从CFODrawPortsComponent继承，用于实现垂直滚动的功能。

头文件：FOVertScrollBarComponent.h

25.CFOTabComponent

标签组件，从CFODrawPortsComponent继承，用于实现把组件属性分页的功能。

头文件：FOTabComponent .h

26.CFOLineComponent

直线组件，你在画直线时可以用这个组件。首先，在模板中点击鼠标左键，然后移动鼠标到目标点，再双击鼠标。就能得到从起始点到目的点的一条直线。

头文件：FOLineComponent.h

27.CFOBezierLineComponent

贝塞尔曲线组件，你在画贝塞尔曲线时可以用这个组件。首先，在模板中点击鼠标左键，然后从一个点到另一个点移动鼠标，每确定一个点单击鼠标左键，最后双击鼠标。就能得到从起始点到目的点的一条贝塞尔曲线。

头文件：FOBezierLineComponent.h

28.CFOCloseBezierComponent

封闭的贝塞尔曲线组件，你在画封闭的贝塞尔曲线时可以用这个组件。首先，在模板中点击鼠标左键，然后从一个点到另一个点移动鼠标，每确定一个点单击鼠标左键，最后双击鼠标。就能得到从起始点到目的点的一条封闭的贝塞尔曲线。

头文件：FOCloseBezierComponent.h

29.CFOPolygonComponent

多边形组件，你在画多边形时可以用这个组件。首先，在模板中点击鼠标左键，然后从一个点到另一个点移动鼠标，每确定一个点单击鼠标左键，最后双击鼠标。就能得到从起始点到目的点的多边形。

头文件：FOPolygonComponent.h

30.CFOLinkComponent

连接组件实现显示组件间的连接关系。它从CFODrawComponent 派生来，因此具有连接功能。

连接组件看起来象直线组件，但是在线的两端有两个停靠组件。它们总是准备去连接另一个组件。连接组件看起来和做起来都象直线。

当你要给两个组件加一条连接线时，就可以用这个组件。首先选择这个组件，然后从源点到目的点移动鼠标，就会有一条连接线连在两个组件之间。

头文件：FOLinkComponent.h

31.CFOPortComponent

停靠组件在一个组件上指定一个点，在点上你可以和另一个组件建立连接。CFOPortComponent类没有可见的代表物，你可以用它在组件上指定停靠点而不用改变它的外观。你可以选择性从它派生一个类使停靠出现在屏幕上。

头文件：FOPortComponent.h

top


如何在Form

首 页

UCanCode主页

下 载

联 系

怎样在Form++中增加定制组件?

你可以通过以下方式增加定制组件：

(1) 打开Visual C++ 6.0并且运行它去创建一个SDI工程，然后用Form++ Library add-in去生成类。如果你不知道如何创建，可以按照下面方式去做。

(2) 首先，你选择CFODrawComponent作为基类。然后给新建的类输入一个名字。当你完成这些后，单击OK。

Form++ Library add-in将自动地为你新建的组件类生成两个代码模板文件。这两个文件的名字分别是MyCorsssLineComponent.cpp和MyCorsssLineComponent.h,他们都将被自动地插入到工程中去。

(3) 在Visual C++中打开名字为MyCorsssLineComponent.h的文件。在这个文件中，你给这个新组件增加一个ID：

#define MY_LINE_TYPE FO_COMP_CUSTOM + 1

注意:新ID必须是一个比FO_COMP_CUSTOM大的值。

(4) 在CMyCorsssLineComponent构造函数中，添加如下代码：

(5)新建对象的代码如下：

(6) 再次运行Form++ Library add-in，选择CFODataModel作为基类，生成的类的名字为CMyExtDataModel.新的模板代码将在生成的过程中同时被插入到工程中去。

(7) 在Visual C++中，打开MyExtDataModel.h文件，在文件开始处添加如下代码：

(8) 打开MyExtDataModel.cpp文件，你必须修改以下代码：

(9) 新建一个菜单Insert New Component...，然后在CCustomSampleView类中为新菜单添加如下代码：

(10)在左边组件列表中为你新建的组件添加一个图标，如下图：

把鼠标移动到图标上，然后单击右键，给该图标重命名为101。这样就完成了增加图标。

(11)选择编译，你就可以编译和运行应用程序了。

top


s

首 页

UCanCode主页

下 载

联 系

命令介绍

命令对象是Form++中恢复/撤消系统中的一部分。命令是一个知道如何存储和恢复事件的对象。当终端用户在模板上执行一个动作时，应用程序就会收集需要执行那个动作的命令的信息。于是，应用程序就执行该命令（换言之，它执行一个动作）并且将执行的命令存储到交换模板中去。

命令类层次图


s

首 页

UCanCode主页

下 载

联 系

类型ID

每一个命令都有一个不同的类型ID。当你有一个指向普通CFOCommand对象的指针时，类型ID能够用来区分不同类型的命令。每个类都有一个默认的ID。例如：移动命令有一个叫COMMAND_MOVECOMPONENT的ID。如果你想在同一个类中区分不同的命令时，你可以改变这个ID。


s

首 页

UCanCode主页

下 载

联 系

执行与不执行

一条命令只有当Execute()方法被调用时才会执行。该命令存储了很多额外的信息，这些信息可能需要用来撤消一个命令，于是就可以在模板中调用这个方法来执行这个动作。

当需要撤消一条命令时，就会调用GetUndoCommand()方法。在这里，存储的信息被恢复，动作被撤消。

当前Form++ V4.0支持以下命令。每一个命令都支持撤消/恢复模式。你可以用Form++ Library add-in创建自己的命令。


s

首 页

UCanCode主页

下 载

联 系

目标模板

每条命令都有一个指针指向属于它的模板。命令就用这个指针去访问它的方法，该方法使得它能完成它要执行的动作。例如：当你执行移动命令时，它就调用CFODataModel中的MoveComponent()方法。


s

首 页

UCanCode主页

下 载

联 系

命令中的组件

每个命令都有一系列指向受它影响的组件的指针。这些组件是被引用计算的，因此在所有的命令在使用这些组件被执行的时候，它们不能从内存中被释放掉。例如：如果用户选择了一个组件并且删除它，它将仍然被删除命令引用，即使它在模版中已经不用了。当在模版中移动一个组件时，如果该组件被删除了，命令就会有一个坏指针指向它。如果用户试图想撤消删除命令，程序就会崩溃。因为组件是被引用计算的，只要删除命令还在，该组件就还在内存中。


s

首 页

UCanCode主页

下 载

联 系

命令类

目前Form++ 4.0版支持以下命令。每个命令都支持恢复和撤消模式。在使用Form++ Library add-in时你可以创建你自己的命令。

1.CFOBasecommand

说明：这是所有命令类的基类，从MFC的CObject派生而来。它监视在模板中执行的命令。它也监视一系列的CFODrawComponent类。每个命令对象有一个与之相联系的ID，这样在没有用户运行时类型信息的情况下，代码就可以区分出不同的命令。

头文件：FOBasecommand.h

2.CFOCommand

说明：这里从CFOBasecommand派生的类，它表示执行单条命令。当执行一条命令的时候会调用此类。

头文件：FOCommand.h

3.CFOAddCompCommand

说明：这是从CFOCommand派生的类，它表示添加一个组件。当你执行这个命令时，就可以向模板添加一个组件。当你撤消该动作时，就会建立一个 CFORemoveCompCommand类，并且执行它。

头文件：FOAddCompCommand.h

4.CFOAddCompsCommand

说明：这是从CFOCommand派生的类，它表示添加多个组件。当你执行这个命令时，就可以向模板添加多个组件。当你撤消该动作时，就会建立一个CFORemoveCompsCommand类，并且执行它。

头文件：FOAddCompsCommand.h

5.CFOAddLinkCommand

说明：这是从CFOCommand派生的类，它表示添加一个连接。此类在向模板的组件之间添加一个连接时调用。

头文件：FOAddLinkCommand.h

6.CFOColorChangeCommand

说明：这是从CFOCommand派生的类，它表示改变所选对象颜色。此类在改变所选择的对象的颜色时调用。

头文件：FOColorChangeCommand.h

7.CFOFormColorChangeCommand

说明：这是从CFOCommand派生的类，它表示改变窗体颜色。此类在改变窗体的颜色时调用。

头文件：FOFormColorChangeCommand.h

8.CFOFormSizeAndNameCommand

说明：这是从CFOCommand派生的类，它表示改变窗体大小和名字。此类在改变改变窗体的大小和名字的时候调用。

头文件：FOFormSizeAndNameCommand.h

9.CFOFormSizeCommand

说明：这是从CFOCommand派生的类，它表示只改变窗体大小。此类在仅改变窗体大小的时候调用。

头文件：FOFormSizeCommand.h

10.CFOMoveCompCommand

说明：这是从CFOCommand派生的类，它表示移动一个组件。此类在移动一个组件、改变一个组件的位置时调用。

头文件：FOMoveCompCommand.h

11.CFOMoveCompsCommand

说明：这是从CFOCommand派生的类，它表示移动多个组件。此类在移动多组件、改变它们的位置时调用。

头文件：FOMoveCompsCommand.h

12.CFOOrderSingleCommand

说明：这是从CFOCommand派生的类，它表示对单个组件层次进行排列。此类在只有在对多个组件进行层次叠放时才会被调用。

头文件：FOOrderSingleCommand.h

13.CFORemoveCompCommand

说明：这是从CFOCommand派生的类，它表示对删除单个组件。此类在只有删除单个组件时被调用。

头文件：FORemoveCompCommand.h

14.CFORemoveCompsCommand

说明：这是从CFOCommand派生的类，它表示对删除多个组件。此类在选择了多个组件、并将它们删除时被调用。

头文件：FORemoveCompsCommand.h

15.CFORemoveLinkCommand

说明：这是从CFOCommand派生的类，它表示对删除连接。此类在组件之间添加了连接，并要将此连接删除时被调用。

头文件：FORemoveLinkCommand.h

16.CFOScaleCommand

说明：这是从CFOCommand派生的类，它表示对模板进行比例缩放。此类改变模板的比例时被调用。

头文件：FOScaleCommand.h

17.CFOSizePortCommand

说明：这是从CFOCommand派生的类，它表示改变连接顶点的位置。此类组件之间添加了连接，并且要改变连接顶点的位置时被调用。

头文件：FOSizePortCommand.h

18.CFOSizeSpotCommand

说明：这是从CFOCommand派生的类，它表示改变多边形顶点的位置。此类组件绘制了多边行后，改变顶点的位置时被调用。

头文件：FOSizeSpotCommand.h

19.CFOBasecommandMarco

说明：这是从CFOBaseCommand派生的类，它表示多条命令的基类。

头文件：FOBasecommandMarco.h

20.CFOCommandMarco

说明：这是从CFOBaseCommandMarco派生的类。在执行多条命令的时候会调用此类。

头文件：FOCommandMarco.h

21.CFOAlignCommand

说明：这是从CFOCommandMarco派生的类。它表示对齐组件。在模板中对齐组件的时候将会被调用。

取值：

AlignNone： 不对齐

AlignTop： 上对齐

AlignMiddle： 垂直居中对齐

AlignBottom： 上对齐

AlignLeft： 左对齐

AlignCenter： 水平居中对齐

AlignRight： 右对齐

头文件：FOAlignCommand.h

22.CFOOrderCommand

说明：这是从CFOCommandMarco派生的类。它表示对多个组件进行叠放。当选择了多个组件并且要对它们进行层次叠放的时候将会被调用。

取值类型：

OrderNone： 不进行层次叠放

OrderFront： 把所选择的组件叠放到最上面

OrderBack： 把所选择的组件叠放到最下面向前叠放

OrderForward： 把所选择的组件叠放向上叠放

OrderBackward： 把所选择的组件叠放向下叠放

头文件：FOOrderCommand.h

23.CFOSizeCommand

说明：这是从CFOCommandMarco派生的类。它表示改变多个组件的大小。当选择了多个组件并且要改变它们的大小时将会被调用。

取值类型：

SizeNone: 不调整

SizeHor: 相同的宽度

SizeVer: 相同的高度

SizeAll: 相同的高度和宽度

头文件：FOSizeCommand.h

24.CFOSpacingCommand

说明：这是从CFOCommandMarco派生的类。它表示改变多个组件之间的间距。当选择了多个组件并且要改变它们之间的间距的时候将会被调用。

取值类型：

SpacingNone： 不调整间距

SpacingCross： 在水平方向均匀分布

SpacingDown： 在垂直方向均匀分布

头文件：FOSpacingCommand.h

top


s

首 页

UCanCode主页

下 载

联 系

属性介绍

属性是与对象相关联的一条信息。通过单一的界面来存储和重新取得对象的所有属性，这样提供了一条方便，普通的方法来处理所有属性。由于具有在运行时发现和访问对象的属性的能力，所以可以为访问属性编写普通的服务。例如，同样的串行化代码用来存储和重新取得所有组件的属性。当新属性增加时，不必改变串行化代码。普通的属性浏览器也可以针对对象的属性给它一个相容的界面。

属性类层次图


s

首 页

UCanCode主页

下 载

联 系

属性对象

Form++把属性值作为对象存储在链表中。CFOBaseProperties 类是属性值的基类。从CFOBaseProperties 类派生的类表现出特殊的数据类型或是嵌套的属性。CFOBaseProperties 类与一个属性值相连。

通常，属性值对象只能通过属性容器界面来访问。虽然CFODrawComponent 类提供了直接访问属性值对象的方法，但是一般通过属性容器界面来取得和设置属性值会更方便。有时直接操作嵌套的或混合的属性也很有用。

Property | Description
CFOCompProperties | Component default properties.
CFOFormProperties | Form default properties.
CFOPageProperties | The default properties of Multi page Model's item


s

首 页

UCanCode主页

下 载

联 系

属性ID

每个属性都分配一个唯一的标识符。属性ID值从5000开始。5100和5100以上的属性ID可以被用户所使用，用来定义自己定制的属性。

只要ID值是唯一的，同一类型的组件可以有多于一个的属性。例如，一个组件可以有两个字体属性。

属性ID是用来在链表中查找属性的。你也可以用它识别属性的类型，比如字体属性。在默认状态下，组件属性有一个FO_DEFAULT_PROP_ID的ID值，你可以改变这个ID去标识特定的属性


s

首 页

UCanCode主页

下 载

联 系

取得和设置属性值

1.怎样为一个组件设置属性值？

下面的代码显示了怎样为组件设置属性：

CFOCompProperties pProp = pComp->GetDefaultProperty();
if(pProp != NULL)

{

pProp->SetObjectCaption("New Caption");

pProp->SetObjectName("Name");

}

2.怎样为数据模型设置属性值？

下面的代码显示怎样通过ID获得属性：

CFOPageProperties pProp = pModal->GetDefaultProperty();
if(pProp != NULL)

{

pProp->SetBkColor(RGB(255,0,0));

pProp->SetMinButton(FALSE);

}

3.怎样为组件增加一个新属性？

按下面的去做：

第一步：从windows 开始菜单中打开Form++并运行Form++ Library add-in

第二步：生成一个新的属性类，为新类输入一个名字。例如：CMyCustomProperties。

第三步：打开MyCustomProperties.h文件，在文件开始处插入如下代码：

然后修改构造函数，如下：

第四步：打开你想要把属性增加到的组件类。例如：如果你需要增加这个类到 CMyCorsssLineComponent类中去，就必须首先打开文件MyCorsssLineComponent.cpp，然后插入如下代码：

再插入以下代码：

这样我们就完成了给组件增加属性。你可以用同样的方法给CDataModel 类增加新属性。

4.怎样访问组件的定制属性？

你可以用如下代码访问定制属性：

增加下面的函数：

5.怎样删除组件的定制属性?

你可以用以下代码删除定制属性：

增加下面的函数：

RemoveProperty(ID_MY_PROP_ID)

6.怎样删除组件的全部属性?

你可以用以下代码删除全部定制属性：

增加下面的函数：

ClearAllProp()

7.怎样访问组件的属性列表？

你可以用以下代码访问属性列表：

增加下面的函数：

CFOBasePropertiesList *GetPropList();

9.怎样创建属性备份？

你可以用以下代码创建属性列表备份：

增加下面的函数：

CMyCustomProperties* pCopy = (CMyCustomProperties *)pYourNeedCopyProp->Copy();


属性类

属性是与对象相关联的一条信息。通过单一的界面来存储和重新取得对象的所有属性，这样提供了一条方便，普通的方法来处理所有属性。

1.CFOBaseProperties

所有属性的基类,其他属性类从它继承,本身从CObject类继承。

头文件 ：FOBaseProperties.h

2.CFOCompProperties

这个类从CFOBaseProerties派生。这个类有组件的一些属性，比如标题，画笔，字体，画刷和文本排列等。每个组件都有它自己的属性，因此它们的属性也许不一样。你可以设置每个组件的以上属性。

头文件 ：FOComProperties.h

3.CFOFormProperties

这个类从CFOBaseProerties类派生，有模板的一些属性，比如标题，风格，字体和其它属性。你可以设置模板的以上属性。

头文件：FOFormProperties.h

4.CFOPageProperties

这个类从CFOBaseProerties类派生，有页的一些属性，比如标题，背景色和前景色。你可以设置页的以上属性。

头文件 ：FOPageProperties.h

top


属性对话框设置

首 页

UCanCode主页

下 载

联 系

属性对话框

组件属性表是一系列允许用户定制一个或多个组件属性的属性页。每个 CPropertySheet封装了组件属性的实现。每个对话框都有一个相应的类。这一节讲述了用于执行属性表的每一个类。

普通属性对话框

普通属性对话框，显示所选组件的普通属性，组件类型，名字，是否可见，文本水平和垂直排列方式，字体。用户可以对组件的名字，是否可见，文本水平和垂直排列方式，字体进行设置。例如：

线型属性对话框

填充属性对话框(新增)

Tab 属性对话框

阴影属性对话框

top


s

首 页

UCanCode主页

下 载

联 系

对话框简介

Form++提供了很多的对话框资源，要使用这些资源，你要在菜单中或者工具条增加必要的命令。选择合适的ID值，库中的基本控制类已为你提供了实现。

对话框类层次图

top


s

首 页

UCanCode主页

下 载

联 系

组件属性对话框

组件属性表是一系列允许用户定制一个或多个组件属性的属性页。每个 CPropertySheet封装了组件属性的实现。每个对话框都有一个相应的类。这一节讲述了用于执行属性表的每一个类。

普通属性对话框

普通属性对话框，显示所选组件的普通属性，组件类型，名字，是否可见，文本水平和垂直排列方式，字体。用户可以对组件的名字，是否可见，文本水平和垂直排列方式，字体进行设置。例如：

线型属性对话框

填充属性对话框(新增)

Tab 属性对话框

阴影属性对话框

top


s

首 页

UCanCode主页

下 载

联 系

其他对话框

1.CFOComponentSelectDlg

组件对话框

组件对话框， 显示在当前激活页上的所有组件的名字和类型，用户可以浏览组件或是删除.

2.CFOColorPaletteDialogBar

调色板对话条，在选择模板状态为资源编辑器时，用户可以用它对模板的背景颜色，文本颜色的属性进行设置。在通常状态下背景颜色，文本颜色的属性为缺省值，不出现这个对话框。

3.CFOGridPropDlg

可以来设置网格属性。用户可以设置网格间距、颜色和是否可见。窗体视图基类打开该对话框当它接收到ID_FO_GRID_PROP命令消息时。

4.CFOPagePropDlg

窗体对话框是使用户确认窗体设置信息的。用户可以设置标题、字体和许多其他属性。窗体视图基类打开该对话框当它接收到ID_FO_FORM_SETTING命令消息时。

5.CFOColorDialog

这个对话框用来定制颜色，也可以通过select按钮提供的提取已有图片的颜色，来达到与背景颜色搭配的效果。

6.CFOPrintHeaderFooterDlg

这是类似于Microsoft visio风格的页眉和页脚设置对话框。

7.CFOImageEditDlg

使用这个对话框编辑工具盒中项目的图标。

7.CFOImageFillProp

使用这个对话框改变CFOImageComponent的透明颜色。

8.CFOTypeValueDlg

使用这个对话框改变工具盒中项目的名称和类型。

9.CFOHyLinkProp

使用这个对话框设置CFOHyperComponent的属性。

10.CFOTextBulletDlg

为了表示各个项目之间的关系，我们用项目符号来区分。如下图：

显示的样式为:

top


s

首 页

UCanCode主页

下 载

联 系

下拉颜色选择器

Form++下拉颜色选择器提供了一个高级的颜色选择控件。用户单击格子中的每一个单元格就可以选择颜色了。这个控件包含一个定制按钮。当选中这个按钮时，一个颜色选择对话框就会弹出。这就允许你选择其他颜色而不是在格子中显示的颜色。

1.颜色选择控件

Form++颜色选择类的层次图如下所示：

  • CFOColorCellObj
  • CFODropColorPaletteControl
  • CFODropColorPaletteWnd

CFOColorCellObj

CFOColorCellObj类由CObject类派生而来，用来显示颜色单元格。

CFODropColorPaletteControl

CFODropColorPaletteControl类由CObject派生而来，用来显示颜色选择器。

CFODropColorPaletteWnd

CFODropColorPaletteWnd类由CWnd派生而来，用来嵌入一个对话窗口或CFormView。颜色单元格也会自动地调整它的大小来显示它的内容，并且它有一个三维边界。CFODropColorPaletteWnd可以随意地支持选择颜色的调色板的实现。（例如从当前的逻辑调色板到系统调色板。）

当选择了一个新的颜色后，CFODropColorPaletteWnd类发送一个WM_FO_SELECTCOLOROK消息给它的父窗口。

使用CFODropColorPaletteWnd

若要把CFODropColorPaletteWnd类整和到你的代码中：

  • 用Create()函数创建一个CFODropColorPaletteWnd类窗口，指定该控件是否有定制按钮。如果要把颜色单元格嵌入到对话框中，则要在对话框基本单元中指定x坐标和y坐标。
  • 调用GetColorControl()->SetRGB()函数设置最初的选择颜色。
  • 调用GetColorControl()->GetRGB()函数获得当前选择的颜色。

2.下拉颜色选择器

Form++下拉颜色选择器类提供了一个专门的颜色选择器用来显示和选择颜色。该控件包括一个弹出下拉颜色单元格的箭头。

Form++下拉颜色选择器类层次图：

  • CFOColorCellObj
  • CFODropColorPaletteControl
  • CFODropColorPaletteWnd
  • CFOPopupColorPaletteWnd
  • CFOColorButton

CFOColorCellObj

CFOColorCellObj类由CObject类派生而来，它用来显示颜色单元格。

CFODropColorPaletteControl

CFODropColorPaletteControl类由 CObject类派生而来，它用来显示颜色选择器。

CFODropColorPaletteWnd

CFODropColorPaletteWnd类由CWnd类派生而来，用来嵌入一个对话窗口或CFormView。颜色单元格也会自动地调整它的大小来显示它的内容，并且它有一个三维边界。CFODropColorPaletteWnd可以支持任意选择颜色的调色板的实现。（例如从当前的逻辑调色板到系统调色板。）

CFOPopupColorPaletteWnd

CFOPopupColorPaletteWnd类由 CFODropColorPaletteWnd 类派生而来，用来显示一个弹出的下拉窗口。

当选择一个新的颜色后，CFOPopupColorPaletteWnd类发送WM_FO_SELECTCOLOROK消息给它的父窗口。

CFOColorButton

CFOColorButton类增加了一个类似于组合框和下拉框的按钮到按钮控件中。用户单击按钮的箭头，就会弹出一个颜色选择器。

当选择一个新的颜色后，CFOColorButton类发送以下消息给它的父窗口。

WM_FO_SELECTCOLOROK -- 确认选择颜色WM_FO_SELECTCOLORCANCEL -- 取消选择颜色WM_FO_SELECTCOLORCUSTOM -- 选择定制颜色WM_FO_SELECTCOLORCHANGE -- 选择改变颜色

使用CFOColorButton

下面将讲述如何使用CFOColorButton类

若要在对话框中使用颜色选择器：

  • 在资源编辑器的对话框资源中新建一个按钮控件

  • 给颜色选择器按钮增加两个数据成员
    CFODropColorButton m_btnTextColor;
    COLORREF m_crColor;

  • 在对话框的DoDataExchange(CDataExchange* pDX)

    函数中增加以下代码：
DDX_Control(pDX,IDC_FO_COLOR_CUSTOM,m_btnTextColor);
//}}AFX_DATA_MAP
DDX_FODropColorButton(pDX,IDC_FO_COLOR_CUSTOM,m_crColor);
  • 调用SetColor()函数设置控件的颜色。例如：
    m_btnTextColor.SetColor(RGB(255,0,0));

  • 调用GetColor()函数获得控件的颜色。例如：
    m_btnTextColor.GetColor();

3.Color Select Dialog

CFOColorDialog类封装了颜色选择对话框。在对话框中可以选择一个标准的颜色（在系统调色板中），并且显示一个可以选择定制颜色的定制按钮。颜色选择器提供了一个选择按钮 [image] ，当你在选择按钮上按住鼠标左键时，鼠标指针会变成类似于Photoshop and Frontpage 2000中的颜色滴管 [image] 。 你可以通过这个滴管获得屏幕上的任何一种颜色。

Form++颜色对话框类层次图：

使用CFOColorDialog

下面将讲述如何使用CFOColorDialog类

若要使用颜色选择器：

  • 你可以在栈上构建一个CFOColorDialog对象，然后调用DoModal函数。你可以把最初的颜色作为CFOColorDialog 构造函数做为参数。

  • 调用SetColor()方法设置对话框的颜色。例如：
    dlg.SetColor(RGB(255,0,0));

  • 调用GetColor()方法得到对话框的颜色。例如：
    dlg.GetColor();

4.调色板工具栏

CFOColorPaletteDialogBar封装了颜色选择对话框工具栏。该对话框工具栏可以选择标准颜色（在系统调色板中）。

Form++颜色对话框工具栏类层次图：

  • CFOColorCellObj
  • CFOColorPaletteControl
  • CFOColorPaletteDialogBar

CFOColorCellObj

CFOColorCellObj类由CObject类派生而来，它用来显示颜色单元格。

CFOColorPaletteControl

CFOColorPaletteControl类由CObject派生而来，用来显示颜色选择器。

CFOColorPaletteDialogBar

CFOColorPaletteDialogBar类由CDialogBar类派生而来，用来嵌入在对话框工具栏或CFrameWnd类。颜色单元格也会自动地调整它的大小来显示它的内容，并且它有一个三维边界。CFOColorPaletteDialogBar 可以支持任意选择颜色的调色板的实现。（例如从当前的逻辑调色板到系统调色板。）

使用 CFOColorPaletteDialogBar

下面将讲述如何使用CFOColorPaletteDialogBar类

若要使用颜色对话框工具栏：

  • 从基类CFOColorPaletteDialogBar派生出一个新类 CMyColorPaletteBar。
  • 增加以下2个函数：

    // Attributes
    public:
    virtual void OnUpdateCmdUI(CFrameWnd* pTarget, BOOL bDisableIfNoHndler);
    virtual void OnColorChange(COLORREF crColor,BOOL bLine);

          /////////////////////////////////////////////////////////////////////////////
// CMyColorPaletteBar message handlers
void CMyColorPaletteBar::OnUpdateCmdUI(CFrameWnd* /*pTarget*/, BOOL /*bDisableIfNoHndler*/)
{
CFrameWnd *pParent =
      STATIC_DOWNCAST(CFrameWnd,AfxGetMainWnd());
ASSERT_VALID(pParent);
COLORREF crTemp;
COLORREF crBack;
COLORREF crLine;
CFOBaseView* pView = (CFOBaseView*)(pParent->GetActiveFrame()->GetActiveView());
if(pView != NULL && pView->IsKindOf(RUNTIME_CLASS(CFOBaseView)))
{
if (pView->GetColorAndPositionAtCursor(crBack,crTemp,crLine))
{
SetColors(crLine,crBack);
}
}
}

void CMyColorPaletteBar::OnColorChange(COLORREF crColor,BOOL bLine)
{
CFrameWnd *pParent =
      STATIC_DOWNCAST(CFrameWnd,AfxGetMainWnd());
ASSERT_VALID(pParent);
CFOBaseView* pView = (CFOBaseView*)(pParent->GetActiveFrame()->GetActiveView());
if(pView != NULL && pView->IsKindOf(RUNTIME_CLASS(CFOBaseView)))
{
FO_COLOR *m_color = new
      FO_COLOR;
m_color->crText = m_crText;
m_color->crBack = m_crBack;
pView->SendMessage(WM_FO_COLORHASCHANGED,(WPARAM)m_color);
}
}
  • 给颜色选择器按钮的CMainFrame类增加一个数据成员。例如：CMyColorPaletteBar m_wndColorBar;
  • 在OnCreate()函数中增加以下代码：

    // Initialize dialog bar m_wndMyDialogBar
    if (!m_wndColorBar.Create(this, IDD_FO_COLORBAR,
    CBRS_TOP | CBRS_TOOLTIPS | CBRS_FLYBY | CBRS_HIDE_INPLACE,
    3004))
    {
    TRACE0("Failed to create dialog bar m_wndMyDialogBar\n");
    return -1; // fail to create
    }
    ShowControlBar(&m_wndColorBar,FALSE,FALSE);
    m_wndColorBar.SetWindowText("Colors");
    m_wndColorBar.InitPalette();

    m_wndColorBar.EnableDocking(CBRS_ALIGN_TOP);
    EnableDocking(CBRS_ALIGN_ANY);

    FloatControlBar(&m_wndColorBar,CPoint(400,100));

在Form++Samples\CustomMSample文件夹的CustomMSample示例中你将看到CFOColorPaletteDialogBar类以及它支持的类的使用。


Drop down line type picker

首 页

UCanCode主页

下 载

联 系

下拉线形选择器

Form++下拉线形选择器类提供了一个高级的线形选择控件。用户单击格子中的每一个单元格就可以选择线形了。这个控件包含一个定制按钮。当选中这个按钮时，一个线形选择对话框就会弹出。

下拉线形选择器

Form++下拉线形选择器类提供了一个专业的线形选择器用于选择和显示线形。

Form++下拉线形选择器类层次图：

  • CFOLineTypeCellObj
  • CFOLineTypeControl
  • CFOLineTypeWnd
  • CFOPopup LineType Wnd
  • CFODrop LineType Button

CFOLineType Cell Obj

CFOLineTypeCellObj类由CObject类派生而来，用来显示线形单元格。

CFOLineTypeControl

CFOLineTypeControl类由CObject类派生而来，用来显示线形选择器。

CFOLineTypeWnd

CFOLineTypeWnd类由CWnd类派生而来，用来嵌入在对话框窗口或CFormView类. 线形单元格也会自动地调整它的大小来显示它的内容，并且它有一个三维边界。

CFOPopupLineTypeWnd

CFOPopupLineTypeWnd类由CFOLineTypeWnd类派生而来，用来显示弹出的下拉窗口。

当选择了一个新的线形后，CFOPopupLineTypeWnd类会发送WM_FO_SELECTLINETYPEOK消息给它的父窗口。

CFODropLineTypeButton

CFODropLineTypeButton类增加了一个类似于组合框和下拉框的按钮到按钮控件中。用户单击按钮的箭头，就会弹出一个线形选择器。

当选择了一个新的线形后，CFODropLineTypeButton类会发送以下消息给它的父窗口。

WM_FO_SELECTLINETYPEOK-- 确认选择线形WM_FO_SELECTLINETYPECANCEL-- 取消选择线形
WM_FO_SELECTLINETYPECUSTOM-- 选择定制线形
WM_FO_SELECTLINETYPECHANGE-- 选择变化线形

使用CFOLineTypeButton

下面将讲述如何使用CFOLineTypeButton类

若要在对话框中使用线形选择器：

  • 在资源编辑器的对话框资源中新建一个按钮控件。

  • 给线形选择按钮的对话框类增加两个数据成员，例如：
    CFODropLineTypeButton m_wndLineType;
    int m_nLineType;

  • 在对话框的DoDataExchange(CDataExchange* pDX)函数中增加以下代码：
    DDX_Control(pDX,IDC_FO_LINETYPE_CUSTOM,m_wndLineType);
    //}}AFX_DATA_MAP
    DDX_FODropLineTypeButton(pDX,IDC_FO_LINETYPE_CUSTOM,m_wndLineType);

  • 调用SetLineType()函数设置线形。例如：
    m_wndLineType.SetLineType(PS_DASH);

  • 调用GetLineType() 函数获得线形。例如：
    m_wndLineType.GetLineType();


Drop down line width picker

首 页

UCanCode主页

下 载

联 系

下拉线宽选择器

Form++下拉线宽选择器类提供了一个高级的线宽选择控件。用户单击格子中的每一个单元格就可以选择线宽了。这个控件包含一个定制按钮。当选中这个按钮时，一个线宽选择对话框就会弹出。

下拉线宽选择器

Form++下拉线宽选择器类提供了一个专业的线宽选择器用于选择和显示线宽。

Form++下拉线宽选择器类层次图：

  • CFOLineWidthCellObj
  • CFOLineWidthControl
  • CFOLineWidthWnd
  • CFOPopup LineWidth Wnd
  • CFODrop LineWidth Button

CFO LineWidthCell Obj

CFOLineWidthCellObj类由CObject类派生而来，用来显示线宽单元格。

CFOLineWidthControl

CFOLineWidthControl 类由CObject类派生而来，用来显示线宽选择器。

CFOLineWidthWnd

CFOLineWidthWnd 类由CWnd类派生而来，用来嵌入在对话框窗口或CFormView类. 线宽单元格也会自动地调整它的大小来显示它的内容，并且它有一个三维边界。

CFOPopupLineWidthWnd

CFOPopupLineWidthWnd 类由 CFOLineWidthWnd 类派生而来，用来显示弹出的下拉窗口。

当选择了一个新的线宽后，CFOPopupLineWidthWnd类会发送WM_FO_SELECTLINEWIDTHOK消息给它的父窗口。

CFODropLineWidthButton

CFODropLineWidthButton类增加了一个类似于组合框和下拉框的按钮到按钮控件中。用户单击按钮的箭头，就会弹出一个线宽选择器。

当选择了一个新的线宽后，CFODropLineWidthButton类会发送以下消息给它的父窗口。

WM_FO_SELECTLINEWIDTHOK-- 确认选择线宽
WM_FO_SELECTLINEWIDTHCANCEL-- 取消选择线宽
WM_FO_SELECTLINEWIDTHCUSTOM-- 选择定制线宽
WM_FO_SELECTLINEWIDTHCHANGE-- 选择变化线宽

使用CFOLineWidthButton

下面将讲述如何使用CFOLineWidthButton类

若要在对话框中使用线宽选择器：

  • 在资源编辑器的对话框资源中新建一个按钮控件。

  • 给线宽选择按钮的对话框类增加两个数据成员，例如：CFODropLineWidthButton m_wndLineWidth;
    int m_nLineWidth;

  • 在对话框的DoDataExchange(CDataExchange* pDX)函数中增加以下代码：DDX_Control(pDX,IDC_FO_LINEWIDTH_CUSTOM,m_wndLineWidth);
    //}}AFX_DATA_MAP
    DDX_FODropLineWidthButton(pDX,IDC_FO_LINEWIDTH_CUSTOM,m_wndLineWidth);

  • 调用SetLineWidth()函数设置线宽。例如：
    m_wndLineWidth.SetLineWidth(2);

  • 调用SetLineWidth()函数获得线宽。例如：
    m_wndLineWidth.SetLineWidth();


Drop down arrow picker

首 页

UCanCode主页

下 载

联 系

下拉箭头选择器

Form++下拉线宽选择器类提供了一个高级的线宽选择控件。用户单击格子中的每一个单元格就可以选择线宽了。这个控件包含一个定制按钮。当选中这个按钮时，一个线宽选择对话框就会弹出。

下拉箭头选择器

Form++下拉箭头选择器类提供了一个专业的箭头选择器用于选择和显示箭头。

Form++下拉箭头选择器类层次图：

  • CFOArrowTypeCellObj
  • CFOArrowTypeControl
  • CFOArrowTypeWnd
  • CFOPopup ArrowType Wnd
  • CFODrop ArrowType Button

CFOArrowType Cell Obj

CFOArrowTypeCellObj 类由CObject类派生而来，用来显示箭头单元格。

CFOArrowTypeControl

CFOArrowTypeControl类由CObject类派生而来，用来显示箭头选择器。

CFOArrowTypeWnd

CFOArrowTypeWnd 类由CWnd类派生而来，用来嵌入在对话框窗口或CFormView类. 箭头单元格也会自动地调整它的大小来显示它的内容，并且它有一个三维边界。CFOArrowTypeWnd类支持任意选择始端箭头和尾端箭头类型。

CFOPopupArrowTypeWnd

CFOPopupArrowTypeWnd 类由CFOArrowTypeWnd 类派生而来，用来显示弹出的下拉窗口。

当选择了一个新的箭头后，CFOPopupArrowTypeWnd类会发送WM_FO_SELECTARROWTYPEOK消息给它的父窗口。

CFODropArrowTypeButton

CFODropArrowTypeButton 类增加了一个类似于组合框和下拉框的按钮到按钮控件中。用户单击按钮的箭头，就会弹出一个箭头选择器。

当选择了一个新的箭头后，CFODropArrowTypeButton类会发送以下消息给它的父窗口。

WM_FO_SELECTARROWTYPEOK-- 确认选择箭头
WM_FO_SELECTARROWTYPECANCEL-- 取消选择箭头
WM_FO_SELECTARROWTYPECUSTOM-- 选择定制箭头
WM_FO_SELECTARROWTYPECHANGE-- 选择变化箭头

使用CFOArrowTypeButton

下面将讲述如何使用CFOArrowTypeButton 类

若要在对话框中使用箭头选择器：

  • 在资源编辑器的对话框资源中新建一个按钮控件。

  • 给箭头选择按钮的对话框类增加两个数据成员，例如：
    CFODropArrowTypeButton m_wndEndArrow;
    int m_nEndArrowLength;

  • 在对话框的DoDataExchange(CDataExchange* pDX)函数中增加以下代码：
    DDX_Control(pDX,IDC_FO_ARROW_CUSTOM,m_wndEndArrow);
    //}}AFX_DATA_MAP
    DDX_FODropArrowTypeButton(pDX,IDC_FO_ARROW_CUSTOM,m_nEndArrowLength);

  • 调用SetArrowType()函数设置箭头。例如：
    m_wndEndArrow.SetArrowType(1);

  • 调用GetArrowType()函数获得箭头。例如：
    m_wndEndArrow.GetArrowType();


Brush

首 页

UCanCode主页

下 载

联 系

选择画刷类型

Form++画刷类型类提供了高级的画刷选择控件。用户可以选择单元格的画刷类型来填充控件。

画刷类型窗口

Form++ Library画刷类型类层次图：

  • CFOBrushTypeCellObj
  • CFOBrushTypeControl
  • CFOBrushTypeWnd

CFOBrushTypeCellObj

CFOColorCellObj类由CObject派生而来，它显示画刷类型单元格。

CFOBrushTypeControl

CFOBrushTypeControl类由CObject派生而来，用来显示画刷类型选择器。

CFOBrushTypeWnd

CFOPopupBrushTypeWnd类由CWnd 类派生而来，用来嵌入在对话窗口或CFormView类。

当选择了一个新的画刷类型后，CFOBrushTypeWnd类会发送WM_FO_SELECTBRUSHYPEOK消息给它的父窗口。

使用 CFOBrushTypeWnd

若要将CFOBrushTypeWnd类整合到代码中：

  • 用Create()新建一个CFOBrushTypeWnd类窗口，然后指定控件是否有定制按钮。
  • 调用GetBrushControl()->SetBrushType(1)函数设置初始画刷类型。
  • 调用GetBrushControl()->GetBrushType()函数获得当前画刷类型。


Select Gradient Type

首 页

UCanCode主页

下 载

联 系

选择阴影类型

Form++阴影类型类提供了高级的阴影选择控件。用户可以选择单元格的阴影类型来填充控件。

阴影类型窗口

Form++ Library阴影类型类层次图：

  • CFOGradientTypeCellObj
  • CFOGradientTypeControl
  • CFOGradientTypeWnd

CFOGradientTypeCellObj

CFOGradientTypeCellObj 类由CObject派生而来，它显示阴影类型单元格。

CFOGradientTypeControl

CFOGradientTypeControl 类由CObject派生而来，用来显示阴影类型选择器。

CFOGradientTypeWnd

CFOGradientTypeWnd 类由CWnd 类派生而来，用来嵌入在对话窗口或CFormView类。

当选择了一个新的阴影类型后，CFO Gradient TypeWnd类会发送WM_FO_SELECTGRADIENTTYPEOK消息给它的父窗口。

使用CFOGradientTypeWnd

若要将CFOGradientTypeWnd 类整合到代码中：

  • 用Create()新建一个CFOGradientTypeWnd 类窗口，然后指定控件是否有定制按钮。
  • 调用GetGradientControl()->SetGradientType(1)函数设置初始阴影类型。
  • 调用GetGradientControl()->GetGradientType()函数获得当前阴影类型。


Select Image Type

首 页

UCanCode主页

下 载

联 系

选择图象类型

Form++图象类型类提供了高级的图象选择控件。用户可以选择单元格的图象类型来填充控件。

图象类型窗口

Form++ Library图象类型类层次图：

  • CFOImageTypeCellObj
  • CFOImageTypeControl
  • CFOImageTypeWnd

CFOImageTypeCellObj

CFOImageTypeCellObj 类由CObject派生而来，它显示图象类型单元格。

CFOImageTypeControl

CFOImageTypeControl 类由CObject派生而来，用来显示图象类型选择器。

CFOImageTypeWnd

CFOImageTypeWnd 类由CWnd 类派生而来，用来嵌入在对话窗口或CFormView类。

当选择了一个新的图象类型后，CFO Image TypeWnd类会发送WM_FO_SELECTIMAGETYPEOK消息给它的父窗口。

使用CFOImageTypeWnd

若要将CFOImageTypeWnd 类整合到代码中：

  • 用Create()新建一个CFOImageTypeWnd 类窗口，然后指定控件是否有定制按钮。
  • 调用GetImageTypeControl()->SetImageType(1)函数设置初始图象类型。
  • 调用GetImageTypeControl()->GetImageType() 函数获得当前图象类型。


s

首 页

UCanCode主页

下 载

联 系

Form++工具盒窗口

1.工具盒窗口

Form++工具盒外观感觉与Microsoft Visio很相似。因为工具盒窗口本身时一个CWnd的派生类，所以它可以在任意地方嵌入，比如象停靠窗口、对话框甚至是框架窗口的整个客户区。

Form++工具盒窗口类层次图：

  • CFOToolBoxItem
  • CFOToolBoxPage
  • CFOToolBoxPageWnd
  • CFOMultiToolBoxWnd

CFOMultiToolBoxWnd

CFOMultiToolBoxWnd类由CWnd派生而来，它起到一个包含其他页对象的容器类的作用。因为它是从CWnd派生而来的，所以CFOMultiToolBoxWnd类也可以被其它由CWnd类派生的类包含。

显示在CFOMultiToolBoxWnd类窗口的页是CFOToolBoxPage类的示例。你可以用AddPage()函数创建它们。

CFOToolBoxPage

CFOToolBoxPage类对象代表用户可以选择的单独一页。它显示在CFOMultiToolBoxWnd类窗口。当调用AddPage()函数时，CFOToolBoxPage类就会被创建。

CFOToolBoxPageWnd

CFOToolBoxPageWnd类由CWnd派生而来，它起到包含一页中所有对象的容器类的作用。在这个窗口中你可以新建、复制、粘贴和删除对象。

CFOToolBoxPageWnd类也包含一个指向当前CFOToolBoxPage对象的指针。

使用CFOMultiToolBoxWnd

  • 若要整合CFOMultiToolBoxWnd类到你的应用程序中，在父窗口的中，按照如下方法，添加CFOMultiToolBoxWnd类对象：CFOMultiToolBoxWnd m_wndTool;
  • 在新建父框架时，调用CFOMultiToolBoxWnd ::Create()函数创建工具盒窗口，例如：

    m_wndTool.Create(WS_CHILD|WS_VISIBLE|WS_EX_CLIENTEDGE,CRect(0,0,100,100),this,1232);

    m_wndTool.AddPage("New");
    m_wndTool.ActivatePage(0);

  • 调用AddPage()函数增加页。例如：

    m_wndTool.AddPage("New");
    m_wndTool.ActivatePage(0);

  • 调用ActivatePage()函数激活指定页。
  • 调用SelectPage()函数选择页。
  • 调用RemovePage() 函数删除指定页。
  • 调用RenamePage()函数重命名指定页。
  • 调用CFOToolBoxPage& GetActivePage()函数得到激活页对象。
  • 调用GetPage()函数得到指定页对象。
  • 调用GetToolBoxWnd()函数得到指向包含CFOToolBoxPageWnd类窗口对象的页的指针。
  • 要输出当前选中的页上的新对象，你必须调用CFOToolBoxPageWnd类对象的RemoveItem()函数，例如：

    m_wndTool.GetToolBoxWnd()->RemoveItem(pItem);
  • 要从文件中导入新资源，你可以用以下代码：

    m_wndTool.GetToolBoxWnd()->LoadResFile("test.trs");
  • 要向当前选中的页增加一个新项目，你首先需要得到CFOToolBoxPageWnd对象：

    CFOToolBoxItem * pItem = m_wndTool.GetToolBoxWnd()->AddNewItem();

    // Init your item data below.

  • 要改变绘制页的方式，你需要从CFOMultiToolBoxWnd类派生出新类，并且增加画图函数。

2.工具盒

Form++CFOMultiToolBoxBar类封装了类似于Microsoft visio like 风格的组件。

Form++CFOMultiToolBoxBar类层次图：

  • CFOToolBoxItem
  • CFOToolBoxPage
  • CFOToolBoxPageWnd
  • CFOMultiToolBoxWnd
  • CFOMultiToolBoxBar

CFOMultiToolBoxWnd

CFOMultiToolBoxWnd 类由CWnd派生而来，它起到包含一页中所有对象的容器类的作用。因为它是从CWnd派生而来的，所以CFOMultiToolBoxWnd类也可以被其它由CWnd类派生的类包含。

显示在CFOMultiToolBoxWnd类窗口的页是CFOToolBoxPage类的示例。你可以用AddPage()函数创建它们。

CFOToolBoxPage

CFOToolBoxPage类对象代表用户可以选择的单独一页。它显示在CFOMultiToolBoxWnd类窗口。当调用AddPage()函数时，CFOToolBoxPage类就会被创建。

CFOToolBoxPageWnd

CFOToolBoxPageWnd类由CWnd派生而来，它起到包含一页中所有对象的容器类的作用。在这个窗口中你可以新建、复制、粘贴和删除对象。

CFOToolBoxPageWnd类也包含一个指向当前CFOToolBoxPage对象的指针。

CFOMultiToolBoxBar

CFOMultiToolBoxBar类由CDialogBar类派生而来，用来嵌入在对话框工具栏或CFrameWnd窗口中。该工具盒窗口会根据其内容自动调整大小，并且有一个三维边界。CFOMultiToolBoxBar类支持任意调色板下选择颜色。

使用CFOMultiToolBoxBar

下面将讲述如何使用CFOMultiToolBoxBar类

若要使用CFOMultiToolBoxBar类

  • 给颜色选择器按钮的CMainFrame类增加一个数据成员。例如：
    CFOMultiToolBoxBar m_FileBar;
  • 在OnCreate()函数中增加以下代码：

          if (!m_FileBar.Create(this,ID_VIEW_TOOLBOX,_T("Docking Window"),CSize(200,
      150)))
{
TRACE0("Failed to create m_FileBar\n");
return -1; // fail to create
}

m_FileBar.SetBarStyle(m_FileBar.GetBarStyle() |
CBRS_TOOLTIPS | CBRS_FLYBY | CBRS_SIZE_DYNAMIC);

m_FileBar.EnableDocking(CBRS_ALIGN_ANY);

    EnableDocking(CBRS_ALIGN_ANY);

    DockControlBar(&m_FileBar, AFX_IDW_DOCKBAR_LEFT);

在 Form++的Samples\CustomMSample文件夹里的CustomMSample示例展示了如何使用CFOMultiToolBoxBar类和它支持的类。


窗体类

首 页

UCanCode主页

下 载

联 系

其它窗口

Form++ 提供了几个窗体和执行一般用户 界面活动的控制类。这些窗体可以被绝大多数Form++的应用程序开发者所使用。为了给你的应用程序增加这些窗体，你需要给你的程序用适当的命令ID来添加菜单和按钮。基本控制类已经有这些窗体的消息句柄，这些句柄可以提供给你使用。

窗体类

目前Form++提供以下窗体类：

1.CFOPaintWnd

说明：这是从MFC的CWnd类中派生的类。它显示设置图标形状的窗体。当你需要给图标设置一个形状时，这个窗体将会显示你给图标所设置的外型。

头文件：FOPaintWnd.h

2.CFOHorRulerBar

说明：这是从MFC的CControlBar类中派生的类。它显示水平标尺。当显示水平标尺的时候调用此类。

头文件：FOHorRulerBar.h

3.CFOVertRulerBar

说明：这是从MFC的CControlBar类中派生的类。它显示垂直标尺。当显示垂直标尺的时候调用此类。

头文件：FOVertRulerBar.h

4.CFOBulletTypeWnd (新增)

说明：这是从MFC的CWnd类中派生的类。它用来显示项目符号窗口。如下：

头文件：FOBulletTypeWnd.h

top


Home

首 页

UCanCode主页

下 载

联 系

箭头类简介

Form++提供了足够的资源和控制类来进行用户交互。利用Form++进行开发时，你要填加资源只需要从属性对话框中进行选择。所有的实现以封装在Form++类库中。而且，你可以利用Form++类库轻松填加自己的资源样式。

下面是类库提供的箭头资源，你可以根据你的需要使用：
点击 这里 阅读类继承图。

back


Caption

首 页

UCanCode主页

下 载

联 系

箭头类列表

类继承图 详细描述了类库中类的关系。

类分布在以下的目录中。

CFOXArrowObject | Base class name:CFOBaseEndObject, Defined in:FOXArrowObject.h
CFOXAntennaArrowObject | Base class name:CFOBaseEndObject, Defined in: FOXAntennaArrowObject.h
CFOTRoundArrowObject | Base class name:CFOBaseEndObject, Defined in:FOTRoundArrowObject.h
CFOTriCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FOTriCrossArrowObject.h
CFOTArrowObject | Base class name:CFOBaseEndObject, Defined in:FOTArrowObject.h
CFOSRoundTriCrossObject | Baseclassname:CFOBaseEndObject,Definedin:FOSRoundTriCrossObject.h
CFOSRoundTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSRoundTriArrowObject.h
CFOSRoundRTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSRoundRTriArrowObject.h
CFOSRoundFlagArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSRoundFlagArrowObject.h
CFOSRoundCrossObject | Base class name:CFOBaseEndObject, Defined in:FOSRoundCrossObject.h
CFOSRoundBiCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSRoundBiCrossArrowObject.h
CFOSolidTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSolidTriArrowObject.h
CFOSolidRTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSolidRTriArrowObject.h
CFOSolidRoundArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSolidRoundArrowObject.h
CFOSolidRectArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSolidRectArrowObject.h
CFOSolidFlagArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSolidFlagArrowObject.h
CFOSolidArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSolidArrowObject.h
CFOSBiTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOSBiTriArrowObject.h
CFORounTriCrossArrowObject | Baseclassname:CFOBaseEndObject,Definedin:FORounTriCrossArrowObject.h
CFORounTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FORounTriArrowObject.h
CFORoundRTriArrowObject | Base class name:CFOBaseEndObject, Defined in: FORoundRTriArrowObject.h
CFORoundFlagArrowObject | Base class name:CFOBaseEndObject, Defined in:FORoundFlagArrowObject.h
CFORoundCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FORoundCrossArrowObject.h
CFORoundBiCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FORoundBiCrossArrowObject.h
CFONormalCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FONormalCrossArrowObject.h
CFONormalArrowObject | Base class name:CFOBaseEndObject, Defined in:FONormalArrowObject.h
CFOLineArrowObject | Base class name:CFOBaseEndObject, Defined in:FOLineArrowObject.h
CFOEmptyTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOEmptyTriArrowObject.h
CFOEmptyRTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOEmptyRTriArrowObject.h
CFOEmptyRoundArrowObject | Base class name:CFOBaseEndObject, Defined in:FOEmptyRoundArrowObject.h
CFOEmptyRectArrowObject | Base class name:CFOBaseEndObject, Defined in:FOEmptyRectArrowObject.h
CFOEmptyFlagArrowObject | Base class name:CFOBaseEndObject, Defined in:FOEmptyFlagArrowObject.h
CFOEmptyArrowObject | Base class name:CFOBaseEndObject, Defined in:FOEmptyArrowObject.h
CFOCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FOCrossArrowObject.h
CFOBiTriArrowObject | Base class name:CFOBaseEndObject, Defined in:FOBiTriArrowObject.h
CFOBiNormalCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FOBiNormalCrossArrowObject.h
CFOBiCrossArrowObject | Base class name:CFOBaseEndObject, Defined in:FOBiCrossArrowObject.h
CFOAntennaRoundArrowObject | Base class name:CFOBaseEndObject, Defined in:FOAntennaRoundArrowObject.h
CFOAntennaArrowObject | Base class name:CFOBaseEndObject, Defined in:FOAntennaArrowObject.h


Arrows Class Hierarchy

首 页

UCanCode主页

下 载

联 系

箭头类层次图

要了解详细信息，请点击这里。

back


Home

首 页

UCanCode主页

下 载

联 系

箭头类

The CFOAntennaArrow Class

CFOAntennaArrowObject继承了基类CFOBaseEndObject.

绘制效果 :

CFOAntennaRoundArrowObject

CFOAntennaRoundArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOBiCrossArrowObject

CFOBiCrossArrowObjectClass继承了基类CFOBaseEndObject

绘制效果 :

CFOBiNormalCrossArrowObject

CFOBiNormalCrossArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOBiTriArrowObject

CFOBiTriArrowObjectClass继承了基类CFOBaseEndObject

绘制效果 :

CFOCrossArrowObject

CFOCrossArrowObjectClass继承了基类CFOBaseEndObject

绘制效果 :

CFOEmptyArrowObject

CFOEmptyArrowObjectClass继承了基类CFOBaseEndObject

绘制效果 :

CFOEmptyFlagArrowObject

CFOEmptyFlagArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOEmptyRectArrowObject

CFOEmptyRectArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOEmptyRoundArrowObject

CFOEmptyRoundArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOEmptyRTriArrowObject

CFOEmptyRTriArrowObject继承了基类 CFOBaseEndObject

绘制效果 :

CFOEmptyTriArrowObject

CFOEmptyTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOLineArrowObject

CFOLineArrowObjectClass继承了基类CFOBaseEndObject

绘制效果 :

CFONormalArrowObject

CFONormalArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFONormalCrossArrowObject

CFONormalCrossArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFORoundBiCrossArrowObject

CFORoundBiCrossArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFORoundCrossArrowObject

CFORoundCrossArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFORoundFlagArrowObject

CFORoundFlagArrowObjectis继承了基类CFOBaseEndObject

绘制效果 :

CFORoundRTriArrowObject

CFORoundRTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFORounTriArrowObject

Class CFORounTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFORounTriCrossArrowObject

Class CFORounTriCrossArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSBiTriArrowObject

CFOSBiTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSolidArrowObject

CFOSolidArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSolidFlagArrowObject

CFOSolidFlagArrowObject继承了基类CFOBaseEndObject

绘制效果:

CFOSolidRectArrowObject

CFOSolidRectArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSolidRoundArrowObject

CFOSolidRoundArrowObject继承了基类CFOBaseEndObject

绘制效果:

CFOSolidRTriArrowObject

CFOSolidRTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSolidTriArrowObject

CFOSolidTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSRoundBiCrossArrowObject

CFOSRoundBiCrossArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSRoundCrossObject

Class CFOSRoundCrossObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSRoundFlagArrowObject

CFOSRoundFlagArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSRoundRTriArrowObject

CFOSRoundRTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSRoundTriArrowObject

CFOSRoundTriArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOSRoundTriCrossObject

CFOSRoundTriCrossObject继承了基类CFOBaseEndObject

绘制效果 :

CFOTArrowObject

CFOTArrowObject继承了基类CFOBaseEndObject

绘制效果:

CFOTriCrossArrowObject

CFOTriCrossArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOTRoundArrowObject

CFOTRoundArrowObject继承了基类CFOBaseEndObject

绘制效果 :

CFOXAntennaArrowObject

Class CFOXAntennaArrowObject:

CFOXAntennaArrowObject继承了基类CFOBaseEndObject.

绘制效果 :

CFOXArrowObject

CFOXArrowObject继承了基类CFOBaseEndObject.

绘制效果 :


Caption

首 页

UCanCode主页

下 载

联 系

创建自己的箭头类

如果你不想使用Form++提供的尾端箭头，你可以创建自己的类。从CFOBaseEndObject类派生出一个类，然后增加OnDraw()和BuildLineEnd()函数。至于已经存在的尾端箭头，则在CFOCrossArrowObject类和CFOEmptyArrowObject类中。

为了新建一个定制的尾端箭头，你需要用与直线有关的函数OnDraw()和 BuildLineEnd()计算出图形的位置。在CFOCrossArrowObject类中， 用BuildLineEnd()函数来计算，它用箭头的大小决定怎样显示多边形。多边形顶点既用于计算区域的大小，也用于绘制尾端箭头。

你也可以使用Form++ Library add-in来创建自己的箭头类，步骤如下：

1.运行Form++ Library add-in，生成文档和视图类

2.在基类选择对话框中选择CFOBaseEndObject作为基类创建一个新的箭头类CMyArrowClass


s

首 页

UCanCode主页

下 载

联 系

FOSample示例

  • 1 示例指南

  • 2 新建FOSample工程

  • 3 FOSample应用程序选项

  • 4 修改FOSample中的Stdafx.h文件

  • 5 在FOSample中引用Form++资源

  • 6 修改FOSample应用程序执行文件

  • 7 修改FOSample视图类头文件

  • 8 修改FOSample视图类执行文件

  • 9.生成新的模板类

  • 10 修改FOSample文档类头文件

  • 11 修改FOSample文档类执行文件

  • 12 增加画图工具栏

  • 13 增加格式工具栏

  • 14 增加菜单项和加速键

  • 15 增加工具盒

  • 16 复制工具盒项目文件

  • 17 编译运行FOSample


s

首 页

UCanCode主页

下 载

联 系

新建FOSample工程

  1. 启动Visual Studio。

  2. 从菜单中选择File|New命令。

  3. 弹出一个对话框，标题为New。

  4. 在对话框中选择Projects页。

  5. 在Project name中输入工程名FOSample ，在Location中输入 <Your Form++ Library>\Samples\fosample\mysample。

  6. 从列表中选择 MFC AppWizard (exe) 。

    Visual C++ 6.0 New对话框

7.单击OK按钮。


s

首 页

UCanCode主页

下 载

联 系

FOSample应用程序选项

  1. MFC AppWizard对话框将弹出。

  2. 所有步骤都按照默认设置。你可以在任何时候通过单击Next或Finish按钮创建工程。

  3. New Project Information对话框将弹出。

  4. 单击OK。


s

首 页

UCanCode主页

下 载

联 系

修改FOSample工程中的stdafx.h文件

fo.h是Form++中的核心头文件。一旦这个文件被引用了，则你的应用程序中全部必须的类都可以用了。这个和引用afx*.h和相似。

  1. 打开stdafx.h。

  2. 在文件末尾增加下面这行：

    #include "fo.h"

  3. 保存stdafx.h后并关闭。


s

首 页

UCanCode主页

下 载

联 系

在FOSample工程中引用Form++资源

在你的应用程序的资源脚本中包含Form++资源头文件后，你的应用程序就可以访问Form++的资源了。当你静态连接Form++库时，就必须包含Form++库的资源脚本。下面的步骤讲述了如何在你的工程中增加Form++的资源文件。

  1. 在Visual Studio的集成开发环境中按ALT+0打开Workspace View。

  2. 在Workspace View中选择Resource View。

  3. 选择Resource View中的根目录，单击鼠标右键。

  4. 一个上下文菜单会弹出：

    Visual C++ 6.0 Resource View

  5. 选择Resource Includes.

  6. Resource Includes对话框会弹出。

    Visual C++ 6.0 Resource Includes对话框

  7. 在Read-only symbol directives中增加下面这行：
    #include "fores.h"
  8. 注意: 如果你的应用程序用动态连接方式（DLL）连接了Form+的库的话，那么你就可以跳过这个步骤。应用以下文件不会对你的应用程序中的功能有影响，但是它可能会使你最终应用程序文件变得很大。Form++动态连接方式（DLL）已经包含了Form++的库资源，因此采用这种方式连接就不需要在应用程序中包含头文件了。

    在Complile-time directives的末尾增加下面这行：

    #include "fores.rc"
  9. 单击OK。

  10. 一个消息对话框会弹出，警告你"Directive text will be written verbatim into your resource script and may render it uncompilable." 。这个对你的应用程序没有影响，单击OK。

  11. 保存fosample.rc（CTRL+S）。


s

首 页

UCanCode主页

下 载

联 系

修改FOSample文档类执行文件

在这一步中，我们将修改构造函数、析构函数和OnNewDocument()函数。这是使Form++文档类正常工作所必不可少的。

  1. 打开FOSampleDoc.cpp。

  2. 在构造函数中增加以下代码：

    CFOSampleDoc::CFOSampleDoc()
    {
    // TODO: add one-time construction code here
    m_pDataModel = new CMyExtDataModel;
    }

  3. 在析构函数中增加以下代码：

    CFOSampleDoc::~CFOSampleDoc()
    {
    if(m_pDataModel != NULL)
    {
    delete m_pDataModel;
    }
    }

  4. 在OnNewDocument()函数中增加以下代码：

    BOOL CFOSampleDoc::OnNewDocument()
    {
    m_pDataModel->SetDocument(this);
    if (!CDocument::OnNewDocument())
    return FALSE;

    // TODO: add reinitialization code here
    // (SDI documents will reuse this document)

    return TRUE;
    }

  5. 在Serialize()函数中增加以下代码：

    void
      CFOSampleDoc::Serialize(CArchive& ar)
{
if(ar.IsStoring())
{
m_pDataModel->Serialize(ar);
}
else
{
m_pDataModel->Serialize(ar);
}
}
  6. 增加SetTitle()函数，代码如下：

    void
      CFOSampleDoc::SetTitle(LPCTSTR lpszTitle)
{
m_pDataModel->SetDocTitle(lpszTitle);
CDocument::SetTitle(lpszTitle);
}
  7. 增加DeleteContents()函数，代码如下：

    void
      CFOSampleDoc::DeleteContents()
{
// TODO: Add your specialized code here and/or call the base
      class
m_pDataModel->ResetContent();
CDocument::DeleteContents();
}
  8. 增加OnSaveDocument()函数，代码如下：

    // @@ added override
BOOL CFOSampleDoc::OnSaveDocument(LPCTSTR lpszPathName)
{
m_pDataModel->SetDocument(this);
if (!CDocument::OnSaveDocument(lpszPathName))
{
return FALSE;
}
m_pDataModel->SetClean(); // Tells the command history
      that the document is "clean" at this point
SetModifiedFlag(FALSE);
return TRUE;
}
  9. 增加OnOpenDocument()函数，代码如下：

    BOOL CFOSampleDoc::OnOpenDocument(LPCTSTR lpszPathName)
    {
    m_pDataModel->SetDocument(this);
    if(!CDocument::OnOpenDocument(lpszPathName))
    {
    return FALSE;
    }
    return TRUE;
    }

  10. 增加SetModifiedFlag()函数，代码如下：

    // @@ added override (optional as
      long as you never call this member)
void CFOSampleDoc::SetModifiedFlag(BOOL b)
{
// Do nothing
m_pDataModel->SetModifiedFlag(b);
}
  11. 增加IsModified()函数，代码如下：

    // @@ added override
    BOOL CFOSampleDoc::IsModified()
    {
    return m_pDataModel->IsModified();
    }

  12. 使用数据成员m_pDataModel设置或访问CFODataModal类中的函数。
  13. 保存FOSampleDoc.cpp.


s

首 页

UCanCode主页

下 载

联 系

修改FOSample视图类头文件

在这一步中，应用程序的视图类的基类应该由CView变为 CFOBaseView。

  1. 打开FOSampleView.h.

  2. 将所有出现CView的地方用CFOBaseView代替。

  3. 保存FOSampleView.h后关闭。


s

首 页

UCanCode主页

下 载

联 系

修改FOSample视图类执行文件

在这一步中，为了调用CFOBaseView基类，要修改OnDraw()函数、OnBeginPrint()函数和OnEndPrinting()函数。这是让Form++视图类正常工作必不可少的。

注意：你不需要改动OnDraw()、OnBeginPrinting()和OnEndPrinting()函数中参数的名字。

  1. 打开FOSampleView.cpp。

  2. 将所有的CView用CFOBaseView替代。

  3. 要调用CFOBaseView类执行文件修改OnDraw()函数，用下面的两行代替// TODO: … ：
    // Form++ Library Add line.
Draw(pDC);
  4. 调用CFOBaseView类执行文件修改OnBeginPrinting(…)函数，用下面的代码代替// TODO: …：

    CFOBaseView::OnBeginPrinting(pDC, pInfo);

  5. 调用 CFOBaseView类执行文件修改OnEndPrinting(…)函数，用下面的代码代替// TODO: …：
    CFOBaseView::OnEndPrinting(pDC, pInfo);

    调用 CFOBaseView类执行文件修改OnPreparePrinting(…)函数，用下面的代码代替// TODO: …：

    return CFOBaseView::OnPreparePrinting(pInfo);

    调用 CFOBaseView类执行文件修改OnInitialUpdate(…)函数，用下面的代码代替// TODO: …：

    // Form++ Library Add line.
    SetCurrentModel(GetDocument()->m_pDataModel);
    CFOBaseView::OnInitialUpdate();

  6. 保存FOSampleView.cpp。


s

首 页

UCanCode主页

下 载

联 系

生成新的模板类

  1. 从基类CFODataModel中派生出一个新类CMyExtDataModel。你可以用Form++ Library add-in生成代码。

  2. 如果你想在这个模板中新建一个组件，你必须增加以下3个函数。

    // Attributes
    public:
    virtual CFODrawComponent *DoCreateComponentByType(UINT m_drawshape,CRect &rcCreate,CString strFileName = "",CFOToolBoxItem *pCurItem = NULL);
    virtual CString GetUniqueName(UINT nType);
    virtual CString GetUniqueCaption(UINT nType);

    CString
      CMyExtDataModel::GetUniqueName(UINT nType)
{
CString strReturn;
strReturn = "nLine";

return CFODataModel::GetUniqueName(nType);

}

CString CMyExtDataModel::GetUniqueCaption(UINT nType)
{
CString strReturn;
strReturn = "Line";

return CFODataModel::GetUniqueCaption(nType);

}

CFODrawComponent *CMyExtDataModel::DoCreateComponentByType(UINT
      m_drawshape,CRect &rcCreate,CString strFileName,CFOToolBoxItem *pCurItem)
{
CFODrawComponent *pReturn = NULL;

pReturn =
      CFODataModel::DoCreateComponentByType(m_drawshape,rcCreate,strFileName);

return pReturn;

}


s

首 页

UCanCode主页

下 载

联 系

修改FOSample文档类头文件

在这一步中，应用程序的视图类的基类已经由CView类变为了是CFOBaseView类。

  1. 打开FOSampleDoc.h.

  2. 在CFOSampleDoc class类中给数据模板增加一个数据成员，例如：
    CMyExtDataModel *m_pDataModel;

  3. 保存FOSampleDoc.h后关闭。


s

首 页

UCanCode主页

下 载

联 系

增加画图工具栏

  1. 现在增加Form++工具栏。Form++资源包括两种工具栏，分别是命令工具栏和组件工具栏。它们用下面的函数区分：

    Drawing Toolbar | IDR_FO_DRAWCOMPBAR
    Command Toolbar | IDR_FO_FORMAT

    你可以使用这些工具栏中的任意组合，也可以用特定的函数单独使用一个工具按钮。

    注意: 如果你想用Form++标准工具栏，你不需要将它们复制到你的应用程序的资源中去，因为在编译时工具栏已经从fores.rc文件中导入了。如果你想使用自己的定制工具栏，你需要在工程中新建，并且从FORes.rc复制这些按钮。

  2. 增加Form++工具栏到你的框架窗口就象你增加任意其他工具栏一样。在你的主框架头文件中（例如：MainFrm.h),，给工具栏增加一个成员变量：

    CToolBar m_wndDrawBar;

  3. 在你的主框架源文件中（例如：MainFrm.cpp）的OnCreate()函数中增加以下代码新建工具栏。

    if (!m_wndDrawBar.CreateEx(this, TBSTYLE_FLAT, WS_CHILD |
    WS_VISIBLE | CBRS_TOP | CBRS_GRIPPER | CBRS_TOOLTIPS |
    CBRS_FLYBY | CBRS_SIZE_DYNAMIC) ||
    !m_wndDrawBar.LoadToolBar(IDR_FO_DRAWCOMPBAR))
    {
           TRACE0("Failed to create toolbar\n");
           return -1;      // fail to create
    }

  4. 要使工具栏可以停靠，输入下面的代码：

    m_wndDrawBar.EnableDocking(CBRS_ALIGN_ANY);

    给工具栏命名，这样当它浮动时，就会在标题中显示出来。

    m_wndDrawBar.SetWindowText("ToolBox");

  5. 如果你想把工具栏停靠在主框架窗口上，你需要在OnCreate()函数中增加以下代码：

    EnableDocking(CBRS_ALIGN_ANY);

    你可以象下面这样调用函数，这样就可以停靠所有你新建的工具栏。

    DockControlBar(&m_wndDrawBar);

  6. 从Build菜单中选择Rebuild All执行一个完整的编译。然后再运行，运行后的结果应该如下所示：

top


s

首 页

UCanCode主页

下 载

联 系

增加格式工具栏

  1. 现在增加Form++工具栏。Form++资源包括两种工具栏，分别是命令工具栏和组件工具栏。它们用下面的函数区分：

    Drawing Toolbar | IDR_FO_DRAWCOMPBAR
    Command Toolbar | IDR_FO_FORMAT

    你可以使用这些工具栏中的任意组合，也可以用特定的函数单独使用一个工具按钮。

    注意: 如果你想用Form++标准工具栏，你不需要将它们复制到你的应用程序的资源中去，因为在编译时工具栏已经从fores.rc文件中导入了。如果你想使用自己的定制工具栏，你需要在工程中新建，并且从FORes.rc复制这些按钮。

  2. 增加Form++工具栏到你的框架窗口就象你增加任意其他工具栏一样。在你的主框架头文件中（例如：MainFrm.h),，给工具栏增加一个成员变量：

    CToolBar m_wndFormatBar;

  3. 在你的主框架源文件中（例如：MainFrm.cpp）的OnCreate()函数中增加以下代码新建工具栏。

    if (!m_wndFormatBar.CreateEx(this, TBSTYLE_FLAT, WS_CHILD |
    WS_VISIBLE | CBRS_TOP | CBRS_GRIPPER |     CBRS_TOOLTIPS |
    CBRS_FLYBY | CBRS_SIZE_DYNAMIC) ||
    !m_wndFormatBar.LoadToolBar(IDR_FO_FORMAT))
    {
    TRACE0("Failed to create toolbar\n");
    return -1; // fail to create
    }

  4. 要使工具栏可以停靠，输入下面的代码：

    m_wndFormatBar.EnableDocking(CBRS_ALIGN_ANY);

  5. 给工具栏命名，这样当它浮动时，就会在标题中显示出来。

    m_wndFormatBar.SetWindowText("FormatBar");

  6. 如果你想把工具栏停靠在主框架窗口上，你需要在OnCreate()函数中增加以下代码：

    EnableDocking(CBRS_ALIGN_ANY);

  7. 你可以象下面这样调用函数，这样就可以停靠所有你新建的工具栏。

    DockControlBar(&m_wndFormatBar);

8.从Build菜单中选择 Rebuild All执行一个完整的编译。然后再运行，运行后的结果应该如下所示：

top


s

首 页

UCanCode主页

下 载

联 系

增加菜单项和加速键

  1. 现在，增加菜单项。如果你象使菜单项和视图相互作用，你可以从Form++资源中复制到自己的工程中去。确信你没有从Form++资源中删除过它们。打开应用程序的资源文件和Form++的资源文件 (\FO\Include\RoRes.rc).

  2. 高亮显示你想从Form++菜单中引用到应用程序中去的菜单项，并且复制它们。

  3. 在应用程序的视图菜单中粘贴它们。然后从字符表中删除这些菜单项的字符资源。每个菜单项的资源ID都是以 ID_FO_开头的。

  4. 现在让我们增加加速键。FORes.rc文件包含一套Form++要用的一般加速键。

  5. 选择你想在应用程序中使用的加速键，然后复制它们。

  6. 在应用程序加速键表中粘贴刚才复制的加速键。


s

首 页

UCanCode主页

下 载

联 系

增加组件工具盒

  1. 现在，增加工具盒。工具盒窗口类如下：

    CFOMultiToolBoxBar

  2. 增加Form++工具栏到你的框架窗口就象你增加任意其他工具栏一样。在你的主框架头文件中（例如：MainFrm.h),，给工具栏增加一个成员变量：

    CFOMultiToolBoxBar m_FileBar;

  3. 在你的主框架源文件中（例如：MainFrm.cpp）的OnCreate()函数中增加以下代码新建工具栏。

    if (!m_FileBar.Create(this,ID_VIEW_TOOLBOX,_T("Docking Window"),CSize(200, 200)))
    {
    TRACE0("Failed to create m_FileBar\n");
    return -1; // fail to create
    }

    m_FileBar.SetBarStyle(m_FileBar.GetBarStyle() |
    CBRS_TOOLTIPS | CBRS_FLYBY | CBRS_SIZE_DYNAMIC);

    要使工具栏可以停靠，输入下面的代码：

    m_FileBar.EnableDocking(CBRS_ALIGN_ANY);

  4. 给工具栏命名，这样当它浮动时，就会在标题中显示出来。

    m_FileBar.SetWindowText("ToolBox");

  5. 如果你想把工具栏停靠在主框架窗口上，你需要在OnCreate()函数中增加以下代码：

    EnableDocking(CBRS_ALIGN_ANY);

  6. 你可以象下面这样调用函数，这样就可以停靠所有你新建的工具栏。

    DockControlBar(&m_FileBar, AFX_IDW_DOCKBAR_LEFT);

  7. 从Build菜单中选择Rebuild All执行一个完整的编译。然后再运行，运行后的结果应该如下所示：

top


s

首 页

UCanCode主页

下 载

联 系

复制工具盒中的项目

  1. 打开"..\FOSample\Debug"文件夹， 新建一个子文件夹"..\FOSample\Debug\Components"。从"..\UCanCode.Net Software \Prebuild\Components\"文件夹中复制Basic Shapes.trs、Forms Shapes.trs和index.dat 3个文件到应用程序中。
  2. 单击OK.


s

首 页

UCanCode主页

下 载

联 系

编译运行FOSample

到目前为止，你可以编译运行FOSample了。你可以在视图中操作Form++对象了。

  1. 编译运行程序

FOSample运行结果

更新FOSample类向导文件

下面的步骤将用新的基类信息更新FOSample类向导文件（FOSample.clw）。更新类向导文件将使类向导在增加函数时生成正确的基类信息。

  1. 从工程目录中删除FOSample.clw。

  2. 通过单击Workspace View中的Resource View打开 FOSample.rc。

  3. 打开ClassWizard (CTRL+W）。

  4. 一个报告类数据文件不存在的消息对话框会弹出，并且询问你是否象类向导一样生成它。单击YES。

  5. Select Source Files对话框会出现。

  6. 单击OK，并且类向导数据库会重新生成。

  7. 在MFC ClassWizard对话框中单击OK后，并关闭它。


s

首 页

UCanCode主页

下 载

联 系

支持

对Form++的技术支持通过我们的web网站UCanCode Software实现。请访问 UCanCode Software 去阅读知识库，在线支持技术支持表格，升级下载或者和我们联系。如果您还有困难请和我们email联系。或者与我们的技术支持中心电话联系：工作时间（星期一至星期五，8:00AM to 5:00PM）电话： (+86) 28-5257949。

反馈

若您有以下任何问题，请与我们联系ucancode ：

  1. 提交一个bug；

  2. 改进产品的任何建议；

  3. 您对产品的价格的意见。

销售

如果你想订购产品，或者升级，或者需求文档，请与我们的销售代表联系。可以通过互联网或者电子邮件。也可以与我们的销售部门联系。电话： (+86) 28-5257949，传真： (+86) 28-5257233。

©Copyright 2002, UCanCode.Net Software.


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:32 -0000 vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|23 Feb 2002 10:10:18 -0000 vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 06:46:10 -0000 vti_title:SR|共享右边框 vti_backlinkinfo:VX| vti_lineageid:SR|{46554A27-E864-466E-A57D-C573FBC8C6D2} vti_filesize:IR|519 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1252 vti_charset:SR|gb2312 vti_cacheddtm:TX|02 Mar 2002 02:07:32 -0000 vti_cachedlinkinfo:VX| vti_cachedsvcrellinks:VX| vti_cachedtitle:SR|共享右边框 vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


共享上边框

首 页

UCanCode主页

下 载

联 系


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:51 -0000 vti_timelastmodified:TR|10 Apr 2002 06:25:09 -0000 vti_title:SR|共享上边框 vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|components/component\\ essentials.htm get\\ start\\ with\\ form++/installing\\ form++.htm command\\ and\\ windows/windows.htm samples/fosample\\ tutorial/modify\\ fosample's\\ stdafx.h.htm command/command\\ index.htm samples/fosample\\ tutorial/include\\ form++\\ \\ resources\\ in\\ fosample.htm command/introduction\\ to\\ commands.htm introduction\\ to\\ form++/available\\ documents.htm arrows/create\\ your\\ own\\ arrows.htm home/contact.htm windows/drop\\ down\\ line\\ type\\ picker.htm samples/fosample\\ tutorial/modify\\ fosample\\ doc's\\ header\\ files.htm quick\\ tour/run\\ the\\ visual\\ c++\\ appwizard.htm core\\ classes/view/ole\\ drag-and-drop.htm arrows/arrows\\ class\\ hierarchy\\ diagram.htm get\\ start\\ with\\ form++/form++\\ appwizard.htm product\\ overview/page\\ layout.htm quick\\ tour/add\\ format\\ component\\ toolbar.htm product\\ overview/product\\ index.htm windows/drop\\ down\\ line\\ width\\ picker.htm properties/property\\ objects.htm command/target\\ model.htm windows/toolbox\\ bar.htm core\\ classes/core\\ classes\\ list.htm product\\ overview/introduction\\ to\\ product\\ overview.htm quick\\ tour/tour\\ index.htm samples/fosample\\ tutorial/modify\\ the\\ fosample\\ application\\ implementation\\ file.htm components/component\\ index.htm components/how\\ to\\ add\\ custom\\ components\\ in\\ form++.htm product\\ overview/drawing\\ components.htm get\\ start\\ with\\ form++/build\\ form++.htm properties/introduction\\ to\\ properties.htm introduction\\ to\\ form++/software\\ requirements.htm properties/how\\ to\\ get\\ and\\ set\\ properties\\ .htm product\\ overview/property\\ pages.htm product\\ overview/drawing\\ capabilities.htm windows/select\\ gradient\\ type.htm windows/select\\ image\\ type.htm samples/fosample\\ tutorial/tour\\ index.htm command/type\\ ids.htm dialog/other\\ dialogs.htm quick\\ tour/summary\\ of\\ the\\ quick\\ tour.htm quick\\ tour/add\\ draw\\ toolbar.htm arrows/arrow\\ classes.htm command/components\\ in\\ a\\ command.htm introduction\\ to\\ form++/welcome\\ to\\ form++.htm dialog/dialog\\ index.htm dialog/introduction\\ to\\ dialogs.htm introduction\\ to\\ form++/what\\ is\\ new\\ in\\ 4.0.htm introduction\\ to\\ form++/intro\\ index.htm properties/property\\ id.htm windows/select\\ brush\\ type.htm product\\ overview/file\\ export.htm properties/property\\ classes.htm product\\ overview/grid\\ property.htm dialog/component\\ property\\ dialogs.htm arrows/index\\ of\\ arrow.htm components/properties\\ and\\ dialog\\ and\\ components/page/component\\ classes.htm samples/fosample\\ tutorial/fosample\\ appwizard\\ options_copy(4).htm samples/fosample\\ tutorial/fosample\\ appwizard\\ options.htm arrows/detail\\ arrows\\ information.htm get\\ start\\ with\\ form++/get\\ start\\ index.htm product\\ overview/definitions.htm product\\ overview/manipulating\\ components.htm introduction\\ to\\ form++/features\\ in\\ form++.htm samples/fosample\\ tutorial/modify\\ fosample\\ view's\\ header\\ file.htm command/executing\\ and\\ unexecuting.htm command/command\\ classes.htm components/component\\ class\\ hierarchy.htm introduction\\ to\\ form++/technical\\ support.htm samples/fosample\\ tutorial/override\\ oninitialupdate.htm windows/drop\\ down\\ arrow\\ picker.htm 20011130fo3英文版/page/new_page_1.htm samples/fosample\\ tutorial/modify\\ fosample\\ view's\\ implementation\\ file.htm arrows/introduction\\ to\\ arrows.htm properties/properties\\ dialog.htm components/shape\\ components.htm windows/index\\ of\\ windows.htm samples/tour\\ index.htm quick\\ tour/add\\ components\\ toolbox.htm introduction\\ to\\ form++/prerequisites\\ to\\ using\\ form++.htm quick\\ tour/adding\\ menu\\ items\\ and\\ accelerators.htm windows/drop\\ down\\ color\\ picker.htm quick\\ tour/create\\ classes\\ using\\ form++\\ classwizard.htm core\\ classes/introduction\\ to\\ core\\ classes.htm product\\ overview/rulers.htm samples/fosample\\ tutorial/create\\ a\\ new\\ fosample\\ project.htm introduction\\ to\\ form++/online\\ resources.htm windows/other\\ windows.htm product\\ overview/background.htm properties/property\\ index.htm vti_lineageid:SR|{BE1CE95C-15C6-4813-9AF2-DB7974F27963} vti_nexttolasttimemodified:TR|28 Feb 2002 09:20:34 -0000 vti_modifiedby:SR|RICHISOFT\\Administrator vti_cacheddtm:TX|10 Apr 2002 06:25:09 -0000 vti_filesize:IR|1167 vti_cachedtitle:SR|共享上边框 vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 vti_charset:SR|gb2312


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 03:13:10 -0000 vti_timelastmodified:TR|10 Apr 2002 06:25:14 -0000 vti_title:SR|Form vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|core\\ classes/datamodel/cfodatamodel.htm arrows/index\\ of\\ detailed\\ arrows\\ info.htm core\\ classes/datamodel/cfotabpagemodel.htm _private/top.htm arrows\\ and\\ core\\ classes/detail\\ arrows\\ information.htm arrows\\ and\\ core\\ classes/introduction\\ to\\ arrows.htm 复件from用户手册/detail-arrow.htm 复件from用户手册/index\\ of\\ arrows.htm arrows\\ and\\ core\\ classes/index\\ of\\ arrow.htm arrows\\ and\\ core\\ classes/arrow\\ classes.htm main.htm core\\ classes/core\\ classes\\ hierarchy\\ diagram.htm core\\ classes/view/cfomultipageview.htm _borders/top.htm core\\ classes/other\\ core\\ classes.htm core\\ classes/introduction\\ to\\ datamodel.htm core\\ classes/view/cfotabpageview.htm arrows\\ and\\ core\\ classes/arrows\\ class\\ hierarchy\\ diagram.htm 复件from用户手册/index\\ of\\ detailed\\ arrows\\ info.htm windows/_borders/top.htm arrows\\ and\\ core\\ classes/create\\ your\\ own\\ arrows.htm core\\ classes/view/cfobaseview.htm core\\ classes/view/cfocontentview.htm 复件from用户手册/core\\ classes\\ info-detail.htm core\\ classes/datamodel/cfomultitabmodel.htm arrows/index\\ of\\ arrows.htm core\\ classes/datamodel/cfosubformmodel.htm core\\ classes/index\\ of\\ core\\ classes.htm core\\ classes/datamodel/cfomultipagemodel.htm arrows/detail-arrow.htm vti_nexttolasttimemodified:TR|14 Mar 2002 07:54:06 -0000 vti_lineageid:SR|{7E20B727-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|RICHISOFT\\Administrator vti_cacheddtm:TX|10 Apr 2002 06:25:14 -0000 vti_filesize:IR|5057 vti_cachedtitle:SR|Form vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|splash.bmp H|Introduction\\ to\\ form++/Intro\\ Index.htm H|Introduction\\ to\\ form++/Intro\\ Index.htm H|Quick\\ Tour/Tour\\ Index.htm H|Get\\ Start\\ With\\ form++/Get\\ Start\\ Index.htm H|Product\\ Overview/Product\\ Index.htm H|Core\\ Classes/Index\\ of\\ core\\ classes.htm H|Components/Component\\ Index.htm H|command/Command\\ Index.htm H|Properties/Property\\ Index.htm H|Dialog/Dialog\\ Index.htm H|Windows/Index\\ of\\ Windows.htm H|arrows/Index\\ of\\ arrow.htm H|Samples/Tour\\ Index.htm H|Home/Contact.htm K|main.htm S|arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FSUS|splash.bmp FHUS|Introduction\\ to\\ form++/Intro\\ Index.htm FHUS|Introduction\\ to\\ form++/Intro\\ Index.htm FHUS|Quick\\ Tour/Tour\\ Index.htm FHUS|Get\\ Start\\ With\\ form++/Get\\ Start\\ Index.htm FHUS|Product\\ Overview/Product\\ Index.htm FHUS|Core\\ Classes/Index\\ of\\ core\\ classes.htm FHUS|Components/Component\\ Index.htm FHUS|command/Command\\ Index.htm FHUS|Properties/Property\\ Index.htm FHUS|Dialog/Dialog\\ Index.htm FHUS|Windows/Index\\ of\\ Windows.htm FHUS|arrows/Index\\ of\\ arrow.htm FHUS|Samples/Tour\\ Index.htm FHUS|Home/Contact.htm FKUS|main.htm FSUS|arrows/images/index\\ 2.gif vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|true vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0


Active To Do List

Number | Task | Pri | Author | Created By Tool | Created On | Modified On | Completed | Modified By | Assigned To | Link To | Magic | Description
1 | 替换 、 | 2 | Administrator | FrontPage 的替换 | 26 Feb 2002 10:06:45 +0800 | 26 Feb 2002 10:06:45 +0800 | N |  | Administrator | Properties/Property Classes.htm | ~$REPLACE 、 , DOWN TOP | 将 6 处 、 替换为 ,


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_modifiedby:SR|Administrator vti_timecreated:TR|26 Feb 2002 02:06:45 -0000 vti_timelastmodified:TR|26 Feb 2002 02:06:45 -0000 vti_filesize:IR|1000 vti_title:SR|Active To Do List vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=utf-8 vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX| vti_nexttolasttimemodified:TR|26 Feb 2002 02:06:45 -0000 vti_cacheddtm:TX|26 Feb 2002 02:06:45 -0000 vti_cachedlinkinfo:VX|H|../Properties/Property\\ Classes.htm vti_cachedsvcrellinks:VX|FHUS|Properties/Property\\ Classes.htm vti_cachedtitle:SR|Active To Do List vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


Home

首 页

UCanCode主页

下 载

联 系

箭头

  • 1 简介

  • 2 箭头类

  • 3 箭头类层次图

  • 4 箭头类详细信息

  • 5 创建自己箭头的类


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:04:43 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:21 -0000 vti_title:SR|Caption vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/detail\\ arrows\\ information.htm arrows\\ and\\ core\\ classes/arrow\\ classes.htm arrows\\ and\\ core\\ classes/index\\ of\\ arrow.htm vti_nexttolasttimemodified:TR|28 Feb 2002 09:27:43 -0000 vti_lineageid:SR|{4CF043D4-ED24-4FD8-BCB1-D0E29E55FDB7} vti_filesize:IR|18223 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=iso-8859-1 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|windows-1252 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:21 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|arrows\\ class\\ hierarchy\\ diagram.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Detail\\ arrows\\ information.htm K|Arrow\\ classes.htm S|images/index\\ 2.gif H|arrows\\ class\\ hierarchy\\ diagram.htm S|images/back0.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|arrows/arrows\\ class\\ hierarchy\\ diagram.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Detail\\ arrows\\ information.htm FKUS|arrows/Arrow\\ classes.htm FSUS|arrows/images/index\\ 2.gif FHUS|arrows/arrows\\ class\\ hierarchy\\ diagram.htm FSUS|arrows/images/back0.gif vti_cachedtitle:SR|Caption vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|true vti_error0:SX|Someone directly edited the HTML output of a FrontPage Include component; the changes have been overwritten. vti_error:IX|1 vti_borderaggregate:SR|r


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:16 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:21 -0000 vti_title:SR|Arrows Class Hierarchy vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/introduction\\ to\\ arrows.htm arrows\\ and\\ core\\ classes/arrow\\ classes.htm arrows\\ and\\ core\\ classes/index\\ of\\ arrow.htm arrows\\ and\\ core\\ classes/create\\ your\\ own\\ arrows.htm vti_nexttolasttimemodified:TR|28 Feb 2002 09:28:54 -0000 vti_filesize:IR|1895 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B8B5-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:21 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|images/arrows2.gif H|Detail\\ arrows\\ information.htm H|Introduction\\ to\\ Arrows.htm S|images/back0.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|arrows/images/arrows2.gif FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|arrows/Introduction\\ to\\ Arrows.htm FSUS|arrows/images/back0.gif vti_cachedtitle:SR|Arrows Class Hierarchy vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:04:43 -0000 vti_timelastmodified:TR|14 Mar 2002 07:12:04 -0000 vti_title:SR|Caption vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|14 Mar 2002 07:11:39 -0000 vti_parentlineageid:SR|{4CF043D4-ED24-4FD8-BCB1-D0E29E55FDB7} vti_lineageid:SR|{7E20B8BD-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/index\\ of\\ arrow.htm arrows\\ and\\ core\\ classes/create\\ your\\ own\\ arrows.htm vti_filesize:IR|4634 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=iso-8859-1 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|windows-1252 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 07:12:05 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net K|Create\\ your\\ own\\ arrows.htm S|images/index\\ 2.gif H|arrows\\ class\\ hierarchy\\ diagram.htm S|images/back0.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FKUS|arrows/Create\\ your\\ own\\ arrows.htm FSUS|arrows/images/index\\ 2.gif FHUS|arrows/arrows\\ class\\ hierarchy\\ diagram.htm FSUS|arrows/images/back0.gif vti_cachedtitle:SR|Caption vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|true vti_borderaggregate:SR|r


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:04:43 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:21 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/detail\\ arrows\\ information.htm arrows\\ and\\ core\\ classes/arrows\\ class\\ hierarchy\\ diagram.htm arrows\\ and\\ core\\ classes/arrow\\ classes.htm arrows\\ and\\ core\\ classes/index\\ of\\ arrow.htm vti_nexttolasttimemodified:TR|28 Feb 2002 08:40:36 -0000 vti_lineageid:SR|{7E20B8B9-2670-11D6-A527-525400EA266C} vti_filesize:IR|73953 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:21 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|images/CFOAntennaArrowObject.gif S|images/detail4.jpg S|images/CFOAntennaRoundArrowObject.gif S|images/detail5.jpg S|images/CFOBiCrossArrowObject.gif S|images/detail6.jpg S|images/CFOBiNormalCrossArrowObject.gif S|images/detail7.jpg S|images/CFOBiTriArrowObject.gif S|images/detail8.jpg S|images/CFOCrossArrowObject.gif S|images/detail9.jpg S|images/CFOEmptyArrowObject.gif S|images/detail10.jpg S|images/CFOEmptyFlagArrowObject.gif X|file:///C:/TEMP/msoclip1/01/clip_image001.png S|images/detail11.jpg S|images/CFOEmptyRectArrowObject.gif S|images/detail12.jpg S|images/CFOEmptyRoundArrowObject.gif S|images/detail13.jpg S|images/CFOEmptyRTriArrowObject.gif X|file:///C:/TEMP/msoclip1/05/clip_image001.png S|images/detail14.jpg S|images/CFOEmptyTriArrowObject.gif X|file:///C:/TEMP/msoclip1/06/clip_image001.png S|images/detail15.jpg S|images/CFOLineArrowObject.gif X|file:///C:/TEMP/msoclip1/07/clip_image001.png S|images/detail16.jpg S|images/CFONormalArrowObject.gif S|images/detail17.jpg S|images/CFONormalCrossArrowObject.gif S|images/detail18.jpg S|images/CFORoundBiCrossArrowObject.gif X|file:///C:/TEMP/msoclip1/09/clip_image001.png S|images/detail19.jpg S|images/CFORoundCrossArrowObject.gif X|file:///C:/TEMP/msoclip1/10/clip_image001.png S|images/detail20.jpg S|images/CFORoundFlagArrowObject.gif X|file:///C:/TEMP/msoclip1/11/clip_image001.png S|images/detail21.jpg S|images/CFORoundRTriArrowObject.gif X|file:///C:/TEMP/msoclip1/12/clip_image001.png S|images/detail22.jpg S|images/CFORounTriArrowObject.gif X|file:///C:/TEMP/msoclip1/13/clip_image001.png S|images/detail23.jpg S|images/CFORounTriCrossArrowObject.gif X|file:///C:/TEMP/msoclip1/01/clip_image001.png S|images/detail24.jpg S|images/CFOSBiTriArrowObject.gif X|file:///C:/TEMP/msoclip1/03/clip_image001.png S|images/detail25.jpg S|images/CFOSolidArrowObject.gif S|images/detail26.jpg S|images/CFOSolidFlagArrowObject.gif X|file:///C:/TEMP/msoclip1/05/clip_image001.png S|images/detail27.jpg S|images/CFOSolidRectArrowObject.gif X|file:///C:/TEMP/msoclip1/06/clip_image001.png S|images/detail28.jpg S|images/CFOSolidRoundArrowObject.gif X|file:///C:/TEMP/msoclip1/07/clip_image001.png S|images/detail29.jpg S|images/CFOSolidRTriArrowObject.gif S|images/detail30.jpg S|images/CFOSolidTriArrowObject.gif X|file:///C:/TEMP/msoclip1/09/clip_image001.png S|images/detail31.jpg S|images/CFOSRoundBiCrossArrowObject.gif X|file:///C:/TEMP/msoclip1/10/clip_image001.png S|images/detail32.jpg S|images/CFOSRoundCrossObject.gif X|file:///C:/TEMP/msoclip1/11/clip_image001.png S|images/detail33.jpg S|images/CFOSRoundFlagArrowObject.gif X|file:///C:/TEMP/msoclip1/12/clip_image001.png S|images/detail34.jpg S|images/CFOSRoundRTriArrowObject.gif X|file:///C:/TEMP/msoclip1/13/clip_image001.png S|images/detail35.jpg S|images/CFOSRoundTriArrowObject.gif X|file:///C:/TEMP/msoclip1/01/clip_image001.png S|images/detail36.jpg S|images/CFOSRoundTriCrossObject.gif S|images/detail37.jpg S|images/CFOTArrowObject.gif S|images/detail38.jpg S|images/CFOTriCrossArrowObject.gif X|file:///C:/TEMP/msoclip1/03/clip_image001.png S|images/detail39.jpg S|images/CFOTRoundArrowObject.gif S|images/detail40.jpg S|images/CFOXAntennaArrowObject.gif X|file:///C:/TEMP/msoclip1/04/clip_image001.png S|images/detail41.jpg S|images/CFOXArrowObject.gif S|images/detail42.jpg K|Detail\\ arrows\\ information.htm S|images/index\\ 2.gif H|Arrow\\ classes.htm S|images/back0.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|arrows/images/CFOAntennaArrowObject.gif FSUS|arrows/images/detail4.jpg FSUS|arrows/images/CFOAntennaRoundArrowObject.gif FSUS|arrows/images/detail5.jpg FSUS|arrows/images/CFOBiCrossArrowObject.gif FSUS|arrows/images/detail6.jpg FSUS|arrows/images/CFOBiNormalCrossArrowObject.gif FSUS|arrows/images/detail7.jpg FSUS|arrows/images/CFOBiTriArrowObject.gif FSUS|arrows/images/detail8.jpg FSUS|arrows/images/CFOCrossArrowObject.gif FSUS|arrows/images/detail9.jpg FSUS|arrows/images/CFOEmptyArrowObject.gif FSUS|arrows/images/detail10.jpg FSUS|arrows/images/CFOEmptyFlagArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/01/clip_image001.png FSUS|arrows/images/detail11.jpg FSUS|arrows/images/CFOEmptyRectArrowObject.gif FSUS|arrows/images/detail12.jpg FSUS|arrows/images/CFOEmptyRoundArrowObject.gif FSUS|arrows/images/detail13.jpg FSUS|arrows/images/CFOEmptyRTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/05/clip_image001.png FSUS|arrows/images/detail14.jpg FSUS|arrows/images/CFOEmptyTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/06/clip_image001.png FSUS|arrows/images/detail15.jpg FSUS|arrows/images/CFOLineArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/07/clip_image001.png FSUS|arrows/images/detail16.jpg FSUS|arrows/images/CFONormalArrowObject.gif FSUS|arrows/images/detail17.jpg FSUS|arrows/images/CFONormalCrossArrowObject.gif FSUS|arrows/images/detail18.jpg FSUS|arrows/images/CFORoundBiCrossArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/09/clip_image001.png FSUS|arrows/images/detail19.jpg FSUS|arrows/images/CFORoundCrossArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/10/clip_image001.png FSUS|arrows/images/detail20.jpg FSUS|arrows/images/CFORoundFlagArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/11/clip_image001.png FSUS|arrows/images/detail21.jpg FSUS|arrows/images/CFORoundRTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/12/clip_image001.png FSUS|arrows/images/detail22.jpg FSUS|arrows/images/CFORounTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/13/clip_image001.png FSUS|arrows/images/detail23.jpg FSUS|arrows/images/CFORounTriCrossArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/01/clip_image001.png FSUS|arrows/images/detail24.jpg FSUS|arrows/images/CFOSBiTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/03/clip_image001.png FSUS|arrows/images/detail25.jpg FSUS|arrows/images/CFOSolidArrowObject.gif FSUS|arrows/images/detail26.jpg FSUS|arrows/images/CFOSolidFlagArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/05/clip_image001.png FSUS|arrows/images/detail27.jpg FSUS|arrows/images/CFOSolidRectArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/06/clip_image001.png FSUS|arrows/images/detail28.jpg FSUS|arrows/images/CFOSolidRoundArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/07/clip_image001.png FSUS|arrows/images/detail29.jpg FSUS|arrows/images/CFOSolidRTriArrowObject.gif FSUS|arrows/images/detail30.jpg FSUS|arrows/images/CFOSolidTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/09/clip_image001.png FSUS|arrows/images/detail31.jpg FSUS|arrows/images/CFOSRoundBiCrossArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/10/clip_image001.png FSUS|arrows/images/detail32.jpg FSUS|arrows/images/CFOSRoundCrossObject.gif NXUS|file:///C:/TEMP/msoclip1/11/clip_image001.png FSUS|arrows/images/detail33.jpg FSUS|arrows/images/CFOSRoundFlagArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/12/clip_image001.png FSUS|arrows/images/detail34.jpg FSUS|arrows/images/CFOSRoundRTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/13/clip_image001.png FSUS|arrows/images/detail35.jpg FSUS|arrows/images/CFOSRoundTriArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/01/clip_image001.png FSUS|arrows/images/detail36.jpg FSUS|arrows/images/CFOSRoundTriCrossObject.gif FSUS|arrows/images/detail37.jpg FSUS|arrows/images/CFOTArrowObject.gif FSUS|arrows/images/detail38.jpg FSUS|arrows/images/CFOTriCrossArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/03/clip_image001.png FSUS|arrows/images/detail39.jpg FSUS|arrows/images/CFOTRoundArrowObject.gif FSUS|arrows/images/detail40.jpg FSUS|arrows/images/CFOXAntennaArrowObject.gif NXUS|file:///C:/TEMP/msoclip1/04/clip_image001.png FSUS|arrows/images/detail41.jpg FSUS|arrows/images/CFOXArrowObject.gif FSUS|arrows/images/detail42.jpg FKUS|arrows/Detail\\ arrows\\ information.htm FSUS|arrows/images/index\\ 2.gif FHUS|arrows/Arrow\\ classes.htm FSUS|arrows/images/back0.gif vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|true


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:31 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:21 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/introduction\\ to\\ arrows.htm main.htm vti_nexttolasttimemodified:TR|28 Feb 2002 09:28:10 -0000 vti_lineageid:SR|{7E20B8BA-2670-11D6-A527-525400EA266C} vti_filesize:IR|2844 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:21 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Introduction\\ to\\ Arrows.htm H|Arrow\\ classes.htm H|Arrows\\ class\\ hierarchy\\ diagram.htm H|Detail\\ arrows\\ information.htm H|../Components/How\\ to\\ add\\ custom\\ components\\ in\\ Form++.htm H|Create\\ your\\ own\\ arrows.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|arrows/Introduction\\ to\\ Arrows.htm FHUS|arrows/Arrow\\ classes.htm FHUS|arrows/Arrows\\ class\\ hierarchy\\ diagram.htm FHUS|arrows/Detail\\ arrows\\ information.htm FHUS|Components/How\\ to\\ add\\ custom\\ components\\ in\\ Form++.htm FHUS|arrows/Create\\ your\\ own\\ arrows.htm vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:04:44 -0000 vti_timelastmodified:TR|14 Mar 2002 03:59:49 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/arrows\\ class\\ hierarchy\\ diagram.htm arrows\\ and\\ core\\ classes/index\\ of\\ arrow.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:21 -0000 vti_lineageid:SR|{A75F9D3E-B65E-4704-A7B9-414A13A4627D} vti_filesize:IR|2619 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:59:49 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|images/index\\ 1.gif H|Arrows\\ Class\\ Hierarchy\\ Diagram.htm H|Index\\ of\\ arrow.htm S|images/back0.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|arrows/images/index\\ 1.gif FHUS|arrows/Arrows\\ Class\\ Hierarchy\\ Diagram.htm FHUS|arrows/Index\\ of\\ arrow.htm FSUS|arrows/images/back0.gif vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

命令

  • 1 介绍

  • 2 类型IDs

  • 3 执行与不执行

  • 4 目标模板

  • 5 命令中的组件

  • 6 命令类


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:17 -0000 vti_timelastmodified:TR|14 Mar 2002 07:34:05 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|command/command\\ classes.htm command/command\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 06:22:53 -0000 vti_lineageid:SR|{7E20B822-2670-11D6-A527-525400EA266C} vti_filesize:IR|22635 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 07:34:05 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../Windows/index.1.gif S|../Windows/index.2.gif S|../Windows/index.3.gif S|../Windows/index.4.gif S|../Windows/index.6.gif S|../Windows/index.7.gif S|../Windows/index.7.gif S|../Windows/index.8.gif S|../Windows/index.9.gif S|../Windows/index.10.gif S|../Windows/index.11.gif S|../Windows/index.12.gif S|../Windows/index.13.gif S|../Windows/index.14.gif S|../Windows/index.15.gif S|../Windows/index.16.gif S|../Windows/index.17.gif S|../Windows/index.18.gif S|../Windows/index.19.gif S|../Windows/index.20.gif S|../Windows/index.21.gif S|../Windows/index.22.gif S|../Windows/index.24.gif S|../Windows/index.24.gif K|Command\\ Classes.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/index.1.gif FSUS|Windows/index.2.gif FSUS|Windows/index.3.gif FSUS|Windows/index.4.gif FSUS|Windows/index.6.gif FSUS|Windows/index.7.gif FSUS|Windows/index.7.gif FSUS|Windows/index.8.gif FSUS|Windows/index.9.gif FSUS|Windows/index.10.gif FSUS|Windows/index.11.gif FSUS|Windows/index.12.gif FSUS|Windows/index.13.gif FSUS|Windows/index.14.gif FSUS|Windows/index.15.gif FSUS|Windows/index.16.gif FSUS|Windows/index.17.gif FSUS|Windows/index.18.gif FSUS|Windows/index.19.gif FSUS|Windows/index.20.gif FSUS|Windows/index.21.gif FSUS|Windows/index.22.gif FSUS|Windows/index.24.gif FSUS|Windows/index.24.gif FKUS|Command/Command\\ Classes.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|true


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:17 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|main.htm vti_nexttolasttimemodified:TR|27 Feb 2002 07:39:46 -0000 vti_filesize:IR|2362 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B823-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Introduction\\ to\\ Commands.htm H|Type\\ IDs.htm H|Executing\\ and\\ Unexecuting.htm H|Target\\ Model.htm H|Components\\ in\\ a\\ Command.htm H|Command\\ Classes.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|Command/Introduction\\ to\\ Commands.htm FHUS|command/Type\\ IDs.htm FHUS|command/Executing\\ and\\ Unexecuting.htm FHUS|command/Target\\ Model.htm FHUS|Command/Components\\ in\\ a\\ Command.htm FHUS|command/Command\\ Classes.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:17 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|command/command\\ index.htm vti_nexttolasttimemodified:TR|27 Feb 2002 07:34:32 -0000 vti_filesize:IR|1924 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B824-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:17 -0000 vti_timelastmodified:TR|14 Mar 2002 02:43:33 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|command/command\\ index.htm vti_nexttolasttimemodified:TR|13 Mar 2002 07:51:52 -0000 vti_lineageid:SR|{7E20B825-2670-11D6-A527-525400EA266C} vti_filesize:IR|2308 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 02:43:33 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|commandbar.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Command/commandbar.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:17 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|command/command\\ index.htm vti_nexttolasttimemodified:TR|23 Feb 2002 10:10:17 -0000 vti_filesize:IR|2234 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B826-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Coms2.gif S|Coms3.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Command/Coms2.gif FSUS|Command/Coms3.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:17 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|command/command\\ index.htm vti_nexttolasttimemodified:TR|27 Feb 2002 07:33:53 -0000 vti_lineageid:SR|{7E20B827-2670-11D6-A527-525400EA266C} vti_filesize:IR|1807 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:41:17 -0000 vti_timelastmodified:TR|14 Mar 2002 05:31:05 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|command/command\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 03:06:16 -0000 vti_lineageid:SR|{7E20B828-2670-11D6-A527-525400EA266C} vti_filesize:IR|2023 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:31:05 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

组件

  • 1 组件类的层次

  • 2 组件要素

  • 3 成形组件

  • 4 组件类详细信息

  • 5 怎样在Form++中添加定制组件?


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:31 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|components/component\\ index.htm components/component\\ class\\ hierarchy.htm vti_nexttolasttimemodified:TR|27 Feb 2002 05:25:43 -0000 vti_lineageid:SR|{7E20B83F-2670-11D6-A527-525400EA266C} vti_filesize:IR|2080 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Components.gif K|Component\\ Class\\ Hierarchy.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Components/Components.gif FKUS|Components/Component\\ Class\\ Hierarchy.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:31 -0000 vti_timelastmodified:TR|14 Mar 2002 03:08:14 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|components/component\\ index.htm components/component\\ essentials.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B840-2670-11D6-A527-525400EA266C} vti_filesize:IR|5212 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:08:14 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|controlpoint.gif K|Component\\ Essentials.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Components/controlpoint.gif FKUS|Components/Component\\ Essentials.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:31 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|main.htm vti_nexttolasttimemodified:TR|27 Feb 2002 05:24:12 -0000 vti_filesize:IR|2449 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B841-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Component\\ Class\\ Hierarchy.htm H|Component\\ Essentials.htm H|Shape\\ Components.htm H|properties\\ and\\ dialog\\ and\\ components/page/Component\\ Classes.htm H|How\\ to\\ add\\ custom\\ components\\ in\\ Form++.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|components/Component\\ Class\\ Hierarchy.htm FHUS|components/Component\\ Essentials.htm FHUS|components/Shape\\ Components.htm FHUS|components/properties\\ and\\ dialog\\ and\\ components/page/Component\\ Classes.htm FHUS|components/How\\ to\\ add\\ custom\\ components\\ in\\ Form++.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:16:57 -0000 vti_timelastmodified:TR|14 Mar 2002 02:42:26 -0000 vti_title:SR|如何在Form vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/index\\ of\\ arrow.htm components/how\\ to\\ add\\ custom\\ components\\ in\\ form++.htm components/component\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 02:41:14 -0000 vti_lineageid:SR|{7E20B829-2670-11D6-A527-525400EA266C} vti_filesize:IR|5581 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 02:42:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../class\\ wizard/new_pa9.gif S|../class\\ wizard/new_pa10.gif S|../class\\ wizard/How\\ to34.gif S|../class\\ wizard/new_pa13.gif S|../class\\ wizard/new_pa14.gif S|../class\\ wizard/How\\ to35.gif S|../class\\ wizard/new_pa16.gif S|../class\\ wizard/new_pa17.gif K|How\\ to\\ add\\ custom\\ components\\ in\\ Form++.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|class\\ wizard/new_pa9.gif FSUS|class\\ wizard/new_pa10.gif FSUS|class\\ wizard/How\\ to34.gif FSUS|class\\ wizard/new_pa13.gif FSUS|class\\ wizard/new_pa14.gif FSUS|class\\ wizard/How\\ to35.gif FSUS|class\\ wizard/new_pa16.gif FSUS|class\\ wizard/new_pa17.gif FKUS|Components/How\\ to\\ add\\ custom\\ components\\ in\\ Form++.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|如何在Form vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:31 -0000 vti_timelastmodified:TR|14 Mar 2002 02:45:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|components/component\\ index.htm components/shape\\ components.htm vti_nexttolasttimemodified:TR|14 Mar 2002 02:44:18 -0000 vti_lineageid:SR|{7E20B842-2670-11D6-A527-525400EA266C} vti_filesize:IR|9861 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 02:45:27 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|basiccomps.gif S|custcomps1.gif S|custcomps2.gif K|Shape\\ Components.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Components/basiccomps.gif FSUS|Components/custcomps1.gif FSUS|Components/custcomps2.gif FKUS|Components/Shape\\ Components.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Mar 2002 05:31:31 -0000 vti_extenderversion:SR|4.0.2.3406 vti_filesize:IR|14098 vti_title:SR|组件类 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|components/component\\ index.htm components/properties\\ and\\ dialog\\ and\\ components/page/component\\ classes.htm vti_nexttolasttimemodified:TR|14 Mar 2002 05:29:17 -0000 vti_author:SR|Administrator vti_timecreated:TR|23 Feb 2002 08:04:40 -0000 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:31:31 -0000 vti_cachedlinkinfo:VX|I|../../../_private/top.htm -H|../../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|new_pa7.gif S|new_pa8.gif S|new_pa9.gif S|new_pa10.gif S|new_pa11.gif S|new_pa12.gif S|new_pa13.gif S|new_pa14.gif S|new_pa15.gif S|new_pa16.gif S|new_pa17.gif S|new_pa18.gif S|new_pa19.gif S|new_pa20.gif S|new_pa21.gif S|new_pa22.gif S|new_pa24.gif S|new_pa25.gif S|new_pa26.gif S|new_pa28.gif S|new_pa30.gif S|new_pa31.gif S|new_pa32.gif S|new_pa33.gif S|new_pa34.gif S|new_pa35.gif S|new_pa36.gif S|new_pa37.gif S|new_pa38.gif S|new_pa39.gif S|new_pa40.gif K|Component\\ Classes.htm S|../../../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa7.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa8.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa9.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa10.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa11.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa12.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa13.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa14.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa15.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa16.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa17.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa18.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa19.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa20.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa21.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa22.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa24.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa25.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa26.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa28.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa30.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa31.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa32.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa33.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa34.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa35.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa36.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa37.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa38.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa39.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa40.gif FKUS|Components/properties\\ and\\ dialog\\ and\\ components/page/Component\\ Classes.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|组件类 vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


Home

首 页

UCanCode主页

下 载

联 系

核心类

  • 1 核心类简介

  • 2 核心类继承图

  • 3 核心类列表

  • 4 数据模型简介

  • 5 视图类简介


CFODataModel

首 页

UCanCode主页

下 栽

联 系

其他核心类

CFOArea

这个类描述的是一个或者多个组件形成的区域。

CFOBackComponent

表格的背景色和外观等保存在模型中。你可以定义背景上的组件，使用背景色。缺省情况下，背景色是灰色的，你可以依需要而改变。

背景的组件是 CFOBackComponent 的对象，这使得我们可以很容易的改变表格上其他组件后的背景显示。

CFOCompSelection

缺省情况下，Form++的应用程序开始在选择模式。你可以任意选择组件。

CFOCustomDataModel

CFOCustomDataModel提供了一系列的方法使你能够控制组件。通过这个类可以编辑组件的任何方面。

CFODataModelBase

新建的一个基类，存储基本数据和实现基本操作。要使用CFODataModelBase对象，只要调用构造函数。

CFODoc

CFODoc从CDocument(MFC)继承而来，它扩展了CDocument的许多特点，比CDocument类提供了更多的函数。

CFODoubleBufferDC

CFODoubleBufferDC构建双缓冲区来存储图象和组件。

CFODrawHelper

CFODrawHelper用于显示绘制时显示帮助信息。

CFOMPtArea

CFOMPtArea 是建立一个多个点组成区域并对区域进行管理的类。

CFOMultiTracker

处理拖放一个组件是显示痕迹。跟踪对组件的操作并且显示组件的变化和外形。它可以使用户确定如果拖放到当前位置组件会变成什么形状。

top


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:04:44 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/index\\ of\\ core\\ classes.htm core\\ classes/core\\ classes\\ list.htm core\\ classes/core\\ classes\\ hierarchy\\ diagram.htm vti_nexttolasttimemodified:TR|01 Mar 2002 05:09:48 -0000 vti_lineageid:SR|{7E20B8B7-2670-11D6-A527-525400EA266C} vti_filesize:IR|3305 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|H|../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../arrows/images/core\\ c1.gif S|Core\\ c1.gif S|../arrows/images/core\\ c3.gif S|../arrows/images/core\\ c4.gif H|Core\\ classes\\ List.htm S|../arrows/images/back.gif K|Core\\ classes\\ hierarchy\\ diagram.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/core\\ c1.gif FSUS|core\\ classes/Core\\ c1.gif FSUS|arrows/images/core\\ c3.gif FSUS|arrows/images/core\\ c4.gif FHUS|Core\\ Classes/Core\\ classes\\ List.htm FSUS|arrows/images/back.gif FKUS|Core\\ Classes/Core\\ classes\\ hierarchy\\ diagram.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:04:44 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|Caption vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/index\\ of\\ core\\ classes.htm core\\ classes/core\\ classes\\ list.htm core\\ classes/core\\ classes\\ hierarchy\\ diagram.htm vti_nexttolasttimemodified:TR|01 Mar 2002 05:10:04 -0000 vti_lineageid:SR|{7E20B8B8-2670-11D6-A527-525400EA266C} vti_filesize:IR|8890 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=iso-8859-1 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|windows-1252 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Core\\ classes\\ hierarchy\\ diagram.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm K|../Core\\ Classes/Other\\ Core\\ Classes.htm H|Index\\ of\\ core\\ classes.htm S|../arrows/images/back0.gif K|Core\\ classes\\ List.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|core\\ classes/Core\\ classes\\ hierarchy\\ diagram.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Index\\ of\\ core\\ classes.htm FSUS|arrows/images/back0.gif FKUS|Core\\ Classes/Core\\ classes\\ List.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|Caption vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_error0:SX|Someone directly edited the HTML output of a FrontPage Include component; the changes have been overwritten. vti_error:IX|1


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/core\\ classes\\ list.htm main.htm core\\ classes/introduction\\ to\\ core\\ classes.htm vti_nexttolasttimemodified:TR|27 Feb 2002 08:59:51 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|3625 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|H|../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net H|Introduction\\ to\\ core\\ classes.htm H|Core\\ classes\\ hierarchy\\ diagram.htm H|Core\\ classes\\ List.htm H|Introduction\\ to\\ DataModel.htm H|Introduction\\ to\\ View.htm vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FHUS|core\\ classes/Introduction\\ to\\ core\\ classes.htm FHUS|core\\ classes/Core\\ classes\\ hierarchy\\ diagram.htm FHUS|core\\ classes/Core\\ classes\\ List.htm FHUS|core\\ classes/Introduction\\ to\\ DataModel.htm FHUS|core\\ classes/Introduction\\ to\\ View.htm vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:04:44 -0000 vti_timelastmodified:TR|14 Mar 2002 05:21:36 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/index\\ of\\ core\\ classes.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B8BB-2670-11D6-A527-525400EA266C} vti_filesize:IR|4699 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:21:36 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Other\\ Core\\ Classes.htm H|Index\\ of\\ core\\ classes.htm S|../arrows/images/back.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|Core\\ Classes/Other\\ Core\\ Classes.htm FHUS|Core\\ Classes/Index\\ of\\ core\\ classes.htm FSUS|arrows/images/back.gif vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|true


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 05:22:27 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/index\\ of\\ core\\ classes.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|4298 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:22:27 -0000 vti_cachedlinkinfo:VX|H|../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net H|DataModel/CFODataModel.htm H|DataModel/CFOSubFormModel.htm H|DataModel/CFOMultiPageModel.htm H|DataModel/CFOTabPageModel.htm H|DataModel/CFOMultiTabModel.htm vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FHUS|core\\ classes/DataModel/CFODataModel.htm FHUS|Core\\ Classes/DataModel/CFOSubFormModel.htm FHUS|Core\\ Classes/DataModel/CFOMultiPageModel.htm FHUS|Core\\ Classes/DataModel/CFOTabPageModel.htm FHUS|Core\\ Classes/DataModel/CFOMultiTabModel.htm vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 03:12:28 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/index\\ of\\ core\\ classes.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|4657 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:12:28 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net H|View/OLE\\ Drag-and-Drop.htm H|View/CFOBaseView.htm H|View/CFOMultiPageView.htm H|View/CFOTabPageView.htm H|View/CFOContentView.htm vti_cachedsvcrellinks:VX|NHUS|file:///D:/备份/用户手册/Form中文用户手册/new/Output_Chs/main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FHUS|core\\ classes/View/OLE\\ Drag-and-Drop.htm FHUS|core\\ classes/View/CFOBaseView.htm FHUS|core\\ classes/View/CFOMultiPageView.htm FHUS|core\\ classes/View/CFOTabPageView.htm FHUS|Core\\ Classes/View/CFOContentView.htm vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:03:31 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|CFODataModel vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|arrows\\ and\\ core\\ classes/index\\ of\\ core.htm core\\ classes/other\\ core\\ classes.htm core\\ classes/core\\ classes\\ list.htm core\\ classes/introduction\\ to\\ core\\ classes.htm arrows\\ and\\ core\\ classes/introduction.htm vti_nexttolasttimemodified:TR|02 Mar 2002 01:29:07 -0000 vti_lineageid:SR|{7E20B8B6-2670-11D6-A527-525400EA266C} vti_filesize:IR|8073 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=iso-8859-1 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|windows-1252 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|H|../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../arrows/images/CFOArea.bmp S|../arrows/images/CFOBackComponent.bmp S|../arrows/images/CFOCompSelection.bmp S|../arrows/images/CFOCustomDataModel.bmp S|../arrows/images/CFODataModelBase.bmp S|../arrows/images/cfodoc.bmp S|../arrows/images/CFODoubleBufferDC.bmp S|../arrows/images/CFODrawHelper.bmp S|../arrows/images/CFOMPtArea.bmp S|../arrows/images/CFOMultiTracker.bmp K|Other\\ Core\\ Classes.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/CFOArea.bmp FSUS|arrows/images/CFOBackComponent.bmp FSUS|arrows/images/CFOCompSelection.bmp FSUS|arrows/images/CFOCustomDataModel.bmp FSUS|arrows/images/CFODataModelBase.bmp FSUS|arrows/images/cfodoc.bmp FSUS|arrows/images/CFODoubleBufferDC.bmp FSUS|arrows/images/CFODrawHelper.bmp FSUS|arrows/images/CFOMPtArea.bmp FSUS|arrows/images/CFOMultiTracker.bmp FKUS|Core\\ Classes/Other\\ Core\\ Classes.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|CFODataModel vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


Home

首 页

UCanCode主页

下 载

联 系

CFODataModel

模型是一个表格上组件的容器。模型存储表格的可视化信息，如页的名称、背景色等。模型作为命令的对象，支持撤消和重做的功能。当一个命令运行时，它通过调用模型的方法对模型进行一个或者多个操作。命令执行完后，模型会保存信息。

类CFODataModel包含其他可视化组件的模型。用来建立单页数据模型。

Using CFODataModel

  • 从基类CFODataModel产生一个新类CMyExtDataModel。你可以使用Form++ Library add-in来生成代码。
  • 如果你想在这个模板中生成新组件，你需要生成以下三个函数：

    // Attributes
    public:
    virtual CFODrawComponent *DoCreateComponentByType(UINT     m_drawshape,CRect &rcCreate,CString strFileName = "",CFOToolBoxItem *pCurItem = NULL);
    virtual CString GetUniqueName(UINT nType);
    virtual CString GetUniqueCaption(UINT nType);

    CString
      CMyExtDataModel::GetUniqueName(UINT nType)
{
CString strReturn;
strReturn = "nLine";

return CFODataModel::GetUniqueName(nType);

}

CString CMyExtDataModel::GetUniqueCaption(UINT nType)
{
CString strReturn;
strReturn = "Line";

return CFODataModel::GetUniqueCaption(nType);

}

CFODrawComponent *CMyExtDataModel::DoCreateComponentByType(UINT

      m_drawshape,CRect &rcCreate,CString strFileName,CFOToolBoxItem *pCurItem)
{
CFODrawComponent *pReturn = NULL;

pReturn =
        CFODataModel::DoCreateComponentByType(m_drawshape,rcCreate,strFileName);

return pReturn;

}
  • 给用数据模型生成的CDocument类添加一个数据成员。例如：
    CMyExtDataModel *m_pDataModel;
  • 在构造函数中添加以下代码：

    CCustomSampleDoc::CCustomSampleDoc()
    {
     // TODO: add one-time construction code here
    m_pDataModel = new CMyExtDataModel;
     }

  • 在析构函数中添加以下代码：

    CCustomSampleDoc::~CCustomSampleDoc()
    {
     if(m_pDataModel != NULL)
    {
    delete m_pDataModel;
    }
    }

  • 在OnNewDocument()函数中添加以下代码：

    BOOL
      CCustomSampleDoc::OnNewDocument()
{
m_pDataModel->SetDocument(this);
if (!CDocument::OnNewDocument())
return FALSE;

// TODO: add reinitialization code here
// (SDI documents will reuse this document)

return TRUE;
}
  • 在Serialize()函数中添加以下代码：

    void
      CCustomSampleDoc::Serialize(CArchive& ar)
{
if(ar.IsStoring())
{
m_pDataModel->Serialize(ar);
}
else
{
m_pDataModel->Serialize(ar);
}
}
  • 添加SetTitle()函数，代码如下：

    void
      CCustomSampleDoc::SetTitle(LPCTSTR lpszTitle)
{
m_pDataModel->SetDocTitle(lpszTitle);
CDocument::SetTitle(lpszTitle);
}
  • 添加DeleteContents()函数，代码如下：

    void
      CCustomSampleDoc::DeleteContents()
{
// TODO: Add your specialized code here and/or call the base
      class
m_pDataModel->ResetContent();
CDocument::DeleteContents();
}
  • 添加OnSaveDocument()函数，代码如下：

    // @@ added override
BOOL CCustomSampleDoc::OnSaveDocument(LPCTSTR lpszPathName)
{
m_pDataModel->SetDocument(this);
if (!CDocument::OnSaveDocument(lpszPathName))
{
return FALSE;
}
m_pDataModel->SetClean(); // Tells the command history
      that the  document is "clean" at this point
SetModifiedFlag(FALSE);
return TRUE;
}
  • 添加OnOpenDocument()函数，代码如下：

    BOOL
      CCustomSampleDoc::OnOpenDocument(LPCTSTR lpszPathName)
{
m_pDataModel->SetDocument(this);
if(!CDocument::OnOpenDocument(lpszPathName))
{
return FALSE;
}
return TRUE;
}
  • 添加SetModifiedFlag()函数，代码如下：

    // @@ added override (optional as
      long as you never call this member)
void CCustomSampleDoc::SetModifiedFlag(BOOL b)
{
// Do nothing
m_pDataModel->SetModifiedFlag(b);
}
  • 添加IsModified()函数，代码如下：

    // @@ added override
    BOOL CCustomSampleDoc::IsModified()
    {
     return m_pDataModel->IsModified();
    }

  • 用数据成员m_pDataModel来设置或访问CFODataModal类中的函数。


Home

首 页

UCanCode主页

下 载

联 系

CFOMultiPageModel

CFOMultiPageModel类是一个包含其他CFOSubFormModel的可见数据模型。如果你想生成一个类似于CustomMSample的应用程序，你应该从这个基类派生出你自己的类。

使用CFOMultiPageModel

  • 从基类CFOMultiPageModel中派生出一个新类CMyMultiDataModel。你可以用Form++ Library add-in生成这些代码。
  • 给用数据模型生成的CDocument 类添加一个数据成员。例如：CMyMultiDataModel *m_pMultiModel;
  • 在构造函数中添加如下代码：

    CCustomMSampleDoc::CCustomMSampleDoc()
    {
     // TODO: add one-time construction code here
    m_pMultiModel = new CMyMultiDataModel;
    }
  • 在析造函数中添加如下代码：

    CCustomMSampleDoc::~CCustomMSampleDoc()
    {
     if(m_pMultiModel != NULL)
    {
    delete m_pMultiModel;
    m_pMultiModel = NULL;
    }
    }

  • 在OnNewDocument() 函数函数中添加如下代码：

    BOOL
      CCustomMSampleDoc::OnNewDocument()
{
m_pMultiModel->SetDocument(this);
if (!CDocument::OnNewDocument())
return FALSE;

// TODO: add reinitialization code here
// (SDI documents will reuse this document)
m_pMultiModel->OnNewDocument();

return TRUE;
}
  • 在Serialize()函数中添加如下代码：

    void CCustomMSampleDoc::Serialize(CArchive&
      ar)
{
m_pMultiModel->Serialize(ar);
if (ar.IsStoring())
{
// TODO: add storing code here
}
else
{
// TODO: add loading code here
}
}
  • 添加DeleteContents()函数，代码如下：

    void
      CCustomMSampleDoc::DeleteContents()
{
// TODO: Add your specialized code here and/or call the base
      class
if(m_pMultiModel != NULL)
{
m_pMultiModel->ResetContent();
}
CDocument::DeleteContents();
}
  • 添加OnSaveDocument()函数，代码如下：

    BOOL CCustomMSampleDoc::OnSaveDocument(LPCTSTR
      lpszPathName)
{
// TODO: Add your specialized code here and/or call the base
      class
m_pMultiModel->SetDocument(this);
return CDocument::OnSaveDocument(lpszPathName);
}
  • 添加OnOpenDocument()函数，代码如下：

    BOOL CCustomMSampleDoc::OnOpenDocument(LPCTSTR
      lpszPathName)
{
m_pMultiModel->SetDocument(this);
if (!CDocument::OnOpenDocument(lpszPathName))
return FALSE;

// TODO: Add your specialized creation code here
m_pMultiModel->OnOpenDocument();
return TRUE;
}
  • 使用数据成员m_pMultiModel来设置或访问CFOMultiPageModel中的函数。


Home

首 页

UCanCode主页

下 载

联 系

CFOMultiTabModel

CFOMultiTabModel 类是一个包含CFOMultiTabModel类的可见模型。如果你想要你的应用程序支持多页，你需要使用这个类。如果你想生成类似于CustomMSample的应用程序，你应该从这个基类派生你自己的类。

使用 CFOMultiTabModel

  • 从CFOMultiTabModelCreate类中派生出一个新类CMyMultiDataModel。你可以用Form++ Library add-in来生成代码。
  • 给用数据模型生成的CDocument类添加一个数据成员。例如：
    CMyMultiDataModel *m_pMultiModel;
  • 在构造函数中添加如下代码：

    CMultiPageDoc::CMultiPageDoc()
    {
    // TODO: add one-time construction code here
    m_pMultiModel = new CMyMultiDataModel;
    }
  • 在析造函数中添加如下代码：

    CMultiPageDoc::~CMultiPageDoc()
    {
    if(m_pMultiModel != NULL)
    {
    delete m_pMultiModel;
    m_pMultiModel = NULL;
    }
    }

  • 在OnNewDocument()函数中添加如下代码：

    BOOL CMultiPageDoc::OnNewDocument()
    {
    m_pMultiModel->SetDocument(this);
    if (!CDocument::OnNewDocument())
    return FALSE;

    // TODO: add reinitialization code here
    // (SDI documents will reuse this document)
    m_pMultiModel->OnNewDocument();

    return TRUE;
    }

  • 在Serialize()函数中添加如下代码：

    void CMultiPageDoc::Serialize(CArchive& ar)
    {
    m_pMultiModel->Serialize(ar);
    if (ar.IsStoring())
    {
    // TODO: add storing code here
    }
    else
    {
    // TODO: add loading code here
    }
    }

  • 添加DeleteContents()函数，代码如下：

    void CMultiPageDoc::DeleteContents()
{
// TODO: Add your specialized code here and/or call the base
      class
if(m_pMultiModel != NULL)
{
m_pMultiModel->ResetContent();
}
CDocument::DeleteContents();
}
  • 添加OnSaveDocument()函数，代码如下：

    BOOL CMultiPageDoc::OnSaveDocument(LPCTSTR
      lpszPathName)
{
// TODO: Add your specialized code here and/or call the base
      class
m_pMultiModel->SetDocument(this);
return CDocument::OnSaveDocument(lpszPathName);
}
  • 添加OnOpenDocument()函数，代码如下：

    BOOL CMultiPageDoc::OnOpenDocument(LPCTSTR
      lpszPathName)
{
m_pMultiModel->SetDocument(this);
if (!CDocument::OnOpenDocument(lpszPathName))
return FALSE;

// TODO: Add your specialized creation code here
m_pMultiModel->OnOpenDocument();
return TRUE;
}
  • 使用数据成员m_pMultiModel来设置或访问CFOMultiTabModel类中的函数。


Home

首 页

UCanCode主页

下 载

联 系

CFOSubFormModel

CFOSubFormModel 类是一个可见组件，它包含其他可见组件。这个模型是为多页模型而用的。每页都有它各自的CFOSubFormModel类对象，该对象包含了页的全部信息。该类只用于定义多页模型。如果你想创建一个类似于CustomMSample的应用程序，你应该从这个基类派生你自己的数据模型类。

使用 CFOSubFormModel

  • 从基类CFOSubFormModel中派生CMyExtDataModel类。你可以用Form++ Library add-in来生成这些代码。
  • 如果你要在这个数据模型中创建新类，你需要生成以下3个函数：

    // Attributes
    public:
    virtual CFODrawComponent *DoCreateComponentByType(UINT     m_drawshape,CRect &rcCreate,CString strFileName = "",CFOToolBoxItem *pCurItem = NULL);
    virtual CString GetUniqueName(UINT nType);
    virtual CString GetUniqueCaption(UINT nType);
    CString CMyExtDataModel::GetUniqueName(UINT nType)
    {
    return CFOSubFormModel::GetUniqueName(nType);
    }
    CString CMyExtDataModel::GetUniqueCaption(UINT nType)
    {
    return CFOSubFormModel::GetUniqueCaption(nType);
    }
    CFODrawComponent *CMyExtDataModel::DoCreateComponentByType(UINT m_drawshape,CRect &rcCreate,CString strFileName,CFOToolBoxItem *pCurItem)
    {
     CFODrawComponent *pReturn = NULL;
    pReturn = CFOSubFormModel::DoCreateComponentByType(m_drawshape,rcCreate,strFileName);

    }
  • CFOSubFormModel类应该和CFOMultiPageModel类一起运行，这样你应该从CFOMultiPageModel类中派生出一个类。例如：CMyMultiDataModel 类和以下3个函数：

    virtual CFOSubFormModel* AddNewModel(CString strCaption = "");

    CFOSubFormModel *CMyMultiDataModel::AddNewModel(CString strCaption)
    {
     int nPageNumber = GetUniquePageNumber();
    if(strCaption.IsEmpty())
    {
    strCaption = GetUniquePageCaption();
    }
    CMyExtDataModel *pModel = new CMyExtDataModel;
    pModel->SetPageItemCaption(strCaption);
    pModel->SetPageItemNumber( nPageNumber );
    pModel->SetPageItemSelected(TRUE);
    m_ModelList.AddTail(pModel);
    ChangeModel(pModel->GetPageItemNumber());
    GetDocument()->SetModifiedFlag();
    return pModel;
     }


Home

首 页

UCanCode主页

下 载

联 系

CFOTabPageModel

CFOTabPageModel类是一个可见组件，它包含了其他的可见组件。这个模型是为多页模型而用的。每页都有它各自的CFOTabPageModel类对象，这个对象包含了页的全部信息。这个类是用于定义多页模型。如果你想创建类似于MultiPage的应用程序，你应该从这个基类中派生你自己的模型类。

使用CFOTabPageModel

  • 从基类CFOTabPageModel派生出新类CMyExtDataModel。你可以用Form++ Library add-in生成代码。
  • 如果你想在这个模型中创建一个新组件，你需要生成以下3个函数：

    // Attributes
    public:
    virtual CFODrawComponent *DoCreateComponentByType(UINT     m_drawshape,CRect &rcCreate,CString strFileName = "",CFOToolBoxItem *pCurItem = NULL);
    virtual CString GetUniqueName(UINT nType);
    virtual CString GetUniqueCaption(UINT nType);
    CString CMyExtDataModel::GetUniqueName(UINT nType)
    {
    return CFOTabPageModel ::GetUniqueName(nType);
    }
    CString CMyExtDataModel::GetUniqueCaption(UINT nType)
    {
    return CFOTabPageModel ::GetUniqueCaption(nType);
    }
    CFODrawComponent *CMyExtDataModel::DoCreateComponentByType(UINT m_drawshape,CRect &rcCreate,CString strFileName,CFOToolBoxItem *pCurItem)
    {
    CFODrawComponent *pReturn = NULL;

    pReturn = CFOTabPageModel ::DoCreateComponentByType(m_drawshape,rcCreate,strFileName);

    }
  • CFOTabPageModel类应该和CFOMultiTabModel 类一起运行，因此你应该从CFOMultiTabModel类中派生出一个新类，例如；CMyMultiDataModel类和以下3个函数：

    virtual CFOTabPageModel * AddNewModel(CString strCaption = "");

    CFOTabPageModel
      *CMyMultiDataModel::AddNewModel(CString strCaption)
{
int nPageNumber = GetUniquePageNumber();
if(strCaption.IsEmpty())
{
strCaption = GetUniquePageCaption();
}
CMyExtDataModel *pModel = new CMyExtDataModel;
pModel->SetPageItemCaption(strCaption);
pModel->SetPageItemNumber( nPageNumber );
pModel->SetPageItemSelected(TRUE);
m_ModelList.AddTail(pModel);
ChangeModel(pModel->GetPageItemNumber());
GetDocument()->SetModifiedFlag();
return pModel;
}


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 05:23:03 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ datamodel.htm vti_nexttolasttimemodified:TR|14 Mar 2002 01:38:46 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|15169 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:23:03 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../arrows/images/CFODataModel.bmp vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/CFODataModel.bmp vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 01:42:29 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ datamodel.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|10050 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 01:42:29 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../arrows/images/CFOMultiPageModel.bmp vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/CFOMultiPageModel.bmp vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 03:09:33 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ datamodel.htm vti_nexttolasttimemodified:TR|14 Mar 2002 02:43:58 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|9414 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:09:33 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../Data\\ Model/CFOMultiTabModel.gif vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|Data\\ Model/CFOMultiTabModel.gif vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 02:50:50 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ datamodel.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|7625 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 02:50:50 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../arrows/images/CFOSubFormModel.bmp vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/CFOSubFormModel.bmp vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 01:38:18 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ datamodel.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|7184 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 01:38:18 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../Data\\ Model/CFOTabPageModel.gif vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|Data\\ Model/CFOTabPageModel.gif vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


Home

首 页

UCanCode主页

下 载

联 系

CFOBaseView

CFOBaseView类是一个窗体基类。每一个视图类都有垂直和水平滚动条。当窗体大小超过客户区大小时，滚动条就会自动显示。

使用CFOBaseView class:

  • 从基类CFOBaseView派生出一个新类CCustomSampleView。你可以用Form++ Library add-in生成代码。
  • 添加如下2个函数：
    • // Attributes
      public:
      virtual void OnInitialUpdate(); // called first time after construct
      virtual void OnDraw(CDC* pDC); // overridden to draw this view

      ON_COMMAND(ID_FILE_PRINT, CFOBaseView::OnFilePrint)
      ON_COMMAND(ID_FILE_PRINT_DIRECT, CFOBaseView::OnFilePrint)
      ON_COMMAND(ID_FILE_PRINT_PREVIEW, CFOBaseView::OnFilePrintPreview)

      void CCustomSampleView::OnInitialUpdate()
      {

      // Form++ Library Add line.
      SetCurrentModel(GetDocument()->m_pDataModel);

      CFOBaseView::OnInitialUpdate();

      }

      void
                CCustomSampleView::OnDraw(CDC* pDC)
{
CCustomSampleDoc* pDoc = GetDocument();
ASSERT_VALID(pDoc);
// TODO: add draw code for native data here

// Form++ Library Add line.
Draw(pDC);
}

      BOOL
                CCustomSampleView::OnPreparePrinting(CPrintInfo* pInfo)
{
// default preparation
return CFOBaseView::OnPreparePrinting(pInfo);
}

void CCustomSampleView::OnBeginPrinting(CDC* pDC, CPrintInfo*
                pInfo)
{
// Form++ Library Add line.
CFOBaseView::OnBeginPrinting(pDC,pInfo);
}
  • 如果你想给派生类增加自己的特点，你可以添加一些基类CFOBaseView的函数。


Home

首 页

UCanCode主页

下 载

联 系

CFOContentView

CFOContentView是一个多页模板视图基类。它负责显示显示模板的内容。如果你想创建类似于CustomMSample的应用程序，你需要使用这个基类来派生其他的类。

使用CFOContentView类:

  • 从CFOContentView派生出一个新类CContentView。你可以用 Form++ Library add-in来生成代码。
  • 添加以下函数：

    // Attributes
    public:
    virtual void OnDraw(CDC* pDC); // overridden to draw this view

    //Form++ Library add line.
    void CContentView::OnDraw(CDC* pDC)
    {
    CDocument* pDoc = GetDocument();
    pDoc;
    // TODO: add draw code here
    OnDrawItems(pDC);
    }

  • 如果你想给自己派生的类增加一些特点，你可以添加一些基类 CFOContentView的函数。


Home

首 页

UCanCode主页

下 载

联 系

CFOMultiPageView

CFOMultiPageView 是一个多页模型的窗体视图基类。CFOMultiPageView类包含了多页可视信息，并且负责显示页。如果你想创建一个类似于CustomMSample的应用程序，你需要从这个基类派生你自己的视图类。

使用CFOMultiPageView类:

  • 从基类CFOMultiPageView派生出一个新类CCustomMSampleView。你可以用Form++ Library add-in产生代码。
  • 添加如下2个函数：
    • // Attributes
      public:
      virtual void OnInitialUpdate(); // called first time after construct
      virtual void OnDraw(CDC* pDC); // overridden to draw this view

      ON_COMMAND(ID_FILE_PRINT, CFOMultiPageView::OnFilePrint)
      ON_COMMAND(ID_FILE_PRINT_DIRECT, CFOMultiPageView::OnFilePrint)
      ON_COMMAND(ID_FILE_PRINT_PREVIEW, CFOMultiPageView::OnFilePrintPreview)

      void
                CCustomMSampleView::OnDraw(CDC* pDC)
{
CCustomMSampleDoc* pDoc = GetDocument();
ASSERT_VALID(pDoc);
// Form++ Library Add line.
Draw(pDC);
// TODO: add draw code for native data here
}

      void CCustomMSampleView::OnInitialUpdate()
      {

      // Form++ Library Add line.
      SetMultiModel(GetDocument()->m_pMultiModel);

      CFOMultiPageView::OnInitialUpdate();

      }

      BOOL
                CCustomMSampleView::OnPreparePrinting(CPrintInfo* pInfo)
{
// default preparation
return CFOBaseView::OnPreparePrinting(pInfo);
}

void CCustomMSampleView::OnBeginPrinting(CDC* pDC, CPrintInfo*
                pInfo)
{
// TODO: add extra initialization before printing
// Form++ Library Add line.
CFOMultiPageView::OnBeginPrinting(pDC,pInfo);
}
  • 如果你想给你派生出来的类增加一些特点，你可以添加基类 CFOMultiPageView的一些函数。


Home

首 页

UCanCode主页

下 载

联 系

CFOTabPageView

CFOTabPageView是多属性页面模型的一个窗体视图基类。CFOTabPageView类包含了多属性页面可视信息，它负责显示多属性页。如果你想创建一个类似于 MultiPage 的应用程序，你应该从这个基类派生出你自己的视图类。

使用CFOTabPageView类:

  • 从基类CFOTabPageView新建一个类CMultiPageView。你可以用Form++ Library add-in生成代码。
  • 添加如下两个函数：
    • // Attributes
      public:
      virtual void OnDraw(CDC* pDC); // overridden to draw this view

      ON_COMMAND(ID_FILE_PRINT, CScrollView::OnFilePrint)
      ON_COMMAND(ID_FILE_PRINT_DIRECT, CScrollView::OnFilePrint)
      ON_COMMAND(ID_FILE_PRINT_PREVIEW, CScrollView::OnFilePrintPreview)

      void
                CMultiPageView::OnDraw(CDC* pDC)
{
CMultiPageDoc* pDoc = GetDocument();
ASSERT_VALID(pDoc);
// Form++ Library Add line.
Draw(pDC);
// TODO: add draw code for native data here
}

      BOOL
                CMultiPageView::OnPreparePrinting(CPrintInfo* pInfo)
{
// default preparation
return CFOBaseView::OnPreparePrinting(pInfo);
}

void CMultiPageView::OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo)
{
// TODO: add extra initialization before printing
// Form++ Library Add line.
CFOBaseView::OnBeginPrinting(pDC,pInfo);
}

  • 如果你想给派生出来的类增加自己的特点，你可以添加基类 CFOTabPageView的一些函数。


s

首 页

UCanCode主页

下 载

联 系

OLE 拖放

Form++允许使用OLE拖放技术来移动组件。只有在你的应用程序中初始化了OLE库，你才可以使用这个功能。在你的应用对象的InitInstance(）函数中加入对AfxOleInit()的调用，就能初始化OLE 库。

使用OLE拖放技术使终端用户可以把组件从一个窗口拖到另一个窗口。它也支持拖动拷贝操作。拖动拷贝操作就是把终端用户正在拖动的组件拷贝到新位置，而不是移动它。如果你不想支持这个功能或是装载OLE动态连接库，就不要对OLE初始化。当OLE没有初始化，包含在CFOBaseView对象中的标准拖放功能就没有。

OLE拖放类层次

1 CFODropSource

当用户开始一个移动操作时，拖放源在CFOBaseView中被创建。它负责确定拖动什么时候开始，除此外，还在拖动操作中提供反馈，而且还确定什么时候拖动终止。

2 CFODropTarget

拖放目标处理拖放操作结束的接收。它确定被拖动的组件落在窗口的什么位置。当拖动操作结束时，它执行移动或是拷贝。


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|01 Apr 2002 07:28:08 -0000 vti_title:SR|Home vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ view.htm vti_nexttolasttimemodified:TW|01 Apr 2002 07:27:59 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|UCC102\\Administrator vti_cacheddtm:TX|01 Apr 2002 07:27:59 -0000 vti_filesize:IR|6568 vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../arrows/images/CFOBaseView.bmp vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/CFOBaseView.bmp vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|14 Mar 2002 02:21:25 -0000 vti_title:SR|Home vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ view.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_filesize:IR|4351 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 02:21:25 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../arrows/images/CFOContentView.bmp vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/CFOContentView.bmp vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|01 Apr 2002 07:29:23 -0000 vti_title:SR|Home vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ view.htm vti_nexttolasttimemodified:TW|01 Apr 2002 07:29:02 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|UCC102\\Administrator vti_cacheddtm:TX|01 Apr 2002 07:28:38 -0000 vti_filesize:IR|7044 vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../arrows/images/CFOMultiPageView.bmp vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|arrows/images/CFOMultiPageView.bmp vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:58:25 -0000 vti_timelastmodified:TR|01 Apr 2002 07:30:03 -0000 vti_title:SR|Home vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ view.htm vti_nexttolasttimemodified:TW|01 Apr 2002 07:29:55 -0000 vti_lineageid:SR|{7E20B8BC-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|UCC102\\Administrator vti_cacheddtm:TX|01 Apr 2002 07:30:03 -0000 vti_filesize:IR|6346 vti_cachedtitle:SR|Home vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|../../view/CFOTabPageView.gif vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|view/CFOTabPageView.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:46:49 -0000 vti_timelastmodified:TR|14 Mar 2002 05:24:51 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|core\\ classes/introduction\\ to\\ view.htm vti_nexttolasttimemodified:TR|14 Mar 2002 03:11:42 -0000 vti_filesize:IR|3509 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B81F-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:24:51 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../../view/OLE\\ Dr8.gif S|../../view/OLE\\ Dr9.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|view/OLE\\ Dr8.gif FSUS|view/OLE\\ Dr9.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

对话框

  • 1 对话框简介

  • 2 组件属性对话框

  • 3 其他对话框


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:48:07 -0000 vti_timelastmodified:TR|14 Mar 2002 03:14:41 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|dialog/component\\ property\\ dialogs.htm dialog/dialog\\ index.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{F14C15FE-C6FB-4BC3-BEF6-6308DBA6C7B4} vti_filesize:IR|3554 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:14:41 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|screen1.bmp S|screen2.bmp S|dialogfill1.gif S|Compon2.gif S|fillshadow.gif K|Component\\ Property\\ Dialogs.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|dialog/screen1.bmp FSUS|dialog/screen2.bmp FSUS|dialog/dialogfill1.gif FSUS|dialog/Compon2.gif FSUS|dialog/fillshadow.gif FKUS|dialog/Component\\ Property\\ Dialogs.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:48:07 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|main.htm vti_nexttolasttimemodified:TR|27 Feb 2002 09:00:45 -0000 vti_filesize:IR|1901 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B7A5-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Introduction\\ to\\ Dialogs.htm H|Component\\ Property\\ Dialogs.htm H|Other\\ Dialogs.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|dialog/Introduction\\ to\\ Dialogs.htm FHUS|dialog/Component\\ Property\\ Dialogs.htm FHUS|dialog/Other\\ Dialogs.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:48:07 -0000 vti_timelastmodified:TR|14 Mar 2002 03:14:56 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|dialog/dialog\\ index.htm dialog/introduction\\ to\\ dialogs.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:23 -0000 vti_lineageid:SR|{7E20B7AF-2670-11D6-A527-525400EA266C} vti_filesize:IR|2219 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:14:56 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|CFOTextBulletDlg.gif S|Introd45.gif S|Introd50.gif S|Introd51.gif K|Introduction\\ to\\ Dialogs.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|dialog/CFOTextBulletDlg.gif FSUS|dialog/Introd45.gif FSUS|dialog/Introd50.gif FSUS|dialog/Introd51.gif FKUS|dialog/Introduction\\ to\\ Dialogs.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:48:07 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:23 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|dialog/other\\ dialogs.htm dialog/dialog\\ index.htm vti_nexttolasttimemodified:TR|27 Feb 2002 08:57:24 -0000 vti_lineageid:SR|{7E20B7B8-2670-11D6-A527-525400EA266C} vti_filesize:IR|4959 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:23 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Other\\ 11.gif S|Other\\ 1.gif S|Other\\ 3.gif S|Other\\ 4.jpg S|Other\\ 5.gif S|pageset.gif S|Other\\ 2.gif S|printheaderandfooter.gif S|imageeditor.gif S|imagetransparent.gif S|toolboxitemtype.gif S|Eventlink.gif S|bullet.gif S|static.gif K|Other\\ Dialogs.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|dialog/Other\\ 11.gif FSUS|dialog/Other\\ 1.gif FSUS|dialog/Other\\ 3.gif FSUS|dialog/Other\\ 4.jpg FSUS|dialog/Other\\ 5.gif FSUS|dialog/pageset.gif FSUS|dialog/Other\\ 2.gif FSUS|dialog/printheaderandfooter.gif FSUS|dialog/imageeditor.gif FSUS|dialog/imagetransparent.gif FSUS|dialog/toolboxitemtype.gif FSUS|dialog/Eventlink.gif FSUS|dialog/bullet.gif FSUS|dialog/static.gif FKUS|dialog/Other\\ Dialogs.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

启动 Form++

  • 1 安装Form++

  • 2 编译Form++ Libraries

  • 3 运行Form++ Library应用程序向导


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:56 -0000 vti_timelastmodified:TR|10 Apr 2002 06:27:33 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|get\\ start\\ with\\ form++/build\\ form++.htm get\\ start\\ with\\ form++/get\\ start\\ index.htm vti_nexttolasttimemodified:TW|10 Apr 2002 06:27:25 -0000 vti_lineageid:SR|{7E20B748-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|RICHISOFT\\Administrator vti_cacheddtm:TX|10 Apr 2002 06:27:33 -0000 vti_filesize:IR|8279 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../_private/top.htm S|instal13.gif S|Build\\ 20.gif K|Build\\ Form++.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Get\\ Start\\ With\\ form++/instal13.gif FSUS|Get\\ Start\\ With\\ form++/Build\\ 20.gif FKUS|get\\ start\\ with\\ form++/Build\\ Form++.htm FSUS|arrows/images/index\\ 2.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:56 -0000 vti_timelastmodified:TR|10 Apr 2002 06:25:13 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_nexttolasttimemodified:TR|14 Mar 2002 05:16:28 -0000 vti_parentlineageid:SR|{7E20B749-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{7E20B836-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|get\\ start\\ with\\ form++/get\\ start\\ index.htm vti_modifiedby:SR|RICHISOFT\\Administrator vti_cacheddtm:TX|10 Apr 2002 06:25:13 -0000 vti_filesize:IR|5085 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../_private/top.htm S|../Quick\\ Tour/FOWIZ0.gif S|../Quick\\ Tour/Run\\ th2.gif S|../Quick\\ Tour/Run\\ th3.gif S|../Quick\\ Tour/Run\\ th4.gif S|../Quick\\ Tour/Run\\ th5.gif S|../Quick\\ Tour/Run\\ th6.gif S|../Quick\\ Tour/Run\\ th7.gif S|../Quick\\ Tour/FOWIZ8.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/FOWIZ0.gif FSUS|Quick\\ Tour/Run\\ th2.gif FSUS|Quick\\ Tour/Run\\ th3.gif FSUS|Quick\\ Tour/Run\\ th4.gif FSUS|Quick\\ Tour/Run\\ th5.gif FSUS|Quick\\ Tour/Run\\ th6.gif FSUS|Quick\\ Tour/Run\\ th7.gif FSUS|Quick\\ Tour/FOWIZ8.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:56 -0000 vti_timelastmodified:TR|10 Apr 2002 06:25:13 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|main.htm vti_nexttolasttimemodified:TR|26 Feb 2002 08:17:08 -0000 vti_lineageid:SR|{7E20B749-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|RICHISOFT\\Administrator vti_cacheddtm:TX|10 Apr 2002 06:25:13 -0000 vti_filesize:IR|2024 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../_private/top.htm H|Installing\\ Form++.htm H|Build\\ Form++.htm H|Form++\\ AppWizard.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|get\\ start\\ with\\ form++/Installing\\ Form++.htm FHUS|get\\ start\\ with\\ form++/Build\\ Form++.htm FHUS|Get\\ Start\\ With\\ form++/Form++\\ AppWizard.htm vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:56 -0000 vti_timelastmodified:TR|10 Apr 2002 06:25:13 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|quick\\ tour/create\\ classes\\ using\\ form++\\ classwizard.htm get\\ start\\ with\\ form++/installing\\ form++.htm get\\ start\\ with\\ form++/get\\ start\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 05:15:03 -0000 vti_lineageid:SR|{7E20B74D-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|RICHISOFT\\Administrator vti_cacheddtm:TX|10 Apr 2002 06:25:13 -0000 vti_filesize:IR|3053 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../_private/top.htm S|Instal13.gif S|Instal14.gif S|Instal15.gif K|Installing\\ Form++.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Get\\ Start\\ With\\ form++/Instal13.gif FSUS|Get\\ Start\\ With\\ form++/Instal14.gif FSUS|Get\\ Start\\ With\\ form++/Instal15.gif FKUS|get\\ start\\ with\\ form++/Installing\\ Form++.htm FSUS|arrows/images/index\\ 2.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:46:16 -0000 vti_timelastmodified:TR|13 Mar 2002 08:10:18 -0000 vti_filesize:IR|3013 vti_title:SR|s vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX| vti_nexttolasttimemodified:TR|13 Mar 2002 07:52:28 -0000 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|13 Mar 2002 08:10:18 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|http://www.ucancode.net H|mailto:support@ucancode.net H|mailto:support@ucancode.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm NHHS|http://www.ucancode.net NHUS|mailto:support@ucancode.net NHUS|mailto:support@ucancode.net vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

Form++简介

  • 1 欢迎使用Form++

  • 2 使用 Form++前的预备知识

  • 3 Form++特点

  • 4 运行环境需求

  • 5 技术支持

  • 6 提供的文档

  • 7 在线资源

  • 8 Form++ 4.0新增功能

top


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:17 -0000 vti_timelastmodified:TR|01 Apr 2002 07:26:07 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TW|01 Apr 2002 07:26:03 -0000 vti_lineageid:SR|{7E20B72A-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|UCC102\\Administrator vti_cacheddtm:TX|01 Apr 2002 07:26:07 -0000 vti_filesize:IR|3803 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../_private/top.htm H|http://www.adobe.com H|http://www.microsoft.com vti_cachedsvcrellinks:VX|FIUS|_private/top.htm NHHS|http://www.adobe.com NHHS|http://www.microsoft.com vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:51 -0000 vti_timelastmodified:TR|14 Mar 2002 08:13:11 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|introduction\\ to\\ form++/features\\ in\\ form++.htm introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 08:12:09 -0000 vti_lineageid:SR|{7E20B733-2670-11D6-A527-525400EA266C} vti_filesize:IR|4366 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 08:13:11 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Featur1.gif S|Featur2.gif S|feaimage3.gif K|Features\\ in\\ Form++.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Introduction\\ to\\ form++/Featur1.gif FSUS|Introduction\\ to\\ form++/Featur2.gif FSUS|Introduction\\ to\\ form++/feaimage3.gif FKUS|Introduction\\ to\\ form++/Features\\ in\\ Form++.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:51 -0000 vti_timelastmodified:TR|14 Mar 2002 03:24:14 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|main.htm introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TR|13 Mar 2002 07:51:55 -0000 vti_lineageid:SR|{7E20B734-2670-11D6-A527-525400EA266C} vti_filesize:IR|2929 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:24:14 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Welcome\\ to\\ Form++.htm H|Prerequisites\\ to\\ Using\\ Form++.htm H|Prerequisites\\ to\\ Using\\ Form++.htm H|Features\\ in\\ Form++.htm H|Software\\ Requirements.htm H|Technical\\ Support.htm H|Available\\ Documents.htm H|Online\\ Resources.htm H|../Introduction\\ to\\ form++/What\\ is\\ New\\ In\\ 4.0.htm K|intro\\ index.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|introduction\\ to\\ form++/Welcome\\ to\\ Form++.htm FHUS|introduction\\ to\\ form++/Prerequisites\\ to\\ Using\\ Form++.htm FHUS|introduction\\ to\\ form++/Prerequisites\\ to\\ Using\\ Form++.htm FHUS|introduction\\ to\\ form++/Features\\ in\\ Form++.htm FHUS|introduction\\ to\\ form++/Software\\ Requirements.htm FHUS|introduction\\ to\\ form++/Technical\\ Support.htm FHUS|introduction\\ to\\ form++/Available\\ Documents.htm FHUS|introduction\\ to\\ form++/Online\\ Resources.htm FHUS|Introduction\\ to\\ form++/What\\ is\\ New\\ In\\ 4.0.htm FKUS|introduction\\ to\\ form++/intro\\ index.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:17 -0000 vti_timelastmodified:TR|14 Mar 2002 07:20:13 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:25 -0000 vti_lineageid:SR|{7E20B73F-2670-11D6-A527-525400EA266C} vti_filesize:IR|1635 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 07:20:13 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|http://www.ucancode.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm NHHS|http://www.ucancode.net vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:17 -0000 vti_timelastmodified:TR|14 Mar 2002 03:23:01 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:25 -0000 vti_parentlineageid:SR|{7E20B742-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{7E20B744-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|introduction\\ to\\ form++/intro\\ index.htm vti_filesize:IR|9858 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:23:01 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|http://www.codeguru.com H|http://www.codeproject.com H|news://msnews.microsoft.com/microsoft.public.vc.language H|news://msnews.microsoft.com/microsoft.public.vc.mfc H|news://msnews.microsoft.com/comp.os.ms-windows.programmer.tools.mfc H|mailto:LISTSERV@LISTSERV.MSN.COM H|http://msdn.microsoft.com/VISUALC/ H|http://www.samblackburn.com/ H|http://www.msj.com H|http://msdn.microsoft.com H|http://support.microsoft.com/directory/ H|http://www.visionx.com/mfcpro H|http://www.visualcnewsletter.com/ H|http://www.relisoft.com H|http://www.iftech.com/ H|http://www.stratconc.com/browselc H|http://www.pcmi.net/mfc/display.asp H|http://www.developers.net/ H|http://mfcexperts.listbot.com/ H|http://program.solobox.com H|http://www.codecranker.com/ H|http://www.codepile.com/ H|http://www.parashift.com/c++-faq-lite/ vti_cachedsvcrellinks:VX|FIUS|_private/top.htm NHHS|http://www.codeguru.com NHHS|http://www.codeproject.com NHUS|news://msnews.microsoft.com/microsoft.public.vc.language NHUS|news://msnews.microsoft.com/microsoft.public.vc.mfc NHUS|news://msnews.microsoft.com/comp.os.ms-windows.programmer.tools.mfc NHUS|mailto:LISTSERV@LISTSERV.MSN.COM NHHS|http://msdn.microsoft.com/VISUALC/ NHHS|http://www.samblackburn.com/ NHHS|http://www.msj.com NHHS|http://msdn.microsoft.com NHHS|http://support.microsoft.com/directory/ NHHS|http://www.visionx.com/mfcpro NHHS|http://www.visualcnewsletter.com/ NHHS|http://www.relisoft.com NHHS|http://www.iftech.com/ NHHS|http://www.stratconc.com/browselc NHHS|http://www.pcmi.net/mfc/display.asp NHHS|http://www.developers.net/ NHHS|http://mfcexperts.listbot.com/ NHHS|http://program.solobox.com NHHS|http://www.codecranker.com/ NHHS|http://www.codepile.com/ NHHS|http://www.parashift.com/c++-faq-lite/ vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:17 -0000 vti_timelastmodified:TR|14 Mar 2002 05:07:42 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 03:23:14 -0000 vti_lineageid:SR|{7E20B740-2670-11D6-A527-525400EA266C} vti_filesize:IR|2256 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:07:42 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:17 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:25 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TR|01 Mar 2002 03:48:47 -0000 vti_lineageid:SR|{7E20B741-2670-11D6-A527-525400EA266C} vti_filesize:IR|2699 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:25 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|http://www.ucancode.net H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@ucancode.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@ucancode.net vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:17 -0000 vti_timelastmodified:TR|14 Mar 2002 05:06:44 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 05:06:16 -0000 vti_lineageid:SR|{7E20B742-2670-11D6-A527-525400EA266C} vti_filesize:IR|3056 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:06:44 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Mar 2002 03:24:14 -0000 vti_extenderversion:SR|4.0.2.3406 vti_author:SR|RICHISOFT\\Administrator vti_timecreated:TR|21 Feb 2002 01:47:44 -0000 vti_title:SR|新增功能 vti_lineageid:SR|{7E20B743-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|introduction\\ to\\ form++/intro\\ index.htm vti_nexttolasttimemodified:TR|13 Mar 2002 07:59:40 -0000 vti_filesize:IR|3541 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|13 Mar 2002 07:59:40 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Newly1.gif S|Newly2.gif S|Newly3.gif S|Newly4.gif S|Newly5.gif S|Newly6.gif S|Newly7.gif S|Newly8.gif S|Newly9.gif S|Newly10.gif S|Newly99.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Introduction\\ to\\ form++/Newly1.gif FSUS|Introduction\\ to\\ form++/Newly2.gif FSUS|Introduction\\ to\\ form++/Newly3.gif FSUS|Introduction\\ to\\ form++/Newly4.gif FSUS|Introduction\\ to\\ form++/Newly5.gif FSUS|Introduction\\ to\\ form++/Newly6.gif FSUS|Introduction\\ to\\ form++/Newly7.gif FSUS|Introduction\\ to\\ form++/Newly8.gif FSUS|Introduction\\ to\\ form++/Newly9.gif FSUS|Introduction\\ to\\ form++/Newly10.gif FSUS|Introduction\\ to\\ form++/Newly99.gif vti_cachedtitle:SR|新增功能 vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

Grid Property

The grid is a set of evenly spaced points on the Form that you can use to align components. The grid is defined by horizontal and vertical spacing values maintained by the form. When the snap-to-grid option is enabled, the top left corner of a component is aligned to a grid point when the component is moved. The snap to grid feature can be enabled and disabled using the View|Grid Properties menu command. Grid visibility can be turned on and off using the View|Grid menu command.

To change the distance between the points of the grid or to change the color of the grid, you need to change properties in the Grid Properties dialog box. To open this dialog, select Grid Properties from the View menu.

Grid Properties Dialog Box


s

首 页

UCanCode主页

下 载

联 系

产品综述

  • 1 介绍

  • 2 Form++中关键概念

  • 3 Form++ Library应用程序向导

  • 4 画图功能

  • 5 画图组件

  • 6 控制组件布局

  • 7 属性页

  • 8 标尺

  • 9 导出文件

  • 10 页面布局

  • 11 背景

    top


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:25 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm vti_nexttolasttimemodified:TR|27 Feb 2002 01:18:28 -0000 vti_filesize:IR|1590 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B76E-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:25 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:08:51 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:25 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm product\\ overview/definitions.htm vti_nexttolasttimemodified:TR|26 Feb 2002 08:53:18 -0000 vti_lineageid:SR|{7E20B72E-2670-11D6-A527-525400EA266C} vti_filesize:IR|3414 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:25 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../Introduction\\ to\\ form++/Defini3.gif S|Defini31.gif S|Defini32.gif S|Defini33.gif K|Definitions.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Introduction\\ to\\ form++/Defini3.gif FSUS|Product\\ Overview/Defini31.gif FSUS|Product\\ Overview/Defini32.gif FSUS|Product\\ Overview/Defini33.gif FKUS|Product\\ Overview/Definitions.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:25 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm product\\ overview/drawing\\ capabilities.htm vti_nexttolasttimemodified:TR|01 Mar 2002 03:53:55 -0000 vti_lineageid:SR|{7E20B770-2670-11D6-A527-525400EA266C} vti_filesize:IR|3039 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:25 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net K|Drawing\\ Capabilities.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FKUS|Product\\ Overview/Drawing\\ Capabilities.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|14 Mar 2002 03:27:26 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 03:27:17 -0000 vti_lineageid:SR|{7E20B771-2670-11D6-A527-525400EA266C} vti_filesize:IR|5619 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:27:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Drawin1.gif S|drawline.gif S|Drawin2.gif S|drawarrowline.gif S|Drawin3.gif S|Drawin4.gif S|Drawin5.gif S|Drawin6.gif S|Drawin7.gif S|Drawin8.gif S|Drawin9.gif S|Drawin10.gif S|Drawin11.gif S|Drawin12.gif S|Drawin13.gif S|Drawin14.gif S|Drawin15.gif S|Drawin16.gif S|Drawin17.gif S|Drawin18.gif S|Drawin19.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Product\\ Overview/Drawin1.gif FSUS|Product\\ Overview/drawline.gif FSUS|Product\\ Overview/Drawin2.gif FSUS|Product\\ Overview/drawarrowline.gif FSUS|Product\\ Overview/Drawin3.gif FSUS|Product\\ Overview/Drawin4.gif FSUS|Product\\ Overview/Drawin5.gif FSUS|Product\\ Overview/Drawin6.gif FSUS|Product\\ Overview/Drawin7.gif FSUS|Product\\ Overview/Drawin8.gif FSUS|Product\\ Overview/Drawin9.gif FSUS|Product\\ Overview/Drawin10.gif FSUS|Product\\ Overview/Drawin11.gif FSUS|Product\\ Overview/Drawin12.gif FSUS|Product\\ Overview/Drawin13.gif FSUS|Product\\ Overview/Drawin14.gif FSUS|Product\\ Overview/Drawin15.gif FSUS|Product\\ Overview/Drawin16.gif FSUS|Product\\ Overview/Drawin17.gif FSUS|Product\\ Overview/Drawin18.gif FSUS|Product\\ Overview/Drawin19.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|14 Mar 2002 05:19:36 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:25 -0000 vti_lineageid:SR|{7E20B772-2670-11D6-A527-525400EA266C} vti_filesize:IR|1893 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:19:36 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:25 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX| vti_nexttolasttimemodified:TR|23 Feb 2002 10:10:17 -0000 vti_filesize:IR|2630 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B774-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:25 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Grid\\ P40.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Product\\ Overview/Grid\\ P40.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:25 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm vti_nexttolasttimemodified:TR|26 Feb 2002 08:47:37 -0000 vti_lineageid:SR|{7E20B775-2670-11D6-A527-525400EA266C} vti_filesize:IR|2289 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:25 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|14 Mar 2002 05:20:13 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm product\\ overview/manipulating\\ components.htm vti_nexttolasttimemodified:TR|14 Mar 2002 03:29:20 -0000 vti_lineageid:SR|{7E20B787-2670-11D6-A527-525400EA266C} vti_filesize:IR|21979 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:20:13 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Manipu22.gif S|selcomp.gif S|Manipu24.gif S|Manipu25.gif S|Manipu26.gif S|Manipu27.gif S|Manipu28.gif S|Manipu29.gif S|nudgeup_button.gif S|nudgedown_button.gif S|nudgeleft_button.gif S|nudgeright_button.gif S|Manipu30.gif S|Manipu31.gif S|Manipu32.gif S|Manipu33.gif S|Manipu34.gif S|Manipu35.gif S|Manipu36.gif S|Manipu37.gif S|Manipu38.gif S|pantool_button.gif S|Manipu20.gif S|Manipu21.gif S|Manipu39.gif S|Manipu40.gif S|Manipu41.gif S|Manipu42.gif S|groupcomps.gif S|Manipu43.gif S|Manipu44.gif S|Manipu45.gif S|Manipu46.gif S|Manipu47.gif K|Manipulating\\ Components.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Product\\ Overview/Manipu22.gif FSUS|Product\\ Overview/selcomp.gif FSUS|Product\\ Overview/Manipu24.gif FSUS|Product\\ Overview/Manipu25.gif FSUS|Product\\ Overview/Manipu26.gif FSUS|Product\\ Overview/Manipu27.gif FSUS|Product\\ Overview/Manipu28.gif FSUS|Product\\ Overview/Manipu29.gif FSUS|Product\\ Overview/nudgeup_button.gif FSUS|Product\\ Overview/nudgedown_button.gif FSUS|Product\\ Overview/nudgeleft_button.gif FSUS|Product\\ Overview/nudgeright_button.gif FSUS|Product\\ Overview/Manipu30.gif FSUS|Product\\ Overview/Manipu31.gif FSUS|Product\\ Overview/Manipu32.gif FSUS|Product\\ Overview/Manipu33.gif FSUS|Product\\ Overview/Manipu34.gif FSUS|Product\\ Overview/Manipu35.gif FSUS|Product\\ Overview/Manipu36.gif FSUS|Product\\ Overview/Manipu37.gif FSUS|Product\\ Overview/Manipu38.gif FSUS|Product\\ Overview/pantool_button.gif FSUS|Product\\ Overview/Manipu20.gif FSUS|Product\\ Overview/Manipu21.gif FSUS|Product\\ Overview/Manipu39.gif FSUS|Product\\ Overview/Manipu40.gif FSUS|Product\\ Overview/Manipu41.gif FSUS|Product\\ Overview/Manipu42.gif FSUS|Product\\ Overview/groupcomps.gif FSUS|Product\\ Overview/Manipu43.gif FSUS|Product\\ Overview/Manipu44.gif FSUS|Product\\ Overview/Manipu45.gif FSUS|Product\\ Overview/Manipu46.gif FSUS|Product\\ Overview/Manipu47.gif FKUS|Product\\ Overview/Manipulating\\ Components.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm vti_nexttolasttimemodified:TR|01 Mar 2002 03:54:21 -0000 vti_lineageid:SR|{7E20B78C-2670-11D6-A527-525400EA266C} vti_filesize:IR|2101 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|page_settings.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Product\\ Overview/page_settings.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm main.htm vti_nexttolasttimemodified:TR|27 Feb 2002 01:16:01 -0000 vti_lineageid:SR|{7E20B78F-2670-11D6-A527-525400EA266C} vti_filesize:IR|3615 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Introduction\\ to\\ Product\\ Overview.htm H|Definitions.htm H|Form++\\ Library\\ Application\\ Wizard/new_detail.htm H|Form++\\ Library\\ Application\\ Wizard/new_detail.htm H|Drawing\\ Capabilities.htm H|Drawing\\ Components.htm H|Manipulating\\ Components.htm H|Property\\ Pages.htm H|Rulers.htm H|File\\ Export.htm H|Page\\ Layout.htm H|Background.htm K|Product\\ Index.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|product\\ overview/Introduction\\ to\\ Product\\ Overview.htm FHUS|product\\ overview/Definitions.htm FHUS|product\\ overview/Form++\\ Library\\ Application\\ Wizard/new_detail.htm FHUS|product\\ overview/Form++\\ Library\\ Application\\ Wizard/new_detail.htm FHUS|product\\ overview/Drawing\\ Capabilities.htm FHUS|product\\ overview/Drawing\\ Components.htm FHUS|product\\ overview/Manipulating\\ Components.htm FHUS|product\\ overview/Property\\ Pages.htm FHUS|product\\ overview/Rulers.htm FHUS|product\\ overview/File\\ Export.htm FHUS|product\\ overview/Page\\ Layout.htm FHUS|product\\ overview/Background.htm FKUS|Product\\ Overview/Product\\ Index.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|14 Mar 2002 03:29:46 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm product\\ overview/property\\ pages.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_filesize:IR|2640 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B791-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:29:46 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Proper39.gif K|Property\\ Pages.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Product\\ Overview/Proper39.gif FKUS|Product\\ Overview/Property\\ Pages.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:10:56 -0000 vti_timelastmodified:TR|14 Mar 2002 07:28:22 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_filesize:IR|1693 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B792-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 07:28:22 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Rulers41.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Product\\ Overview/Rulers41.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


New features build in New year!

首　　页

UCanCode主页

下　　载

联　　系

Form++应用程序向导-2

4. 确信不选数据库支持,然后点击Next .

5. 确信支持ActiveX控件,然后点击Next

Next


New features build in New year!

首　　页

UCanCod主页

下　　载

联　　系

Form++应用程序向导-3

6.确保选中以下特点,然后点击Next .
 Docking Toolbar
Initial Status Bar
Printing and Print Preview
3D Controls

7. 确信工程：
Consists of standard MFC
Supports source file comments
Uses MFC as a shared DLL.

然后点击Next。

Next


New features build in New year!

首　　页

UCanCode主页

下　　载

联　　系

Form++ 应用程序向导-4

8. 这个页面显示每个生成的类以及他们的相应文件.点击Next 到下一步。

9. 这个页面包括Form++ Library增加的特点.你可以使你的应用支持或者不支持Form++的特点.选中下面的复选框,然后点击Finish。
Ruler.
Color Palette
ToolBox
Format Bar
Draw Bar
Multipage.(If you have created a single document application, this selection is gray.)

Next


New features build in New year!

首　　　页

UCanCode主页

下　　　载

联　　　系

Form++应用程序向导-5

10. 这个页面显示你为你的应用程序选择的所有信息概括。


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Mar 2002 05:17:53 -0000 vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|product\\ overview/product\\ index.htm vti_author:SR|RICHISOFT\\Administrator vti_timecreated:TR|21 Feb 2002 01:47:43 -0000 vti_title:SR|New features build in New year! vti_lineageid:SR|{7E20B7A1-2670-11D6-A527-525400EA266C} vti_nexttolasttimemodified:TR|14 Mar 2002 05:17:45 -0000 vti_filesize:IR|6056 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:17:53 -0000 vti_cachedlinkinfo:VX|H|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|wiz1.gif S|wiz2.gif H|new_detail1.htm vti_cachedsvcrellinks:VX|NHUS|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz1.gif FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz2.gif FHUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/new_detail1.htm vti_cachedtitle:SR|New features build in New year! vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Mar 2002 03:25:02 -0000 vti_extenderversion:SR|4.0.2.3406 vti_author:SR|RICHISOFT\\Administrator vti_timecreated:TR|21 Feb 2002 01:47:43 -0000 vti_title:SR|New features build in New year! vti_lineageid:SR|{7E20B794-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|product\\ overview/form++\\ library\\ application\\ wizard/new_detail.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_filesize:IR|4392 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:25:02 -0000 vti_cachedlinkinfo:VX|H|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|wiz3.gif S|wiz4.gif H|new_detail2.htm vti_cachedsvcrellinks:VX|NHUS|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz3.gif FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz4.gif FHUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/new_detail2.htm vti_cachedtitle:SR|New features build in New year! vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_extenderversion:SR|4.0.2.3406 vti_author:SR|RICHISOFT\\Administrator vti_timecreated:TR|21 Feb 2002 01:47:43 -0000 vti_title:SR|New features build in New year! vti_lineageid:SR|{7E20B795-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|product\\ overview/form++\\ library\\ application\\ wizard/new_detail1.htm vti_nexttolasttimemodified:TR|02 Mar 2002 01:19:40 -0000 vti_filesize:IR|5642 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|H|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|wiz5.gif S|wiz6.gif H|new_detail3.htm vti_cachedsvcrellinks:VX|NHUS|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz5.gif FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz6.gif FHUS|product\\ overview/form++\\ library\\ application\\ wizard/new_detail3.htm vti_cachedtitle:SR|New features build in New year! vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_extenderversion:SR|4.0.2.3406 vti_author:SR|RICHISOFT\\Administrator vti_timecreated:TR|21 Feb 2002 01:47:43 -0000 vti_title:SR|New features build in New year! vti_lineageid:SR|{7E20B796-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|product\\ overview/form++\\ library\\ application\\ wizard/new_detail2.htm vti_nexttolasttimemodified:TR|02 Mar 2002 01:20:59 -0000 vti_filesize:IR|5469 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|H|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|wiz7.gif S|wiz8.gif H|new_detail4.htm vti_cachedsvcrellinks:VX|NHUS|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz7.gif FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz8.gif FHUS|product\\ overview/form++\\ library\\ application\\ wizard/new_detail4.htm vti_cachedtitle:SR|New features build in New year! vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_extenderversion:SR|4.0.2.3406 vti_author:SR|RICHISOFT\\Administrator vti_timecreated:TR|21 Feb 2002 01:47:43 -0000 vti_title:SR|New features build in New year! vti_lineageid:SR|{7E20B797-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|product\\ overview/form++\\ library\\ application\\ wizard/new_detail3.htm vti_nexttolasttimemodified:TR|02 Mar 2002 01:22:24 -0000 vti_filesize:IR|3382 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|H|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net S|wiz9.gif vti_cachedsvcrellinks:VX|NHUS|mk:@MSITStore:C:/Documents\\ and\\ Settings/ryatom/妗岄潰/backup\\ OF/form/Output_Eng/form.chm::/Htmls/main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net FSUS|Product\\ Overview/Form++\\ Library\\ Application\\ Wizard/wiz9.gif vti_cachedtitle:SR|New features build in New year! vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

属性

  • 1 属性介绍

  • 2 属性对象

  • 3 属性IDs

  • 4 获得和设置属性

  • 5 属性类

  • 6 属性对话框


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:47 -0000 vti_timelastmodified:TR|14 Mar 2002 03:37:00 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|properties/property\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 03:35:58 -0000 vti_lineageid:SR|{7E20B817-2670-11D6-A527-525400EA266C} vti_filesize:IR|7314 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:37:00 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Gettin36.gif S|Gettin37.gif S|Gettin38.gif S|Gettin39.gif S|Gettin42.gif S|Gettin43.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Properties/Gettin36.gif FSUS|Properties/Gettin37.gif FSUS|Properties/Gettin38.gif FSUS|Properties/Gettin39.gif FSUS|Properties/Gettin42.gif FSUS|Properties/Gettin43.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:47 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|properties/property\\ index.htm vti_nexttolasttimemodified:TR|27 Feb 2002 07:49:21 -0000 vti_filesize:IR|1968 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B819-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Introd44.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Properties/Introd44.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 03:37:44 -0000 vti_timelastmodified:TR|14 Mar 2002 03:37:15 -0000 vti_title:SR|属性对话框设置 vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|properties/property\\ index.htm properties/properties\\ dialog.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_lineageid:SR|{7E20B816-2670-11D6-A527-525400EA266C} vti_filesize:IR|3705 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:37:15 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../dialog/screen1.bmp S|../dialog/screen2.bmp S|../dialog/dialogfill1.gif S|../dialog/Compon2.gif S|../dialog/fillshadow.gif K|Properties\\ Dialog.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|dialog/screen1.bmp FSUS|dialog/screen2.bmp FSUS|dialog/dialogfill1.gif FSUS|dialog/Compon2.gif FSUS|dialog/fillshadow.gif FKUS|Properties/Properties\\ Dialog.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|属性对话框设置 vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|14 Mar 2002 06:26:26 -0000 vti_extenderversion:SR|4.0.2.3406 vti_author:SR|RICHISOFT\\Administrator vti_timecreated:TR|21 Feb 2002 01:47:44 -0000 vti_title:SR|属性类 vti_lineageid:SR|{7E20B804-2670-11D6-A527-525400EA266C} vti_backlinkinfo:VX|properties/property\\ index.htm properties/property\\ classes.htm _vti_pvt/_x_todo.htm vti_nexttolasttimemodified:TR|14 Mar 2002 06:25:52 -0000 vti_filesize:IR|3996 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 06:26:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa1.gif S|../Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa2.gif S|../Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa3.gif S|../Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa4.gif S|../Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa5.gif S|../Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa6.gif K|Property\\ Classes.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa1.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa2.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa3.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa4.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa5.gif FSUS|Components/properties\\ and\\ dialog\\ and\\ components/page/new_pa6.gif FKUS|Properties/Property\\ Classes.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|属性类 vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:47 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|properties/property\\ index.htm vti_nexttolasttimemodified:TR|27 Feb 2002 07:53:58 -0000 vti_lineageid:SR|{7E20B81A-2670-11D6-A527-525400EA266C} vti_filesize:IR|2296 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:47 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:26 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|main.htm vti_nexttolasttimemodified:TR|27 Feb 2002 07:47:17 -0000 vti_lineageid:SR|{7E20B81B-2670-11D6-A527-525400EA266C} vti_filesize:IR|2442 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:26 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Introduction\\ to\\ Properties.htm H|Property\\ Objects.htm H|Property\\ ID.htm H|How\\ to\\ Get\\ and\\ Set\\ Properties\\ .htm H|Property\\ Classes.htm H|../Properties/Properties\\ Dialog.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|properties/Introduction\\ to\\ Properties.htm FHUS|properties/Property\\ Objects.htm FHUS|properties/Property\\ ID.htm FHUS|properties/How\\ to\\ Get\\ and\\ Set\\ Properties\\ .htm FHUS|properties/Property\\ Classes.htm FHUS|Properties/Properties\\ Dialog.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 02:47:47 -0000 vti_timelastmodified:TR|14 Mar 2002 07:05:21 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|properties/property\\ index.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_lineageid:SR|{7E20B81C-2670-11D6-A527-525400EA266C} vti_filesize:IR|3392 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 07:05:21 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

快速教程

  • 1 概述

  • 2 运行Visual C++ AppWizard

  • 3 使用Form++ Library add-in创建类

  • 4 增加绘图组件工具栏

  • 5 增加格式工具栏

  • 6 增加菜单项和加速键


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 03:41:39 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|quick\\ tour/add\\ components\\ toolbox.htm quick\\ tour/tour\\ index.htm samples/tour\\ index.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_lineageid:SR|{7E20B74E-2670-11D6-A527-525400EA266C} vti_filesize:IR|6204 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:41:39 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Add\\ dr17.gif K|Add\\ Components\\ ToolBox.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Add\\ dr17.gif FKUS|Quick\\ Tour/Add\\ Components\\ ToolBox.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 05:12:12 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|quick\\ tour/add\\ draw\\ toolbar.htm samples/tour\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 05:11:58 -0000 vti_lineageid:SR|{7E20B751-2670-11D6-A527-525400EA266C} vti_filesize:IR|8046 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:12:12 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Add\\ dr17.gif K|Add\\ Draw\\ toolbar.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Add\\ dr17.gif FKUS|Quick\\ Tour/Add\\ Draw\\ toolbar.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 05:13:51 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|quick\\ tour/add\\ format\\ component\\ toolbar.htm quick\\ tour/tour\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 05:13:19 -0000 vti_lineageid:SR|{7E20B752-2670-11D6-A527-525400EA266C} vti_filesize:IR|7515 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:13:51 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Add\\ dr18.gif K|Add\\ Format\\ component\\ toolbar.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Add\\ dr18.gif FKUS|Quick\\ Tour/Add\\ Format\\ component\\ toolbar.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 05:14:13 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|quick\\ tour/tour\\ index.htm samples/tour\\ index.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_lineageid:SR|{7E20B753-2670-11D6-A527-525400EA266C} vti_filesize:IR|2619 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:14:13 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 05:10:05 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|quick\\ tour/create\\ classes\\ using\\ form++\\ classwizard.htm quick\\ tour/tour\\ index.htm samples/tour\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 03:02:08 -0000 vti_lineageid:SR|{7E20B754-2670-11D6-A527-525400EA266C} vti_filesize:IR|7809 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 05:10:05 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Create9.gif S|Create10.gif S|Create11.gif S|Create12.gif S|Create13.gif S|Create15.gif S|Create16.gif H|../Get\\ Start\\ With\\ form++/Installing\\ Form++.htm S|Create14.gif K|Create\\ classes\\ using\\ form++\\ classwizard.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Create9.gif FSUS|Quick\\ Tour/Create10.gif FSUS|Quick\\ Tour/Create11.gif FSUS|Quick\\ Tour/Create12.gif FSUS|Quick\\ Tour/Create13.gif FSUS|Quick\\ Tour/Create15.gif FSUS|Quick\\ Tour/Create16.gif FHUS|Get\\ Start\\ With\\ form++/Installing\\ Form++.htm FSUS|Quick\\ Tour/Create14.gif FKUS|Quick\\ Tour/Create\\ classes\\ using\\ form++\\ classwizard.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|01 Apr 2002 07:50:04 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_backlinkinfo:VX|quick\\ tour/tour\\ index.htm samples/tour\\ index.htm quick\\ tour/run\\ the\\ visual\\ c++\\ appwizard.htm vti_nexttolasttimemodified:TW|14 Mar 2002 05:09:25 -0000 vti_lineageid:SR|{7E20B766-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|UCC102\\Administrator vti_cacheddtm:TX|01 Apr 2002 07:50:04 -0000 vti_filesize:IR|6274 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../_private/top.htm S|FOWIZ0.gif S|Run\\ th2.gif S|Run\\ th3.gif S|Run\\ th4.gif S|Run\\ th5.gif S|Run\\ th6.gif S|Run\\ th7.gif S|FOWIZ8.gif S|test1sample.gif S|test2sample.gif K|Run\\ the\\ Visual\\ C++\\ AppWizard.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/FOWIZ0.gif FSUS|Quick\\ Tour/Run\\ th2.gif FSUS|Quick\\ Tour/Run\\ th3.gif FSUS|Quick\\ Tour/Run\\ th4.gif FSUS|Quick\\ Tour/Run\\ th5.gif FSUS|Quick\\ Tour/Run\\ th6.gif FSUS|Quick\\ Tour/Run\\ th7.gif FSUS|Quick\\ Tour/FOWIZ8.gif FSUS|Quick\\ Tour/test1sample.gif FSUS|Quick\\ Tour/test2sample.gif FKUS|quick\\ tour/Run\\ the\\ Visual\\ C++\\ AppWizard.htm FSUS|arrows/images/index\\ 2.gif vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 03:42:50 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|quick\\ tour/tour\\ index.htm samples/tour\\ index.htm vti_nexttolasttimemodified:TR|14 Mar 2002 01:41:58 -0000 vti_lineageid:SR|{7E20B767-2670-11D6-A527-525400EA266C} vti_filesize:IR|2465 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:42:51 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 02:44:43 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|main.htm vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:26 -0000 vti_filesize:IR|3021 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B768-2670-11D6-A527-525400EA266C} vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 02:44:43 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Summary\\ of\\ the\\ Quick\\ Tour.htm H|Run\\ the\\ Visual\\ C++\\ AppWizard.htm H|Create\\ classes\\ using\\ form++\\ classwizard.htm H|Add\\ Draw\\ toolbar.htm H|Add\\ Format\\ component\\ toolbar.htm H|Adding\\ Menu\\ Items\\ and\\ Accelerators.htm H|Add\\ Components\\ ToolBox.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|quick\\ tour/Summary\\ of\\ the\\ Quick\\ Tour.htm FHUS|quick\\ tour/Run\\ the\\ Visual\\ C++\\ AppWizard.htm FHUS|quick\\ tour/Create\\ classes\\ using\\ form++\\ classwizard.htm FHUS|Quick\\ Tour/Add\\ Draw\\ toolbar.htm FHUS|quick\\ tour/Add\\ Format\\ component\\ toolbar.htm FHUS|quick\\ tour/Adding\\ Menu\\ Items\\ and\\ Accelerators.htm FHUS|quick\\ tour/Add\\ Components\\ ToolBox.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 02:08:10 -0000 vti_parentlineageid:SR|{7E20B768-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{653ED8F6-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|main.htm vti_filesize:IR|5642 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|FOSample\\ tutorial/Summary\\ of\\ Tour.htm H|FOSample\\ tutorial/Create\\ a\\ New\\ fosample\\ Project.htm H|FOSample\\ tutorial/FOSample\\ AppWizard\\ Options.htm H|FOSample\\ tutorial/Modify\\ FOSample's\\ stdafx.h.htm H|FOSample\\ tutorial/Include\\ Form++\\ \\ Resources\\ in\\ fosample.htm H|FOSample\\ tutorial/Modify\\ the\\ fosample\\ Application\\ Implementation\\ File.htm H|FOSample\\ tutorial/Modify\\ fosample\\ View's\\ Header\\ File.htm H|FOSample\\ tutorial/Modify\\ fosample\\ Doc's\\ Header\\ Files.htm H|FOSample\\ tutorial/Modify\\ FOSample\\ View's\\ Implementation\\ File.htm H|FOSample\\ tutorial/Drive\\ a\\ new\\ model\\ calss.htm H|FOSample\\ tutorial/Modify\\ fosample\\ View's\\ Header\\ File.htm H|FOSample\\ tutorial/Modify\\ FOSample\\ Doc's\\ Implementation\\ File.htm H|FOSample\\ tutorial/Add\\ Draw\\ toolbar.htm H|FOSample\\ tutorial/Add\\ Format\\ component\\ toolbar.htm H|FOSample\\ tutorial/Adding\\ Menu\\ Items\\ and\\ Accelerators.htm H|FOSample\\ tutorial/Add\\ Components\\ ToolBox.htm H|FOSample\\ tutorial/Copying\\ toolbox\\ item\\ file.htm H|FOSample\\ tutorial/Compile\\ and\\ run\\ FOSample.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|samples/FOSample\\ tutorial/Summary\\ of\\ Tour.htm FHUS|samples/FOSample\\ tutorial/Create\\ a\\ New\\ fosample\\ Project.htm FHUS|samples/FOSample\\ tutorial/FOSample\\ AppWizard\\ Options.htm FHUS|Samples/FOSample\\ tutorial/Modify\\ FOSample's\\ stdafx.h.htm FHUS|samples/FOSample\\ tutorial/Include\\ Form++\\ \\ Resources\\ in\\ fosample.htm FHUS|samples/FOSample\\ tutorial/Modify\\ the\\ fosample\\ Application\\ Implementation\\ File.htm FHUS|Samples/FOSample\\ tutorial/Modify\\ fosample\\ View's\\ Header\\ File.htm FHUS|samples/FOSample\\ tutorial/Modify\\ fosample\\ Doc's\\ Header\\ Files.htm FHUS|samples/FOSample\\ tutorial/Modify\\ FOSample\\ View's\\ Implementation\\ File.htm FHUS|samples/FOSample\\ tutorial/Drive\\ a\\ new\\ model\\ calss.htm FHUS|Samples/FOSample\\ tutorial/Modify\\ fosample\\ View's\\ Header\\ File.htm FHUS|Samples/FOSample\\ tutorial/Modify\\ FOSample\\ Doc's\\ Implementation\\ File.htm FHUS|samples/FOSample\\ tutorial/Add\\ Draw\\ toolbar.htm FHUS|Samples/FOSample\\ tutorial/Add\\ Format\\ component\\ toolbar.htm FHUS|samples/FOSample\\ tutorial/Adding\\ Menu\\ Items\\ and\\ Accelerators.htm FHUS|samples/FOSample\\ tutorial/Add\\ Components\\ ToolBox.htm FHUS|samples/FOSample\\ tutorial/Copying\\ toolbox\\ item\\ file.htm FHUS|samples/FOSample\\ tutorial/Compile\\ and\\ run\\ FOSample.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

修改FOSample应用程序中的执行文件

Form++用FOInit()函数初始化资源和变量。为了确保在调用任何Form++库函数之前就初始化Form++库，这个函数应该放在你的应用程序的InitInstance()中。要想了解更多关于FOInit()函数的信息请见Form++类库参考手册。

  1. 打开FOSample.cpp，找到InitInstance()函数。

  2. 在InitInstance()函数开始位置增加下面两行：
    // This call will initialize the Form++ library
FOInit();
    AfxOleInit();
  3. 保存FOSample.cpp后关闭。


s

首 页

UCanCode主页

下 载

联 系

Override CFOSampleView::OnInitialUpdate()

OnInitialUpdate() is the primary location for initializing the form++ library.

  1. Start ClassWizard (press CTRL+W)

  2. Select CFOSampleView as the Class name.

  3. Select OnInitialUpdate in the Messages list box.

  4. Click Add Function.

  5. ClassWizard adds an OnInitialUpdate() member function to the CFOSampleView class.

  6. Click Edit Code.

  7. Replace the existing OnInitialUpdate() function with the following:
    void CFOSampleView::OnInitialUpdate()
{
    CFOBaseView::OnInitialUpdate();

    // Form++ Library Add line.
    SetCurrentModel(GetDocument()->m_pDataModel);

}
  8. Save and close FOSampleView.cpp.


s

首 页

UCanCode主页

下 载

联 系

FOSample指南

在这一节中你将学会怎样用Form++创建一个小型的应用程序。我们在这里用Form++创建的程序名字叫FOSample，是一个多文档应用程序。

在Form++的安装目录中的Samples\fosample文件夹中有该应用程序的源文件、工程文件和其他必需的文件。

在Form++中，无论何时你要增加代码，原来的代码处都有一段简短的注释。

工程的文件名是fosample.dsw.，你用Visual C++ 6.0 可以打开它。

如果你只是象读该示例指南而不想增加代码，你仍然可以在完成每一步后编译FOSample，看它的运行结果。对于每一步你都要到指定的目录中去打开工程。

FOSample应用程序最终运行结果


s

首 页

UCanCode主页

下 载

联 系

FOSample指南

在这一节中你将学会怎样用Form++创建一个小型的应用程序。我们在这里用Form++创建的程序名字叫FOSample，是一个多文档应用程序。

在Form++的安装目录中的Samples\fosample文件夹中有该应用程序的源文件、工程文件和其他必需的文件。

在Form++中，无论何时你要增加代码，原来的代码处都有一段简短的注释。

工程的文件名是fosample.dsw，你用Visual C++ 6.0可以打开它。

如果你只是象读该示例指南而不想增加代码，你仍然可以在完成每一步后编译FOSample，看它的运行结果。对于每一步你都要到指定的目录中去打开工程。

FOSample应用程序最终运行结果


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 03:16:56 -0000 vti_parentlineageid:SR|{7E20B74E-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{653ED909-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm samples/fosample\\ tutorial/add\\ components\\ toolbox.htm vti_filesize:IR|6197 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../../Quick\\ Tour/Add\\ dr17.gif K|Add\\ Components\\ ToolBox.htm S|../../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Add\\ dr17.gif FKUS|Samples/FOSample\\ tutorial/Add\\ Components\\ ToolBox.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 03:12:07 -0000 vti_parentlineageid:SR|{7E20B751-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{653ED90A-27FB-11D6-A528-525400EA266C} vti_filesize:IR|7668 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|samples/fosample\\ tutorial/add\\ draw\\ toolbar.htm samples/tour\\ index.htm vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../../Quick\\ Tour/Add\\ dr17.gif K|Add\\ Draw\\ toolbar.htm S|../../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Add\\ dr17.gif FKUS|Samples/FOSample\\ tutorial/Add\\ Draw\\ toolbar.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 02:56:45 -0000 vti_parentlineageid:SR|{7E20B752-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{653ED90B-27FB-11D6-A528-525400EA266C} vti_filesize:IR|7874 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|samples/tour\\ index.htm samples/fosample\\ tutorial/add\\ format\\ component\\ toolbar.htm vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../../Quick\\ Tour/Add\\ dr18.gif K|Add\\ Format\\ component\\ toolbar.htm S|../../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Add\\ dr18.gif FKUS|Samples/FOSample\\ tutorial/Add\\ Format\\ component\\ toolbar.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 03:11:57 -0000 vti_parentlineageid:SR|{7E20B753-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{653ED90C-27FB-11D6-A528-525400EA266C} vti_filesize:IR|2566 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|samples/tour\\ index.htm vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|13 Mar 2002 08:08:18 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 03:36:46 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED90D-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|3129 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|13 Mar 2002 08:08:18 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|fosample.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Samples/FOSample\\ tutorial/fosample.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|01 Apr 2002 07:50:23 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_nexttolasttimemodified:TW|02 Mar 2002 02:07:27 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED906-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_modifiedby:SR|UCC102\\Administrator vti_cacheddtm:TX|01 Apr 2002 07:50:23 -0000 vti_filesize:IR|2065 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../../_private/top.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 03:11:32 -0000 vti_parentlineageid:SR|{653ED8F7-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED8F9-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|2607 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Create1.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Samples/FOSample\\ tutorial/Create1.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 02:20:55 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:27 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED905-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|3670 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 02:20:55 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 01:05:09 -0000 vti_parentlineageid:SR|{653ED8F7-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|1990 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|02 Mar 2002 01:37:51 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED905-27FB-11D6-A528-525400EA266C} vti_filesize:IR|2119 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX| vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 01:34:19 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED8FE-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|4811 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|../../Quick\\ Tour/Create16.gif S|21100.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Quick\\ Tour/Create16.gif FSUS|Samples/FOSample\\ tutorial/21100.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 02:07:07 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED902-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|2039 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 05:30:02 -0000 vti_parentlineageid:SR|{653ED903-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED908-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|9394 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 02:06:17 -0000 vti_parentlineageid:SR|{653ED902-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED907-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|1995 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|01 Apr 2002 07:55:08 -0000 vti_title:SR|s vti_extenderversion:SR|5.0.2.2623 vti_nexttolasttimemodified:TW|01 Apr 2002 07:55:06 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED903-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_modifiedby:SR|UCC102\\Administrator vti_cacheddtm:TX|01 Apr 2002 07:55:08 -0000 vti_filesize:IR|4027 vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|-H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net I|../../_private/top.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|01 Mar 2002 01:11:42 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED8FC-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|2334 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Modify2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Samples/FOSample\\ tutorial/Modify2.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 03:44:38 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:27 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED901-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|2516 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:44:38 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TW|23 Feb 2002 02:47:56 -0000 vti_parentlineageid:SR|{653ED8FB-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED904-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX| vti_filesize:IR|2755 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net vti_cachedsvcrellinks:VX|FIUS|_private/top.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|13 Mar 2002 08:09:03 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|28 Feb 2002 09:55:24 -0000 vti_parentlineageid:SR|{653ED8F6-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED8F7-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX|samples/tour\\ index.htm vti_filesize:IR|2464 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|13 Mar 2002 08:09:03 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|fosample.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Samples/FOSample\\ tutorial/fosample.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 01:09:35 -0000 vti_timelastmodified:TR|14 Mar 2002 03:44:59 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|02 Mar 2002 02:07:27 -0000 vti_parentlineageid:SR|{653ED8F6-27FB-11D6-A528-525400EA266C} vti_lineageid:SR|{653ED8F7-27FB-11D6-A528-525400EA266C} vti_backlinkinfo:VX| vti_filesize:IR|2470 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_modifiedby:SR|Administrator vti_cacheddtm:TX|14 Mar 2002 03:44:59 -0000 vti_cachedlinkinfo:VX|I|../../_private/top.htm -H|../../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|fosample.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Samples/FOSample\\ tutorial/fosample.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


s

首 页

UCanCode主页

下 载

联 系

窗体

  • 1 下拉颜色选择器

  • 2 下拉线形选择器

  • 3 下拉线宽选择器

  • 4 下拉箭头选择器

  • 5 选择画刷类型

  • 6 选择阴影类型

  • 7 选择图象类型

  • 8 工具盒

  • 9 其它窗口


共享上边框

Home

UCanCode Home Page

Download

Contact


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_modifiedby:SR|Administrator vti_timecreated:TR|01 Dec 2001 00:47:48 -0000 vti_timelastmodified:TR|01 Dec 2001 03:20:51 -0000 vti_filesize:IR|1073 vti_title:SR|共享上边框 vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 vti_extenderversion:SR|4.0.2.2717 vti_backlinkinfo:VX| vti_nexttolasttimemodified:TR|01 Dec 2001 01:06:26 -0000 vti_cacheddtm:TX|01 Dec 2001 00:47:48 -0000 vti_cachedlinkinfo:VX|H|../../main.htm H|http://www.ucancode.net H|http://www.ucancode.net H|mailto:support@163.net vti_cachedsvcrellinks:VX|FHUS|main.htm NHHS|http://www.ucancode.net NHHS|http://www.ucancode.net NHUS|mailto:support@163.net vti_cachedtitle:SR|共享上边框 vti_cachedbodystyle:SR| vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_extenderversion:SR|4.0.2.3406 vti_filesize:IR|6241 vti_title:SR|Drop down arrow picker vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_nexttolasttimemodified:TR|02 Mar 2002 01:41:51 -0000 vti_author:SR|Administrator vti_timecreated:TR|23 Feb 2002 03:19:45 -0000 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Drop\\ d2.gif S|Drop\\ d3.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/Drop\\ d2.gif FSUS|Windows/Drop\\ d3.gif vti_cachedtitle:SR|Drop down arrow picker vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 03:23:55 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|28 Feb 2002 01:50:33 -0000 vti_parentlineageid:SR|{7E20B846-2670-11D6-A527-525400EA266C} vti_lineageid:SR|{5939FB36-272E-11D6-A528-525400EA266C} vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_filesize:IR|16840 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|colorimage1.gif S|classwell.gif S|COLORISDF.gif S|colorpickerx.gif S|colordialog1.gif S|image001.gif S|image002.gif S|CFOColorDialog.gif S|colorpbar.gif S|colordbar.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/colorimage1.gif FSUS|Windows/classwell.gif FSUS|Windows/COLORISDF.gif FSUS|Windows/colorpickerx.gif FSUS|Windows/colordialog1.gif FSUS|Windows/image001.gif FSUS|Windows/image002.gif FSUS|Windows/CFOColorDialog.gif FSUS|Windows/colorpbar.gif FSUS|Windows/colordbar.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_extenderversion:SR|4.0.2.3406 vti_filesize:IR|6466 vti_title:SR|Drop down line type picker vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_nexttolasttimemodified:TR|28 Feb 2002 02:41:19 -0000 vti_author:SR|Administrator vti_timecreated:TR|23 Feb 2002 03:38:51 -0000 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Drop\\ d4.gif S|Drop\\ d5.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/Drop\\ d4.gif FSUS|Windows/Drop\\ d5.gif vti_cachedtitle:SR|Drop down line type picker vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_extenderversion:SR|4.0.2.3406 vti_filesize:IR|6131 vti_title:SR|Drop down line width picker vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_nexttolasttimemodified:TR|28 Feb 2002 03:18:08 -0000 vti_author:SR|Administrator vti_timecreated:TR|23 Feb 2002 03:41:06 -0000 vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Drop\\ d6.gif S|Drop\\ d7.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/Drop\\ d6.gif FSUS|Windows/Drop\\ d7.gif vti_cachedtitle:SR|Drop down line width picker vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 03:23:55 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:27 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|main.htm vti_nexttolasttimemodified:TR|28 Feb 2002 03:04:57 -0000 vti_filesize:IR|3068 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_lineageid:SR|{7E20B846-2670-11D6-A527-525400EA266C} vti_cacheddtm:TX|02 Mar 2002 02:07:27 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net H|Drop\\ down\\ color\\ picker.htm H|Drop\\ down\\ line\\ type\\ picker.htm H|Drop\\ down\\ line\\ width\\ picker.htm H|Drop\\ down\\ line\\ width\\ picker.htm H|Drop\\ down\\ arrow\\ picker.htm H|Drop\\ down\\ arrow\\ picker.htm H|Select\\ Brush\\ Type.htm H|Select\\ Gradient\\ Type.htm H|Select\\ Image\\ Type.htm H|ToolBox\\ Bar.htm H|Other\\ Windows.htm vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FHUS|windows/Drop\\ down\\ color\\ picker.htm FHUS|windows/Drop\\ down\\ line\\ type\\ picker.htm FHUS|windows/Drop\\ down\\ line\\ width\\ picker.htm FHUS|windows/Drop\\ down\\ line\\ width\\ picker.htm FHUS|windows/Drop\\ down\\ arrow\\ picker.htm FHUS|windows/Drop\\ down\\ arrow\\ picker.htm FHUS|windows/Select\\ Brush\\ Type.htm FHUS|windows/Select\\ Gradient\\ Type.htm FHUS|windows/Select\\ Image\\ Type.htm FHUS|windows/ToolBox\\ Bar.htm FHUS|windows/Other\\ Windows.htm vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 03:20:50 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:28 -0000 vti_title:SR|窗体类 vti_extenderversion:SR|4.0.2.3406 vti_backlinkinfo:VX|windows/other\\ windows.htm windows/index\\ of\\ windows.htm vti_nexttolasttimemodified:TR|28 Feb 2002 08:25:19 -0000 vti_lineageid:SR|{7E20B89E-2670-11D6-A527-525400EA266C} vti_filesize:IR|5419 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:28 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|index34.gif S|index112.gif S|index142.gif S|index113.gif S|index143.gif S|CFOBulletTypeWnd.gif S|../dialog/bullet.gif K|Other\\ Windows.htm S|../arrows/images/index\\ 2.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/index34.gif FSUS|Windows/index112.gif FSUS|Windows/index142.gif FSUS|Windows/index113.gif FSUS|Windows/index143.gif FSUS|Windows/CFOBulletTypeWnd.gif FSUS|dialog/bullet.gif FKUS|Windows/Other\\ Windows.htm FSUS|arrows/images/index\\ 2.gif vti_cachedtitle:SR|窗体类 vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:28 -0000 vti_extenderversion:SR|4.0.2.3406 vti_filesize:IR|3717 vti_title:SR|Brush vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_nexttolasttimemodified:TR|28 Feb 2002 03:35:05 -0000 vti_author:SR|Administrator vti_timecreated:TR|23 Feb 2002 03:46:10 -0000 vti_cacheddtm:TX|02 Mar 2002 02:07:28 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Brush2.gif S|Brush1.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/Brush2.gif FSUS|Windows/Brush1.gif vti_cachedtitle:SR|Brush vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:28 -0000 vti_extenderversion:SR|4.0.2.3406 vti_filesize:IR|3788 vti_title:SR|Select Gradient Type vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_nexttolasttimemodified:TR|28 Feb 2002 03:38:23 -0000 vti_author:SR|Administrator vti_timecreated:TR|23 Feb 2002 03:50:11 -0000 vti_cacheddtm:TX|02 Mar 2002 02:07:28 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Brush3.gif S|Brush4.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/Brush3.gif FSUS|Windows/Brush4.gif vti_cachedtitle:SR|Select Gradient Type vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|02 Mar 2002 02:07:28 -0000 vti_extenderversion:SR|4.0.2.3406 vti_filesize:IR|3762 vti_title:SR|Select Image Type vti_metatags:VR|HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_nexttolasttimemodified:TR|28 Feb 2002 03:45:36 -0000 vti_author:SR|Administrator vti_timecreated:TR|23 Feb 2002 03:53:04 -0000 vti_cacheddtm:TX|02 Mar 2002 02:07:28 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|Brush5.gif S|Brush6.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/Brush5.gif FSUS|Windows/Brush6.gif vti_cachedtitle:SR|Select Image Type vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false


vti_encoding:SR|utf8-nl vti_author:SR|Administrator vti_timecreated:TR|01 Dec 2001 03:23:55 -0000 vti_timelastmodified:TR|02 Mar 2002 02:07:28 -0000 vti_title:SR|s vti_extenderversion:SR|4.0.2.3406 vti_nexttolasttimemodified:TR|28 Feb 2002 08:19:38 -0000 vti_parentlineageid:SR|{5939FB36-272E-11D6-A528-525400EA266C} vti_lineageid:SR|{5939FB43-272E-11D6-A528-525400EA266C} vti_backlinkinfo:VX|windows/index\\ of\\ windows.htm vti_filesize:IR|12207 vti_metatags:VR|HTTP-EQUIV=Content-Language zh-cn HTTP-EQUIV=Content-Type text/html;\\ charset=gb2312 GENERATOR Microsoft\\ FrontPage\\ 4.0 ProgId FrontPage.Editor.Document vti_charset:SR|gb2312 vti_language:SR|zh-cn vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 4.0 vti_cacheddtm:TX|02 Mar 2002 02:07:28 -0000 vti_cachedlinkinfo:VX|I|../_private/top.htm -H|../main.htm -H|http://www.ucancode.net -H|http://www.ucancode.net -H|mailto:support@163.net S|toolbxwnd.gif S|toolboxhds.gif S|toolboxw.gif S|tbar.gif vti_cachedsvcrellinks:VX|FIUS|_private/top.htm FSUS|Windows/toolbxwnd.gif FSUS|Windows/toolboxhds.gif FSUS|Windows/toolboxw.gif FSUS|Windows/tbar.gif vti_cachedtitle:SR|s vti_cachedbodystyle:SR| vti_cachedhasbots:BR|true vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false